aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2017-08-10 03:30:58 +0800
committerzeising <zeising@FreeBSD.org>2017-08-10 03:30:58 +0800
commit3f34edee6223b5d84b85a13760a9f7baedba057a (patch)
treecfee6695508a753e5f42c4f4fc8633b1919680dd /mail
parentb466e5df4711f7dd12327d61e5ce85f922b3609e (diff)
downloadfreebsd-ports-gnome-3f34edee6223b5d84b85a13760a9f7baedba057a.tar.gz
freebsd-ports-gnome-3f34edee6223b5d84b85a13760a9f7baedba057a.tar.zst
freebsd-ports-gnome-3f34edee6223b5d84b85a13760a9f7baedba057a.zip
Fix runtime on recent perl versions and change default options
Add a patch from upstream to fix runtime when using perl 5.26 or later. [0] Change default options to include DKIM and SPF checking. Bump portrevision. PR: 220474 (based on) [0] Reported by: Trond.Endrestol@ximalas.info [0]
Diffstat (limited to 'mail')
-rw-r--r--mail/spamassassin/Makefile4
-rw-r--r--mail/spamassassin/files/patch-bug740423
2 files changed, 25 insertions, 2 deletions
diff --git a/mail/spamassassin/Makefile b/mail/spamassassin/Makefile
index 0b4db73bd88a..dcb7d756a695 100644
--- a/mail/spamassassin/Makefile
+++ b/mail/spamassassin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spamassassin
PORTVERSION= 3.4.1
-PORTREVISION?= 10 # also bump japanese/spamassassin
+PORTREVISION?= 11 # also bump japanese/spamassassin
CATEGORIES?= mail perl5
MASTER_SITES= APACHE/spamassassin/source CPAN/Mail
DISTNAME= Mail-SpamAssassin-${PORTVERSION}
@@ -55,7 +55,7 @@ OPTIONS_GROUP_DATABASE= MYSQL PGSQL
OPTIONS_GROUP_PLUGINS= DCC DKIM PYZOR RAZOR RELAY_COUNTRY SPF_QUERY
OPTIONS_SINGLE= GPG
OPTIONS_SINGLE_GPG= GNUPG_NONE GNUPG GNUPG2
-OPTIONS_DEFAULT= AS_ROOT GNUPG SSL UPDATE_AND_COMPILE
+OPTIONS_DEFAULT= AS_ROOT DKIM GNUPG SSL UPDATE_AND_COMPILE SPF_QUERY
AS_ROOT_DESC= Run spamd as root (recommended)
diff --git a/mail/spamassassin/files/patch-bug7404 b/mail/spamassassin/files/patch-bug7404
new file mode 100644
index 000000000000..b370d6e0b80f
--- /dev/null
+++ b/mail/spamassassin/files/patch-bug7404
@@ -0,0 +1,23 @@
+--- lib/Mail/SpamAssassin/PerMsgStatus.pm
++++ lib/Mail/SpamAssassin/PerMsgStatus.pm
+@@ -916,16 +916,16 @@
+ $str .= shift @{$ary};
+ }
+ undef $ary;
+- chomp ($str); $str .= " [...]\n";
+
+ # in case the last line was huge, trim it back to around 200 chars
+ local $1;
+- $str =~ s/^(.{,200}).*$/$1/gs;
++ $str =~ s/^(.{200}).+$/$1 [...]/gm;
++ chomp ($str); $str .= "\n";
+
+ # now, some tidy-ups that make things look a bit prettier
+- $str =~ s/-----Original Message-----.*$//gs;
++ $str =~ s/-----Original Message-----.*$//gm;
+ $str =~ s/This is a multi-part message in MIME format\.//gs;
+- $str =~ s/[-_\*\.]{10,}//gs;
++ $str =~ s/[-_*.]{10,}//gs;
+ $str =~ s/\s+/ /gs;
+
+ # add "Content preview:" ourselves, so that the text aligns