aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorfluffy <fluffy@FreeBSD.org>2017-03-07 16:04:16 +0800
committerfluffy <fluffy@FreeBSD.org>2017-03-07 16:04:16 +0800
commit5ef98e234341eeff34efb77777019eef752aca52 (patch)
treee05f0802a8cc761f993fbd5f6a248597d6c97719 /mail
parentaebc0ea7e43b84344c92910279fa9514551140a6 (diff)
downloadfreebsd-ports-gnome-5ef98e234341eeff34efb77777019eef752aca52.tar.gz
freebsd-ports-gnome-5ef98e234341eeff34efb77777019eef752aca52.tar.zst
freebsd-ports-gnome-5ef98e234341eeff34efb77777019eef752aca52.zip
- Update VExim to 2.3 release
- Use GitHub source - Add extrapatch to imply userslist sort order behavior by locapart instead of realname - Pet portlint - Take maintainership PR: 217518 Submitted by: fluffy (myself) Approved by: feld (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/vexim/Makefile44
-rw-r--r--mail/vexim/distinfo5
-rw-r--r--mail/vexim/files/extrapatch-order42
-rw-r--r--mail/vexim/files/pkg-message.in2
-rw-r--r--mail/vexim/pkg-plist173
5 files changed, 158 insertions, 108 deletions
diff --git a/mail/vexim/Makefile b/mail/vexim/Makefile
index 7f21f4c1adef..244524e649a6 100644
--- a/mail/vexim/Makefile
+++ b/mail/vexim/Makefile
@@ -2,56 +2,58 @@
# $FreeBSD$
PORTNAME= vexim
-DISTVERSION= 2.2.2_rc1
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.3
CATEGORIES= mail www
-MASTER_SITES= LOCAL/feld
-DISTNAME= ${PORTNAME}_${DISTVERSION}
-MAINTAINER= feld@FreeBSD.org
+MAINTAINER= fluffy@FreeBSD.org
COMMENT= Web interface for managing virtual domains for exim
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${LOCALBASE}/share/pear/DB.php:databases/pear-DB
-
-VEXIMDIR= www/${PORTNAME}
-WRKSRC= ${WRKDIR}/vexim-release
+USE_GITHUB= yes
+GH_ACCOUNT= ${PORTNAME}
+GH_PROJECT= ${PORTNAME}2
SUB_FILES= pkg-message
+NO_ARCH= yes
NO_BUILD= yes
USE_PHP= gettext session posix
-USES= gettext
-IGNORE_WITH_PHP= 70
+USES= gettext php
OPTIONS_MULTI= DB
OPTIONS_MULTI_DB= MYSQL PGSQL
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS ORDER
OPTIONS_DEFAULT= MYSQL
+ORDER_DESC= Sort userlist by localpart istead of realname
+ORDER_EXTRA_PATCHES= ${FILESDIR}/extrapatch-order
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-USE_PHP+= mysql
+USES+= mysql
+USE_PHP+= pdo_mysql
.endif
.if ${PORT_OPTIONS:MPGSQL}
USES+= pgsql
-USE_PHP+= pgsql
+USE_PHP+= pdo_pgsql
.endif
+.if ${PORT_OPTIONS:MORDER}
post-patch:
- ${RM} -r ${WRKSRC}/.hg ${WRKSRC}/.hgtags ${WRKSRC}/vexim/adminuserchange.phps
- ${MV} ${WRKSRC}/vexim/config/variables.php ${WRKSRC}/vexim/config/variables.php.dist
+ ${RM} -rv ${WRKSRC}/vexim/*.orig
+.endif
do-install:
- @${ECHO} "Installing in ${VEXIMDIR}"
- ${MKDIR} ${STAGEDIR}${PREFIX}/${VEXIMDIR}
+ @${ECHO} "Installing in ${WWWDIR}:"
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
cd ${WRKSRC}/vexim && ${FIND} . \
- -type d -exec ${MKDIR} ${STAGEDIR}${PREFIX}/${VEXIMDIR}/{} \; \
+ -type d -exec ${MKDIR} ${STAGEDIR}${WWWDIR}/{} \; \
-o -type f \
- -exec ${INSTALL_DATA} {} ${STAGEDIR}${PREFIX}/${VEXIMDIR}/{} \;
+ -exec ${INSTALL_DATA} {} ${STAGEDIR}${WWWDIR}/{} \;
${MKDIR} ${STAGEDIR}${DATADIR}
cd ${WRKSRC}/setup && ${FIND} . \
-type d -exec ${MKDIR} ${STAGEDIR}${DATADIR}/{} \; \
@@ -63,7 +65,7 @@ do-install:
-type d -exec ${MKDIR} ${STAGEDIR}${DOCSDIR}/{} \; \
-o -type f \
-exec ${INSTALL_DATA} {} ${STAGEDIR}${DOCSDIR}/{} \;
-.for i in INSTALL README TODO
+.for i in README.md TODO
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
diff --git a/mail/vexim/distinfo b/mail/vexim/distinfo
index 4f56dbcb779d..f6086f648f15 100644
--- a/mail/vexim/distinfo
+++ b/mail/vexim/distinfo
@@ -1,2 +1,3 @@
-SHA256 (vexim_2.2.2_rc1.tar.gz) = cb0d47e3e3e3b53545ad5c959d6acae13f17604550779bc1d01621e65c85a507
-SIZE (vexim_2.2.2_rc1.tar.gz) = 290286
+TIMESTAMP = 1488538725
+SHA256 (vexim-vexim2-v2.3_GH0.tar.gz) = 67fa6c5dbc7a5ab2a4babc9b7707b3595c5d219d51c57d6f81a37ed56b46155a
+SIZE (vexim-vexim2-v2.3_GH0.tar.gz) = 137225
diff --git a/mail/vexim/files/extrapatch-order b/mail/vexim/files/extrapatch-order
new file mode 100644
index 000000000000..2524751254d7
--- /dev/null
+++ b/mail/vexim/files/extrapatch-order
@@ -0,0 +1,42 @@
+--- ./vexim/admingroupchange.php.orig 2016-08-17 21:00:21.000000000 +1000
++++ ./vexim/admingroupchange.php 2017-03-07 17:12:43.849900000 +1000
+@@ -145,7 +145,7 @@
+ <?php
+ $query = "SELECT realname, localpart, user_id FROM users
+ WHERE enabled='1' AND domain_id=:domain_id AND type!='fail'
+- ORDER BY realname, username, type desc";
++ ORDER BY username, realname, type desc";
+ $sth = $dbh->prepare($query);
+ $sth->execute(array(':domain_id'=>$_SESSION['domain_id']));
+ while ($row = $sth->fetch()) {
+--- ./vexim/adminuser.php 2016-08-17 21:00:21.000000000 +1000
++++ ./vexim/adminuser.php 2017-03-05 20:21:00.000000000 +1000
+@@ -83,7 +83,7 @@
+ $query .= ' AND ' . $dbh->quote($_POST['field']) . ' LIKE :searchfor"%';
+ $queryParams[':searchfor'] = '%'.$_POST['searchfor'].'%';
+ }
+- $query .= ' ORDER BY realname, localpart';
++ $query .= ' ORDER BY !admin, localpart, realname';
+ $sth = $dbh->prepare($query);
+ $sth->execute($queryParams);
+ while ($row = $sth->fetch()) {
+--- ./vexim/adminuserchange.php.orig 2016-08-17 21:00:21.000000000 +1000
++++ ./vexim/adminuserchange.php 2017-03-07 17:13:39.572382000 +1000
+@@ -301,7 +301,7 @@
+ $queryuserlist = "SELECT realname, username, user_id, unseen
+ FROM users
+ WHERE enabled='1' AND domain_id=:domain_id AND type != 'fail'
+- ORDER BY realname, username, type desc";
++ ORDER BY username, realname, type desc";
+ $sthuserlist = $dbh->prepare($queryuserlist);
+ $sthuserlist->execute(array(':domain_id'=>$_SESSION['domain_id']));
+ while ($rowuserlist = $sthuserlist->fetch()) {
+@@ -338,7 +338,7 @@
+ <?php
+ # Print the aliases associated with this account
+ $query = "SELECT user_id,localpart,domain,realname FROM users,domains
+- WHERE smtp=:smtp AND users.domain_id=domains.domain_id ORDER BY realname";
++ WHERE smtp=:smtp AND users.domain_id=domains.domain_id ORDER BY localpart";
+ $sth = $dbh->prepare($query);
+ $sth->execute(array(':smtp'=>$row['localpart'].'@'.$_SESSION['domain']));
+ if ($sth->rowCount()) {
diff --git a/mail/vexim/files/pkg-message.in b/mail/vexim/files/pkg-message.in
index 3f82bd409067..6c9479d99cc9 100644
--- a/mail/vexim/files/pkg-message.in
+++ b/mail/vexim/files/pkg-message.in
@@ -1,6 +1,6 @@
------------------------------------------------------------------------
For post-install configuration steps, please read
- %%PREFIX%%/share/doc/vexim/INSTALL
+ %%DOCSDIR%%/README.md
------------------------------------------------------------------------
diff --git a/mail/vexim/pkg-plist b/mail/vexim/pkg-plist
index 75e0f5660ff0..304653be9d6b 100644
--- a/mail/vexim/pkg-plist
+++ b/mail/vexim/pkg-plist
@@ -1,90 +1,95 @@
-%%DATADIR%%/pgsql.sql
+%%DATADIR%%/migrations/vexim_1.3_to_1.5_mysql.sql
+%%DATADIR%%/migrations/vexim_1.5_to_2.0.1_mysql.sql
+%%DATADIR%%/migrations/vexim_2.0.1_to_2.2_mysql.sql
+%%DATADIR%%/migrations/vexim_2.2_to_2.3_mysql.sql
%%DATADIR%%/mysql.sql
-%%DATADIR%%/create_db.pl
-%%PORTDOCS%%%%DOCSDIR%%/docs/clients/cyrus.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/clients/freebsd-courierimap.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/clients/mysql-popper.conf
-%%PORTDOCS%%%%DOCSDIR%%/docs/clients/qpop-mysql.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/clients/freebsd-tpop3d.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/vexim-acl-check-content.conf
-%%PORTDOCS%%%%DOCSDIR%%/docs/database-spec.txt
+%%DATADIR%%/pgsql.sql
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/docs/clients/courierimap.txt
+%%PORTDOCS%%%%DOCSDIR%%/docs/clients/dovecot.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/checklist.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/configure
+%%PORTDOCS%%%%DOCSDIR%%/docs/debian-conf.d/auth/30_vexim_authenticators
+%%PORTDOCS%%%%DOCSDIR%%/docs/debian-conf.d/main/00_vexim_listmacrosdefs
+%%PORTDOCS%%%%DOCSDIR%%/docs/debian-conf.d/router/249_vexim_ditch_routers
+%%PORTDOCS%%%%DOCSDIR%%/docs/debian-conf.d/router/250_vexim_virtual_domains
+%%PORTDOCS%%%%DOCSDIR%%/docs/debian-conf.d/transport/30_vexim_virtual_delivery
+%%PORTDOCS%%%%DOCSDIR%%/docs/debian-conf.d/transport/30_vexim_virtual_ditch_spam_transport
+%%PORTDOCS%%%%DOCSDIR%%/docs/debian-conf.d/transport/30_vexim_virtual_vacation_delivery
+%%PORTDOCS%%%%DOCSDIR%%/docs/vexim-acl-check-content.conf
%%PORTDOCS%%%%DOCSDIR%%/docs/vexim-acl-check-helo.conf
%%PORTDOCS%%%%DOCSDIR%%/docs/vexim-acl-check-rcpt.conf
-%%PORTDOCS%%%%DOCSDIR%%/docs/vexim-acl-check-spf.conf
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/docs/vexim-group-router.conf
%%PORTDOCS%%%%DOCSDIR%%/docs/vexim-group.txt
-www/vexim/admin.php
-www/vexim/adminalias.php
-www/vexim/adminaliasadd.php
-www/vexim/adminaliasaddsubmit.php
-www/vexim/adminaliaschange.php
-www/vexim/adminaliaschangesubmit.php
-www/vexim/adminaliasdelete.php
-www/vexim/admincatchall.php
-www/vexim/admincatchalladd.php
-www/vexim/admincatchallsubmit.php
-www/vexim/adminfail.php
-www/vexim/adminfailadd.php
-www/vexim/adminfailaddsubmit.php
-www/vexim/adminfailchange.php
-www/vexim/adminfailchangesubmit.php
-www/vexim/adminfaildelete.php
-www/vexim/admingroup.php
-www/vexim/admingroupadd.php
-www/vexim/admingroupaddsubmit.php
-www/vexim/admingroupchange.php
-www/vexim/admingroupchangesubmit.php
-www/vexim/admingroupcontentaddsubmit.php
-www/vexim/admingroupcontentdeletesubmit.php
-www/vexim/admingroupdelete.php
-www/vexim/adminlists.php
-www/vexim/adminuser.php
-www/vexim/adminuseradd.php
-www/vexim/adminuseraddsubmit.php
-www/vexim/adminuserblocksubmit.php
-www/vexim/adminuserchange.php
-www/vexim/adminuserchangesubmit.php
-www/vexim/adminuserdelete.php
-www/vexim/config/authpostmaster.php
-www/vexim/config/authsite.php
-www/vexim/config/authuser.php
-www/vexim/config/en.po
-www/vexim/config/functions.php
-www/vexim/config/header.php
-www/vexim/config/httpheaders.php
-www/vexim/config/hu.po
-www/vexim/config/i18n.php
-www/vexim/config/template.pot
-www/vexim/config/variables.php.dist
-www/vexim/images/check.gif
-www/vexim/images/trashcan.gif
-www/vexim/index.php
-www/vexim/locale/de_DE/LC_MESSAGES/de.po
-www/vexim/locale/de_DE/LC_MESSAGES/messages.mo
-www/vexim/locale/en_EN/LC_MESSAGES/en.po
-www/vexim/locale/en_EN/LC_MESSAGES/messages.mo
-www/vexim/locale/es_ES/LC_MESSAGES/es.po
-www/vexim/locale/es_ES/LC_MESSAGES/messages.mo
-www/vexim/locale/hu_HU/LC_MESSAGES/hu.po
-www/vexim/locale/hu_HU/LC_MESSAGES/messages.mo
-www/vexim/locale/ro_RO/LC_MESSAGES/messages.mo
-www/vexim/locale/ro_RO/LC_MESSAGES/ro.po
-www/vexim/login.php
-www/vexim/logout.php
-www/vexim/site.php
-www/vexim/siteadd.php
-www/vexim/siteaddsubmit.php
-www/vexim/sitechange.php
-www/vexim/sitechangesubmit.php
-www/vexim/sitedelete.php
-www/vexim/sitepassword.php
-www/vexim/sitepasswordsubmit.php
-www/vexim/style.css
-www/vexim/userblocksubmit.php
-www/vexim/userchange.php
-www/vexim/userchangesubmit.php
+%%WWWDIR%%/admin.php
+%%WWWDIR%%/adminalias.php
+%%WWWDIR%%/adminaliasadd.php
+%%WWWDIR%%/adminaliasaddsubmit.php
+%%WWWDIR%%/adminaliaschange.php
+%%WWWDIR%%/adminaliaschangesubmit.php
+%%WWWDIR%%/adminaliasdelete.php
+%%WWWDIR%%/admincatchall.php
+%%WWWDIR%%/admincatchalladd.php
+%%WWWDIR%%/admincatchallsubmit.php
+%%WWWDIR%%/adminfail.php
+%%WWWDIR%%/adminfailadd.php
+%%WWWDIR%%/adminfailaddsubmit.php
+%%WWWDIR%%/adminfailchange.php
+%%WWWDIR%%/adminfailchangesubmit.php
+%%WWWDIR%%/adminfaildelete.php
+%%WWWDIR%%/admingroup.php
+%%WWWDIR%%/admingroupadd.php
+%%WWWDIR%%/admingroupaddsubmit.php
+%%WWWDIR%%/admingroupchange.php
+%%WWWDIR%%/admingroupchangesubmit.php
+%%WWWDIR%%/admingroupcontentaddsubmit.php
+%%WWWDIR%%/admingroupcontentdeletesubmit.php
+%%WWWDIR%%/admingroupdelete.php
+%%WWWDIR%%/adminlists.php
+%%WWWDIR%%/adminuser.php
+%%WWWDIR%%/adminuseradd.php
+%%WWWDIR%%/adminuseraddsubmit.php
+%%WWWDIR%%/adminuserblocksubmit.php
+%%WWWDIR%%/adminuserchange.php
+%%WWWDIR%%/adminuserchangesubmit.php
+%%WWWDIR%%/adminuserdelete.php
+%%WWWDIR%%/config/Tests/functionsValidatePasswordTest.php
+%%WWWDIR%%/config/authpostmaster.php
+%%WWWDIR%%/config/authsite.php
+%%WWWDIR%%/config/authuser.php
+%%WWWDIR%%/config/functions.php
+%%WWWDIR%%/config/header.php
+%%WWWDIR%%/config/httpheaders.php
+%%WWWDIR%%/config/i18n.php
+%%WWWDIR%%/config/variables.php.example
+%%WWWDIR%%/images/check.gif
+%%WWWDIR%%/images/trashcan.gif
+%%WWWDIR%%/index.php
+%%WWWDIR%%/locale/de/LC_MESSAGES/de.po
+%%WWWDIR%%/locale/de/LC_MESSAGES/messages.mo
+%%WWWDIR%%/locale/es/LC_MESSAGES/es.po
+%%WWWDIR%%/locale/es/LC_MESSAGES/messages.mo
+%%WWWDIR%%/locale/hu/LC_MESSAGES/hu.po
+%%WWWDIR%%/locale/hu/LC_MESSAGES/messages.mo
+%%WWWDIR%%/locale/it/LC_MESSAGES/it.po
+%%WWWDIR%%/locale/it/LC_MESSAGES/messages.mo
+%%WWWDIR%%/locale/ro/LC_MESSAGES/messages.mo
+%%WWWDIR%%/locale/ro/LC_MESSAGES/ro.po
+%%WWWDIR%%/locale/ru/LC_MESSAGES/ru.po
+%%WWWDIR%%/locale/ru/LC_MESSAGES/messages.mo
+%%WWWDIR%%/locale/template.pot
+%%WWWDIR%%/login.php
+%%WWWDIR%%/logout.php
+%%WWWDIR%%/scripts.js
+%%WWWDIR%%/site.php
+%%WWWDIR%%/siteadd.php
+%%WWWDIR%%/siteaddsubmit.php
+%%WWWDIR%%/sitechange.php
+%%WWWDIR%%/sitechangesubmit.php
+%%WWWDIR%%/sitedelete.php
+%%WWWDIR%%/sitepassword.php
+%%WWWDIR%%/sitepasswordsubmit.php
+%%WWWDIR%%/style.css
+%%WWWDIR%%/userblocksubmit.php
+%%WWWDIR%%/userchange.php
+%%WWWDIR%%/userchangesubmit.php