aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-04-08 03:09:33 +0800
committerdinoex <dinoex@FreeBSD.org>2003-04-08 03:09:33 +0800
commitada8a961de8a844e102e98c4531f8ce8fd9aa3b2 (patch)
tree32f1b3ab4907112979c3dffd1bc29cf5fdd64c58 /mail
parentf986b44bc63f813bfd4c89ef0881f639a864cbd7 (diff)
downloadfreebsd-ports-gnome-ada8a961de8a844e102e98c4531f8ce8fd9aa3b2.tar.gz
freebsd-ports-gnome-ada8a961de8a844e102e98c4531f8ce8fd9aa3b2.tar.zst
freebsd-ports-gnome-ada8a961de8a844e102e98c4531f8ce8fd9aa3b2.zip
This is a simple sendmail milter which adds an X-RBL-Warning header to
any emails that are received that come from an open relay as determined by your choice of RBL checking service (i.e. bl.spamcop.net). This is useful if you'd rather have the mail user agent (MUA) deal with potential spam rather than just blocking it in case you loose legitimate messages. Note that the X-RBL-Warning header is only set if the site was found to be an open-relay. For more information, see the rbl-milter website at: WWW: http://opensource.confusticate.com/rbl-milter/ RBL-Milter was created by Jeremy Beker <gothmog@confusticate.com> and the port is maintained by Ned Wolpert <wolpert@codeheadsystems.com> PR: 45605 Submitted by: wolpert@codeheadsystems.com
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/rbl-milter/Makefile35
-rw-r--r--mail/rbl-milter/distinfo1
-rw-r--r--mail/rbl-milter/files/patch-aa19
-rw-r--r--mail/rbl-milter/files/rbl-milter.sh.in28
-rw-r--r--mail/rbl-milter/pkg-descr14
-rw-r--r--mail/rbl-milter/pkg-message25
-rw-r--r--mail/rbl-milter/pkg-plist2
8 files changed, 125 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index a45c23b21a1b..00ec9e1338fe 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -242,6 +242,7 @@
SUBDIR += queue-repair
SUBDIR += raysfilter
SUBDIR += razor-agents
+ SUBDIR += rbl-milter
SUBDIR += rblcheck
SUBDIR += regm
SUBDIR += rftp
diff --git a/mail/rbl-milter/Makefile b/mail/rbl-milter/Makefile
new file mode 100644
index 000000000000..f59fd883fbad
--- /dev/null
+++ b/mail/rbl-milter/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: rbl-milter
+# Date created: 15 November 2002
+# Whom: wolpert
+#
+# $FreeBSD$
+#
+
+PORTNAME= rbl-milter
+PORTVERSION= 0.30
+CATEGORIES= mail
+MASTER_SITES= http://opensource.confusticate.com/rbl-milter/
+
+MAINTAINER= wolpert@codeheadsystems.com
+COMMENT= A milter that adds mail header warnings on mail from open-relays
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+CONFIGURE_ARGS= --with-sendmail=/usr \
+ --with-sendmail-obj=/usr/lib
+
+.if defined(NO_WERROR)
+pre-configure:
+ @${CP} ${WRKSRC}/configure ${WRKSRC}/configure.sed
+ @${SED} 's!-Werror!!' ${WRKSRC}/configure.sed >${WRKSRC}/configure
+.endif
+
+post-install:
+ @${SED} 's|%%PREFIX%%|${PREFIX}|g' \
+ ${FILESDIR}/rbl-milter.sh.in > ${WRKDIR}/rbl-milter.sh
+ ${INSTALL_SCRIPT} ${WRKDIR}/rbl-milter.sh \
+ ${PREFIX}/etc/rc.d/rbl-milter.sh
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/rbl-milter/distinfo b/mail/rbl-milter/distinfo
new file mode 100644
index 000000000000..cfa0d0d4701d
--- /dev/null
+++ b/mail/rbl-milter/distinfo
@@ -0,0 +1 @@
+MD5 (rbl-milter-0.30.tar.gz) = 349a080780bbe2a79ee39b2e417c0d10
diff --git a/mail/rbl-milter/files/patch-aa b/mail/rbl-milter/files/patch-aa
new file mode 100644
index 000000000000..c2d886cf2a8d
--- /dev/null
+++ b/mail/rbl-milter/files/patch-aa
@@ -0,0 +1,19 @@
+*** configure.old Fri Nov 22 06:30:28 2002
+--- configure Fri Nov 22 06:30:25 2002
+***************
+*** 1230,1236 ****
+
+ LDFLAGS="$LDFLAGS -L$SENDMAIL_OBJ/libmilter -L$SENDMAIL_OBJ/libsm -L$SENDMAIL_OBJ/libsmutil -L$SENDMAIL_OBJ/lib";
+ CFLAGS="$CFLAGS -Wall -Werror"
+! LIBS="$LIBS -pthread -lpthread"
+
+
+ echo $ac_n "checking for socket in -lsocket""... $ac_c" 1>&6
+--- 1230,1236 ----
+
+ LDFLAGS="$LDFLAGS -L$SENDMAIL_OBJ/libmilter -L$SENDMAIL_OBJ/libsm -L$SENDMAIL_OBJ/libsmutil -L$SENDMAIL_OBJ/lib";
+ CFLAGS="$CFLAGS -Wall -Werror"
+! LIBS="$LIBS -pthread -lc_r"
+
+
+ echo $ac_n "checking for socket in -lsocket""... $ac_c" 1>&6
diff --git a/mail/rbl-milter/files/rbl-milter.sh.in b/mail/rbl-milter/files/rbl-milter.sh.in
new file mode 100644
index 000000000000..2f540d3c7f5c
--- /dev/null
+++ b/mail/rbl-milter/files/rbl-milter.sh.in
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+if [ ! -f %%PREFIX%%/sbin/rbl-milter ]
+then
+ echo "rbl-milter not installed"
+ exit 0;
+fi
+
+case $1 in
+start)
+ %%PREFIX%%/sbin/rbl-milter -l -r -p local:/var/run/rbl-milter -d relays.ordb.org \
+ && echo -n " rbl-milter" \
+ || echo " rbl-milter FAILED TO START"
+ ;;
+stop)
+ killall rbl-milter && echo -n " rbl-milter"
+ ;;
+restart)
+ $0 stop
+ $0 start
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ exit 64
+ ;;
+esac
+
+exit 0
diff --git a/mail/rbl-milter/pkg-descr b/mail/rbl-milter/pkg-descr
new file mode 100644
index 000000000000..be41413cc1c7
--- /dev/null
+++ b/mail/rbl-milter/pkg-descr
@@ -0,0 +1,14 @@
+This is a simple sendmail milter which adds an X-RBL-Warning header to
+any Xemails that are received that come from an open relay as
+determined by your Xchoice of RBL checking service (i.e.
+bl.spamcop.net).
+
+This is useful if you'd rather have the mail user agent (MUA) deal with
+ Xpotential spam rather than just blocking it in case you loose
+legitimate Xmessages. Note that the X-RBL-Warning header is only set if
+the site was Xfound to be an open-relay.
+
+For more information, see the rbl-milter website at:
+ WWW: http://opensource.confusticate.com/rbl-milter/
+RBL-Milter was created by Jeremy Beker <gothmog@confusticate.com> and
+the Xport is maintained by Ned Wolpert <wolpert@codeheadsystems.com>
diff --git a/mail/rbl-milter/pkg-message b/mail/rbl-milter/pkg-message
new file mode 100644
index 000000000000..c2ee36d516d6
--- /dev/null
+++ b/mail/rbl-milter/pkg-message
@@ -0,0 +1,25 @@
+The start/stop script has been placed in $PREFIX/etc/rc.d/rbl-milter.sh
+ XRun the program now with the start command to get rbl-milter running.
+By Xdefault, it uses the relays found at relays.ordb.org but you can
+change that Xby modifying the script. It accepts multiple -d commands
+for multiple Xsite checks.
+
+Note that you will need to edit the proper sendmail.mc file in your
+/etc/mail Xdirectory so that sendmail will pass mail to rbl-milter. If
+you have not Xdone this before, do the following:
+
+ cd /etc/mail
+ cp -p freebsd.mc `hostname`.mc
+
+Add the INPUT_MAIL_FILTER line to the file:
+
+ INPUT_MAIL_FILTER(`rbl-milter',`S=local:/var/run/rbl-milter')
+
+and rebuild it
+
+ make
+ make install
+ make restart
+
+By default, the INPUT_MAIL_FILTER line will ignore the filter if
+rbl-milter Xis not running.
diff --git a/mail/rbl-milter/pkg-plist b/mail/rbl-milter/pkg-plist
new file mode 100644
index 000000000000..89d41446f33a
--- /dev/null
+++ b/mail/rbl-milter/pkg-plist
@@ -0,0 +1,2 @@
+sbin/rbl-milter
+etc/rc.d/rbl-milter.sh