aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2012-06-29 18:05:08 +0800
committeraz <az@FreeBSD.org>2012-06-29 18:05:08 +0800
commitb696f60de705575cfdc752261066bafcfd998615 (patch)
treeb98bbf33a5bfac7f3b65291d5b3455e9aa792250 /mail
parent9a292c3f202221efed7d813d68c49503c5f7cddb (diff)
downloadfreebsd-ports-gnome-b696f60de705575cfdc752261066bafcfd998615.tar.gz
freebsd-ports-gnome-b696f60de705575cfdc752261066bafcfd998615.tar.zst
freebsd-ports-gnome-b696f60de705575cfdc752261066bafcfd998615.zip
- Remove SITE_PERL from *_DEPENDS
Approved by: portmgr@ (bapt@)
Diffstat (limited to 'mail')
-rw-r--r--mail/gotmail/Makefile4
-rw-r--r--mail/majordomo/Makefile4
-rw-r--r--mail/pronto/Makefile22
-rw-r--r--mail/tlb/Makefile6
4 files changed, 18 insertions, 18 deletions
diff --git a/mail/gotmail/Makefile b/mail/gotmail/Makefile
index 1853b35bfd37..42f58f2cd495 100644
--- a/mail/gotmail/Makefile
+++ b/mail/gotmail/Makefile
@@ -15,8 +15,8 @@ MAINTAINER= araujo@FreeBSD.org
COMMENT= A script to fetch mail from a Hotmail or MSN mailbox
RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/Net/libnet.cfg:${PORTSDIR}/net/p5-Net
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-Net>=0:${PORTSDIR}/net/p5-Net
MAN1= ${PORTNAME}.1
USE_PERL5= yes
diff --git a/mail/majordomo/Makefile b/mail/majordomo/Makefile
index 1b05d4299905..286f20e54fab 100644
--- a/mail/majordomo/Makefile
+++ b/mail/majordomo/Makefile
@@ -18,7 +18,7 @@ MAINTAINER= anders@FreeBSD.org
COMMENT= A mailing list manager
.if defined(WITH_SHA1_COOKIES)
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+RUN_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1
.endif
USE_PERL5= yes
@@ -35,7 +35,7 @@ DOCSDIR= ${PREFIX}/${PORTNAME}/doc
.if !defined(WITH_SHA1_COOKIES)
. if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS+= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5
. endif
.endif
diff --git a/mail/pronto/Makefile b/mail/pronto/Makefile
index 51d9abfc2637..f7b5e2caf775 100644
--- a/mail/pronto/Makefile
+++ b/mail/pronto/Makefile
@@ -14,19 +14,19 @@ MAINTAINER= araujo@FreeBSD.org
COMMENT= A Mail Client for Gnome/Gtk written in Perl
BUILD_DEPENDS=\
- ${SITE_PERL}/${PERL_ARCH}/Gtk.pm:${PORTSDIR}/x11-toolkits/p5-Gtk \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/DBD/CSV.pm:${PORTSDIR}/databases/p5-DBD-CSV \
- ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
- ${SITE_PERL}/SQL/Statement.pm:${PORTSDIR}/databases/p5-SQL-Statement \
- ${SITE_PERL}/MIME/Tools.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/MIME/Types.pm:${PORTSDIR}/mail/p5-MIME-Types \
- ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/Lingua/Ispell.pm:${PORTSDIR}/textproc/p5-Lingua-Ispell
+ p5-Gtk>=0:${PORTSDIR}/x11-toolkits/p5-Gtk \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-DBD-CSV>=0:${PORTSDIR}/databases/p5-DBD-CSV \
+ p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
+ p5-SQL-Statement>=0:${PORTSDIR}/databases/p5-SQL-Statement \
+ p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools \
+ p5-MIME-Types>=0:${PORTSDIR}/mail/p5-MIME-Types \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-Lingua-Ispell>=0:${PORTSDIR}/textproc/p5-Lingua-Ispell
.if defined(WITH_MYSQL)
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-Mysql
+BUILD_DEPENDS+= p5-Mysql>=0:${PORTSDIR}/databases/p5-Mysql
.endif
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/mail/tlb/Makefile b/mail/tlb/Makefile
index d6b4bcec7116..db5fd4417451 100644
--- a/mail/tlb/Makefile
+++ b/mail/tlb/Makefile
@@ -16,9 +16,9 @@ EXTRACT_SUFX= .tgz
MAINTAINER= anders@FreeBSD.org
COMMENT= The List Batcher, a general purpose mail list delivery engine
-RUN_DEPENDS= ${SITE_PERL}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools \
- ${SITE_PERL}/Date/Format.pm:${PORTSDIR}/devel/p5-TimeDate \
- ${SITE_PERL}/Net/Domain.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= p5-Mail-Tools>=0:${PORTSDIR}/mail/p5-Mail-Tools \
+ p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
+ p5-Net>=0:${PORTSDIR}/net/p5-Net
NO_BUILD= yes
USE_PERL5= yes