aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2013-12-09 00:53:57 +0800
committeradamw <adamw@FreeBSD.org>2013-12-09 00:53:57 +0800
commitdb3941c57c61310dde13327e9ac1422a4dc50223 (patch)
treea10c7c003855b79bd2d28f4f3d9dbed60cc28f4f /mail
parent3149705e5c86a192a816571b7749986d1069f9cb (diff)
downloadfreebsd-ports-gnome-db3941c57c61310dde13327e9ac1422a4dc50223.tar.gz
freebsd-ports-gnome-db3941c57c61310dde13327e9ac1422a4dc50223.tar.zst
freebsd-ports-gnome-db3941c57c61310dde13327e9ac1422a4dc50223.zip
- Convert remaining plugins to bsd.squirrelmail.mk.
- Change the perl5 dependency to install, which it is - Correct path in pkg-message
Diffstat (limited to 'mail')
-rw-r--r--mail/squirrelmail-compatibility-plugin/Makefile6
-rw-r--r--mail/squirrelmail-multilogin-plugin/Makefile65
-rw-r--r--mail/squirrelmail-multilogin-plugin/files/pkg-message.in4
-rw-r--r--mail/squirrelmail-notes-plugin/Makefile78
-rw-r--r--mail/squirrelmail-notes-plugin/files/pkg-message.in4
-rw-r--r--mail/squirrelmail-notify-plugin/Makefile73
-rw-r--r--mail/squirrelmail-quota_usage-plugin/Makefile76
-rw-r--r--mail/squirrelmail-quota_usage-plugin/files/pkg-message.in4
-rw-r--r--mail/squirrelmail-sasql-plugin/Makefile68
-rw-r--r--mail/squirrelmail-sasql-plugin/files/pkg-message.in4
-rw-r--r--mail/squirrelmail-shared_calendars-plugin/Makefile78
-rw-r--r--mail/squirrelmail-shared_calendars-plugin/files/pkg-message.in4
-rw-r--r--mail/squirrelmail-wetteronline-plugin/Makefile74
13 files changed, 90 insertions, 448 deletions
diff --git a/mail/squirrelmail-compatibility-plugin/Makefile b/mail/squirrelmail-compatibility-plugin/Makefile
index 952b40888c00..f68d21f844c9 100644
--- a/mail/squirrelmail-compatibility-plugin/Makefile
+++ b/mail/squirrelmail-compatibility-plugin/Makefile
@@ -14,8 +14,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Required by many plugins for compatibility with SquirrelMail
USES= perl5
-USE_PERL5= run
+USE_PERL5= install
NO_STAGE= yes
+
+.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-multilogin-plugin/Makefile b/mail/squirrelmail-multilogin-plugin/Makefile
index 92e836fd679c..24232f0d1aaf 100644
--- a/mail/squirrelmail-multilogin-plugin/Makefile
+++ b/mail/squirrelmail-multilogin-plugin/Makefile
@@ -13,65 +13,12 @@ DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Allows manual selection of login server on login page
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
- ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
-
-SQUIRREL_PLUGIN_NAME= ${PORTNAME}
-
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-. ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-. else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-. endif
-.endif
-
-SUB_FILES= pkg-message
-
-USES= perl5
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5= build
-USE_PHP= yes
-WANT_PHP_WEB= yes
+USES= perl5
+USE_PERL5= install
+USE_SM_COMPAT= yes
NO_STAGE= yes
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
-
-do-install:
- ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
- cd ${SQUIRRELDIR} && ${PATCH} -p0 < plugins/${SQUIRREL_PLUGIN_NAME}/patches/multilogin-squirrelmail-1.4.12.diff
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
- @${ECHO} ""
- @${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-multilogin-plugin/files/pkg-message.in b/mail/squirrelmail-multilogin-plugin/files/pkg-message.in
index 5a52e022b027..d9df0612aba0 100644
--- a/mail/squirrelmail-multilogin-plugin/files/pkg-message.in
+++ b/mail/squirrelmail-multilogin-plugin/files/pkg-message.in
@@ -1,5 +1,5 @@
For the port to work properly you must copy the file
-%%PREFIX%%/%%SQUIRRELDIR%%/plugins/multilogin/config.sample.php
+%%SQUIRRELDIR%%/plugins/multilogin/config.sample.php
to
-%%PREFIX%%/%%SQUIRRELDIR%%/plugins/multilogin/config.php
+%%SQUIRRELDIR%%/plugins/multilogin/config.php
and edit the configuration to meet your needs.
diff --git a/mail/squirrelmail-notes-plugin/Makefile b/mail/squirrelmail-notes-plugin/Makefile
index 75928f720132..8a83bd989e7b 100644
--- a/mail/squirrelmail-notes-plugin/Makefile
+++ b/mail/squirrelmail-notes-plugin/Makefile
@@ -1,77 +1,25 @@
# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
-PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
-PORTVERSION= 1.2
+PORTNAME= notes
+PORTVERSION= 1.2
PORTREVISION= 1
CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}.${PORTVERSION}-1.4.0
-DIST_SUBDIR= squirrelmail
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
+DISTNAME= ${PORTNAME}.${PORTVERSION}-1.4.0
+DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Allows you to create notes
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
- ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
-
-SQUIRREL_PLUGIN_NAME= notes
-
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-. ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-. else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-. endif
-.endif
-
-SUB_FILES= pkg-message
-
-USES= perl5
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5= build
-USE_PHP= yes
-WANT_PHP_WEB= yes
-IGNORE_WITH_PHP= 5 # known incompatibilities with php-5.4, use 5.3 for now
-DEFAULT_PHP_VER= 53
+USES= perl5
+USE_PERL5= install
+USE_SM_COMPAT= yes
NO_STAGE= yes
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
-
-do-install:
- ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
- @${ECHO} ""
- @${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-notes-plugin/files/pkg-message.in b/mail/squirrelmail-notes-plugin/files/pkg-message.in
index bb53d88b1042..651dbb4c1c81 100644
--- a/mail/squirrelmail-notes-plugin/files/pkg-message.in
+++ b/mail/squirrelmail-notes-plugin/files/pkg-message.in
@@ -1,5 +1,5 @@
For the port to work properly you must copy the file
-%%PREFIX%%/%%SQUIRRELDIR%%/plugins/notes/config.php.sample
+%%SQUIRRELDIR%%/plugins/notes/config.php.sample
to
-%%PREFIX%%/%%SQUIRRELDIR%%/plugins/notes/config.php
+%%SQUIRRELDIR%%/plugins/notes/config.php
and edit the configuration to meet your needs.
diff --git a/mail/squirrelmail-notify-plugin/Makefile b/mail/squirrelmail-notify-plugin/Makefile
index ae71aa1ec814..162d64999126 100644
--- a/mail/squirrelmail-notify-plugin/Makefile
+++ b/mail/squirrelmail-notify-plugin/Makefile
@@ -1,72 +1,25 @@
# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
-PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
-PORTVERSION= 1.3
+PORTNAME= notify
+PORTVERSION= 1.3
PORTREVISION= 1
CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}_${PORTVERSION:S/./_/g}
-DIST_SUBDIR= squirrelmail
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g}
+DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Notify when new mail arrives
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
- ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
-
-SQUIRREL_PLUGIN_NAME= notify
-
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-. ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-. else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-. endif
-.endif
-
-USES= perl5
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5= build
-USE_PHP= yes
-WANT_PHP_WEB= yes
+USES= perl5
+USE_PERL5= install
+USE_SM_COMPAT= yes
NO_STAGE= yes
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
-
-do-install:
- ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
- @${ECHO} ""
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-quota_usage-plugin/Makefile b/mail/squirrelmail-quota_usage-plugin/Makefile
index 758f1ab6f175..6e5ea6ff29a0 100644
--- a/mail/squirrelmail-quota_usage-plugin/Makefile
+++ b/mail/squirrelmail-quota_usage-plugin/Makefile
@@ -1,77 +1,25 @@
# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
-PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
-PORTVERSION= 1.3.1
+PORTNAME= quota_usage
+PORTVERSION= 1.3.1
PORTREVISION= 1
CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}-1.2.7
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1.2.7
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= View quota and current usage
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
- ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
-
-SQUIRREL_PLUGIN_NAME= quota_usage
-
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-. ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-. else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-. endif
-.endif
-
-SUB_FILES= pkg-message
-
-USES= perl5
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5= build
-USE_PHP= yes
-WANT_PHP_WEB= yes
-IGNORE_WITH_PHP= 5 # known incompatibilities with php-5.4, use 5.3 for now
-DEFAULT_PHP_VER= 53
+USES= perl5
+USE_PERL5= install
+USE_SM_COMPAT= yes
NO_STAGE= yes
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
-
-do-install:
- ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
- @${ECHO} ""
- @${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-quota_usage-plugin/files/pkg-message.in b/mail/squirrelmail-quota_usage-plugin/files/pkg-message.in
index 5fa04f5b3da0..d81edeec73d1 100644
--- a/mail/squirrelmail-quota_usage-plugin/files/pkg-message.in
+++ b/mail/squirrelmail-quota_usage-plugin/files/pkg-message.in
@@ -1,5 +1,5 @@
For the port to work properly you must copy the file
-%%PREFIX%%/%%SQUIRRELDIR%%/plugins/quota_usage/config.php.sample
+%%SQUIRRELDIR%%/plugins/quota_usage/config.php.sample
to
-%%PREFIX%%/%%SQUIRRELDIR%%/plugins/quota_usage/config.php
+%%SQUIRRELDIR%%/plugins/quota_usage/config.php
and edit the configuration to meet your needs.
diff --git a/mail/squirrelmail-sasql-plugin/Makefile b/mail/squirrelmail-sasql-plugin/Makefile
index 6c165af7062c..438ba1cb6142 100644
--- a/mail/squirrelmail-sasql-plugin/Makefile
+++ b/mail/squirrelmail-sasql-plugin/Makefile
@@ -1,79 +1,29 @@
# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
-PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTNAME= sasql
PORTVERSION= 3.2.0
PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Edit SpamAssassin settings stored in an SQL DB
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
- ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin \
- ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
-
-SQUIRREL_PLUGIN_NAME= sasql
-
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-. ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-. else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-. endif
-.endif
-
-SUB_FILES= pkg-message
+RUN_DEPENDS= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
USES= perl5
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5= build
-USE_PHP= yes
-WANT_PHP_WEB= yes
+USE_PERL5= install
+USE_SM_COMPAT= yes
NO_STAGE= yes
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
post-patch:
@${RM} ${WRKSRC}/${SQUIRREL_PLUGIN_NAME}/*.orig ${WRKSRC}/${SQUIRREL_PLUGIN_NAME}/.cvsignore
-do-install:
- ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
- @${ECHO} ""
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-sasql-plugin/files/pkg-message.in b/mail/squirrelmail-sasql-plugin/files/pkg-message.in
index 44e646094e69..d7c91e1439a2 100644
--- a/mail/squirrelmail-sasql-plugin/files/pkg-message.in
+++ b/mail/squirrelmail-sasql-plugin/files/pkg-message.in
@@ -1,5 +1,5 @@
For the port to work properly you must copy the file
-%%PREFIX%%/%%SQUIRRELDIR%%/plugins/sasql/sasql_conf.php.dist
+%%SQUIRRELDIR%%/plugins/sasql/sasql_conf.php.dist
to
-%%PREFIX%%/%%SQUIRRELDIR%%/plugins/sasql/sasql_conf.php
+%%SQUIRRELDIR%%/plugins/sasql/sasql_conf.php
and edit the configuration to meet your needs.
diff --git a/mail/squirrelmail-shared_calendars-plugin/Makefile b/mail/squirrelmail-shared_calendars-plugin/Makefile
index 0ab016168b2d..316ef0e83384 100644
--- a/mail/squirrelmail-shared_calendars-plugin/Makefile
+++ b/mail/squirrelmail-shared_calendars-plugin/Makefile
@@ -2,89 +2,33 @@
# $FreeBSD$
PORTNAME= shared_calendars
-PORTVERSION= 2.0.1
+PORTVERSION= 2.0.1
PORTREVISION= 1
CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-PKGNAMEPREFIX= squirrelmail-
-PKGNAMESUFFIX= -plugin
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.4.0
-DIST_SUBDIR= squirrelmail
+DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= iCal-compliant calendaring for SquirrelMail
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
- ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
-
-SQUIRREL_PLUGIN_NAME= ${PORTNAME}
-
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-. ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-. else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-. endif
-.endif
-
-SUB_FILES= pkg-message
-
-USES= perl5
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5= build
-USE_PHP= yes
-WANT_PHP_WEB= yes
+USES= perl5
+USE_PERL5= install
+USE_SM_COMPAT= yes
+_SMSRCDIR= calendar
OPTIONS_DEFINE= SQL
-SQL_DESC= use SQL backend
-
-LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
NO_STAGE= yes
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MSQL}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/calendar_sql_backend:${PORTSDIR}/mail/squirrelmail-calendar_sql_backend-plugin
.else
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/calendar_file_backend:${PORTSDIR}/mail/squirrelmail-calendar_file_backend-plugin
.endif
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
-
-do-install:
- ${CP} -rp ${WRKSRC}/calendar ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
- @${ECHO} ""
- @${CAT} ${PKGMESSAGE}
-
+.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
diff --git a/mail/squirrelmail-shared_calendars-plugin/files/pkg-message.in b/mail/squirrelmail-shared_calendars-plugin/files/pkg-message.in
index c757deeb5481..421fdc004654 100644
--- a/mail/squirrelmail-shared_calendars-plugin/files/pkg-message.in
+++ b/mail/squirrelmail-shared_calendars-plugin/files/pkg-message.in
@@ -1,5 +1,5 @@
For the port to work properly you must copy the file
-%%PREFIX%%/%%SQUIRRELDIR%%/plugins/shared_calendars/data/config.sample.php
+%%SQUIRRELDIR%%/plugins/shared_calendars/data/config.sample.php
to
-%%PREFIX%%/%%SQUIRRELDIR%%/plugins/shared_calendars/data/config.php
+%%SQUIRRELDIR%%/plugins/shared_calendars/data/config.php
and edit the configuration to meet your needs.
diff --git a/mail/squirrelmail-wetteronline-plugin/Makefile b/mail/squirrelmail-wetteronline-plugin/Makefile
index c5eefcdc13e4..3c7fc059b961 100644
--- a/mail/squirrelmail-wetteronline-plugin/Makefile
+++ b/mail/squirrelmail-wetteronline-plugin/Makefile
@@ -1,74 +1,24 @@
# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
-PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
-PORTVERSION= 0.1
+PORTNAME= wetteronline
+PORTVERSION= 0.1
PORTREVISION= 1
CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
-DIST_SUBDIR= squirrelmail
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
+DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Plugin for the weather in Germany
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
- ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
-
-SQUIRREL_PLUGIN_NAME= wetteronline
-
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-. ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-. else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-. endif
-.endif
-
-USES= perl5
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5= build
-USE_PHP= yes
-WANT_PHP_WEB= yes
-IGNORE_WITH_PHP=5 # known incompatibilities with php-5.4, use 5.3 for now
-DEFAULT_PHP_VER=53
+USES= perl5
+USE_PERL5= install
+USE_SM_COMPAT= yes
NO_STAGE= yes
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
-
-do-install:
- ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
- @${ECHO} ""
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
+.include <bsd.port.post.mk>