aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authordan <dan@FreeBSD.org>1999-09-27 13:13:04 +0800
committerdan <dan@FreeBSD.org>1999-09-27 13:13:04 +0800
commit35dc73ef0773f7d35371e27725cf8d6e6eddf773 (patch)
tree94c03a15410e8a6596e9ae40544b3936aa20eab0 /mail
parent87ae668c8872e910816fedd87c8805b7b9fd5591 (diff)
downloadfreebsd-ports-gnome-35dc73ef0773f7d35371e27725cf8d6e6eddf773.tar.gz
freebsd-ports-gnome-35dc73ef0773f7d35371e27725cf8d6e6eddf773.tar.zst
freebsd-ports-gnome-35dc73ef0773f7d35371e27725cf8d6e6eddf773.zip
IMAP-Admin is a Perl module for basic IMAP server administration. With
this module it's easy to make Perl scripts to create new and remove obsolete IMAP accounts, set user quotas on Cyrus server etc. PR: ports/13990 Submitted by: Martti Kuparinen <martti.kuparinen@research.zopps.fi>
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-IMAP-Admin/Makefile36
-rw-r--r--mail/p5-IMAP-Admin/distinfo1
-rw-r--r--mail/p5-IMAP-Admin/pkg-comment1
-rw-r--r--mail/p5-IMAP-Admin/pkg-descr3
-rw-r--r--mail/p5-IMAP-Admin/pkg-plist8
5 files changed, 49 insertions, 0 deletions
diff --git a/mail/p5-IMAP-Admin/Makefile b/mail/p5-IMAP-Admin/Makefile
new file mode 100644
index 000000000000..ed5fbc68dd3a
--- /dev/null
+++ b/mail/p5-IMAP-Admin/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-IMAP-Admin
+# Version required: 0.8.2
+# Date created: Sun Sep 26 09:25:38 EEST 1999
+# Whom: Martti Kuparinen <martti.kuparinen@ericsson.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= IMAP-Admin-0.8.2
+PKGNAME= p5-IMAP-Admin-0.8.2
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IMAP
+
+MAINTAINER= martti.kuparinen@ericsson.com
+
+USE_PERL5= YES
+
+MAN3= IMAP::Admin.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/examples/p5-IMAP-Admin
+ @${INSTALL_DATA} ${WRKSRC}/examples/create.pl \
+ ${WRKSRC}/examples/delete.pl \
+ ${PREFIX}/share/examples/p5-IMAP-Admin
+ @${ECHO} ""
+ @${ECHO} "*******************************************************************************"
+ @${ECHO} "See ${PREFIX}/share/examples/p5-IMAP-Admin for some examples..."
+ @${ECHO} "*******************************************************************************"
+ @${ECHO} ""
+
+.include <bsd.port.mk>
diff --git a/mail/p5-IMAP-Admin/distinfo b/mail/p5-IMAP-Admin/distinfo
new file mode 100644
index 000000000000..de8354af7565
--- /dev/null
+++ b/mail/p5-IMAP-Admin/distinfo
@@ -0,0 +1 @@
+MD5 (IMAP-Admin-0.8.2.tar.gz) = a671b77794702f1514fd931b4a7b001e
diff --git a/mail/p5-IMAP-Admin/pkg-comment b/mail/p5-IMAP-Admin/pkg-comment
new file mode 100644
index 000000000000..e76ca1b23158
--- /dev/null
+++ b/mail/p5-IMAP-Admin/pkg-comment
@@ -0,0 +1 @@
+Perl module for basic IMAP server administration
diff --git a/mail/p5-IMAP-Admin/pkg-descr b/mail/p5-IMAP-Admin/pkg-descr
new file mode 100644
index 000000000000..eacc63a2f9e4
--- /dev/null
+++ b/mail/p5-IMAP-Admin/pkg-descr
@@ -0,0 +1,3 @@
+IMAP-Admin is a Perl module for basic IMAP server administration. With
+this module it's easy to make Perl scripts to create new and remove obsolete
+IMAP accounts, set user quotas on Cyrus server etc.
diff --git a/mail/p5-IMAP-Admin/pkg-plist b/mail/p5-IMAP-Admin/pkg-plist
new file mode 100644
index 000000000000..329c363a3e84
--- /dev/null
+++ b/mail/p5-IMAP-Admin/pkg-plist
@@ -0,0 +1,8 @@
+share/examples/p5-IMAP-Admin/create.pl
+share/examples/p5-IMAP-Admin/delete.pl
+lib/perl5/site_perl/%%PERL_VER%%/IMAP/Admin.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/IMAP/Admin/autosplit.ix
+@dirrm share/examples/p5-IMAP-Admin
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/IMAP/Admin
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/IMAP
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/IMAP