aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-09 18:13:22 +0800
committermiwi <miwi@FreeBSD.org>2007-03-09 18:13:22 +0800
commit3b8d4976d1e09fe5c6193d05681a5213036405f1 (patch)
tree7107cd07b520004a34b4ce712dfdbdbe25047921 /mail
parent60c2c2b87b2a7bf12bb176b4c4941f4febaddf36 (diff)
downloadfreebsd-ports-gnome-3b8d4976d1e09fe5c6193d05681a5213036405f1.tar.gz
freebsd-ports-gnome-3b8d4976d1e09fe5c6193d05681a5213036405f1.tar.zst
freebsd-ports-gnome-3b8d4976d1e09fe5c6193d05681a5213036405f1.zip
qar-bufo generates the Qmail assign and recipients file based on unix groups.
Unlike with qmail-pw2u, you don't need your users in /etc/passwd. They can be stored any where that a NSS module allows. Just make all users who send or recieve mail a member of a specific group, and that group will be used to generate the assign and recipients file. PR: ports/110114 Submitted by: Zane C. Bowers
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/qar-bufo/Makefile41
-rw-r--r--mail/qar-bufo/distinfo3
-rw-r--r--mail/qar-bufo/pkg-descr7
4 files changed, 52 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index d9118fea7a75..c32e9d6da727 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -463,6 +463,7 @@
SUBDIR += pygmy
SUBDIR += pymsgauth
SUBDIR += pyzor
+ SUBDIR += qar-bufo
SUBDIR += qconfirm
SUBDIR += qmHandle
SUBDIR += qmail
diff --git a/mail/qar-bufo/Makefile b/mail/qar-bufo/Makefile
new file mode 100644
index 000000000000..8cd113798c0c
--- /dev/null
+++ b/mail/qar-bufo/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: qar-bufo
+# Date created: 8 March 2007
+# Whom: Zane C. Bowers
+#
+# $FreeBSD$
+#
+
+PORTNAME= qar-bufo
+PORTVERSION= 1.3.1
+CATEGORIES= mail
+MASTER_SITES= http://cpan.org/authors/id/M/MW/MWCZANECB/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= qar-bufo generates the Qmail assign and recipients file based on unix groups.
+
+USE_PERL5= yes
+NO_WRKSUBDIR= yes
+
+MAN1= qar-bufo.1
+
+PLIST_FILES= bin/qar-bufo
+
+post-extract:
+ @${CP} -v ${DISTDIR}/${DISTNAME} ${WRKSRC}
+
+#nothing to configure
+do-configure:
+ @${ECHO} -n
+
+do-build:
+ @${EXEC} pod2man --section=1 --release=${PORTVERSION} --name=${PORTNAME} --center="${PORTNAME} user guide" ${WRKSRC}/${DISTNAME} ${WRKSRC}/${PORTNAME}.1
+
+do-install:
+ @${CP} -v ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/${PORTNAME}
+ @${CP} -v ${WRKSRC}/${PORTNAME}.1 ${PREFIX}/man/man1/${PORTNAME}.1
+ @${CHMOD} +x ${PREFIX}/bin/qar-bufo
+
+.include <bsd.port.mk>
diff --git a/mail/qar-bufo/distinfo b/mail/qar-bufo/distinfo
new file mode 100644
index 000000000000..313dde41feb1
--- /dev/null
+++ b/mail/qar-bufo/distinfo
@@ -0,0 +1,3 @@
+MD5 (qar-bufo-1.3.1) = a68cb5a72a026033fdce9fe2e983e483
+SHA256 (qar-bufo-1.3.1) = 6fa008ab90beef8342978e667a834d0856e750a4fa930495ae9e5041f511c7e0
+SIZE (qar-bufo-1.3.1) = 16079
diff --git a/mail/qar-bufo/pkg-descr b/mail/qar-bufo/pkg-descr
new file mode 100644
index 000000000000..fadaa151a0f3
--- /dev/null
+++ b/mail/qar-bufo/pkg-descr
@@ -0,0 +1,7 @@
+qar-bufo generates the Qmail assign and recipients file based on unix groups.
+
+Unlike with qmail-pw2u, you don't need your users in /etc/passwd. They can be
+stored any where that a NSS module allows.
+
+Just make all users who send or recieve mail a member of a specific group, and
+that group will be used to generate the assign and recipients file.