aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-10-24 18:18:50 +0800
committermat <mat@FreeBSD.org>2016-10-24 18:18:50 +0800
commita20b69c216a68e3cb38e3be3f680fabddc709a73 (patch)
tree24b07d918a45d04da3d1e5d65d5a5802bc0952ff /mail
parent3d6c012d2362b9db5ced15b6080faa949e5c57cb (diff)
downloadfreebsd-ports-gnome-a20b69c216a68e3cb38e3be3f680fabddc709a73.tar.gz
freebsd-ports-gnome-a20b69c216a68e3cb38e3be3f680fabddc709a73.tar.zst
freebsd-ports-gnome-a20b69c216a68e3cb38e3be3f680fabddc709a73.zip
OPTIONS_SET/OPTIONS_UNSET are global variables, they cannot be used in ports Makefiles.
So, replace them with OPTIONS_SLAVE, OPTIONS_EXCLUDE, OPTIONS_DEFAULT, where appropriate. The ghostscript ports are doing something nasty that is certainly wrong, but I don't want to try to understand it. Sponsored by: Absolight
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt/Makefile2
-rw-r--r--mail/qpopper/Makefile8
-rw-r--r--mail/qpopper/pkg-plist2
-rw-r--r--mail/sympa/Makefile2
4 files changed, 4 insertions, 10 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index c2e8d453f6c0..44a35e13eff7 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -54,7 +54,7 @@ AUTOMAKE_ARGS= --add-missing --foreign
OPTIONS_SUB= yes
.if defined (MUTT_LITE)
-OPTIONS_UNSET= NLS DOCS EXAMPLES
+OPTIONS_EXCLUDE= NLS DOCS EXAMPLES
.else
OPTIONS_DEFINE= COMPRESSED_FOLDERS SASL DEBUG DOCS EXAMPLES FLOCK \
FORCEBASE64 GPGME GREETING_PATCH HTML ICONV IDN IFDEF_PATCH \
diff --git a/mail/qpopper/Makefile b/mail/qpopper/Makefile
index 45ae723f29f6..ca71e4c0ec15 100644
--- a/mail/qpopper/Makefile
+++ b/mail/qpopper/Makefile
@@ -76,12 +76,6 @@ OS_DEFS+= -DAPOP_ONLY
.endif
.endif
-# Do not install documentation since it is in pdf format and normally
-# not used unless user wants it.
-.if empty(PORT_OPTIONS:MDOCUMENTATION)
-OPTIONS_UNSET+= DOCS
-.endif
-
# If WITH_DRAC variable present in the environment, qpopper builds
# with Dynamic Relay Authorization Control support.
.if ${PORT_OPTIONS:MDRAC}
@@ -161,7 +155,7 @@ do-install:
.if ${PORT_OPTIONS:MPOPPASSD}
@${INSTALL_PROGRAM} ${WRKSRC}/password/poppassd ${STAGEDIR}${PREFIX}/libexec/qpoppassd
.endif
-.if ${PORT_OPTIONS:MDOCS}
+.if ${PORT_OPTIONS:MDOCUMENTATION}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/GUIDE.pdf ${STAGEDIR}${DOCSDIR}
.endif
diff --git a/mail/qpopper/pkg-plist b/mail/qpopper/pkg-plist
index 6338974096cd..71bd803b90c5 100644
--- a/mail/qpopper/pkg-plist
+++ b/mail/qpopper/pkg-plist
@@ -5,5 +5,5 @@ libexec/qpopper
man/man8/qpopper.8.gz
%%QPOPAUTH%%man/man8/qpopauth.8.gz
%%EPOPPASSD%%libexec/qpoppassd
-%%PORTDOCS%%%%DOCSDIR%%/GUIDE.pdf
+%%DOCUMENTATION%%%%DOCSDIR%%/GUIDE.pdf
@dir(%%USERS%%,%%GROUPS%%,) %%ETCDIR%%
diff --git a/mail/sympa/Makefile b/mail/sympa/Makefile
index 1207e316edb4..42b56ac3c484 100644
--- a/mail/sympa/Makefile
+++ b/mail/sympa/Makefile
@@ -101,7 +101,7 @@ SYBASE_DESC= Sybase database
DB_TYPE:= ${DB_TYPE:tu}
. for option in ${OPTIONS_RADIO_DATABASE}
. if ${DB_TYPE} == ${option:S,PGSQL,PG,}
-OPTIONS_SET+= ${option}
+OPTIONS_DEFAULT+= ${option}
.warning You need to replace your DB_TYPE variable in make.conf with mail_sympa_SET+=${option}
. endif
. endfor