aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-08-30 20:43:25 +0800
committercrees <crees@FreeBSD.org>2011-08-30 20:43:25 +0800
commita9fd83de963b18316e2aed2acbda41fb122f3410 (patch)
tree16715cdd977230c4286e77cd8c2981a986ebe4ab /mail
parentde75829c416d0c2e3bc1acf61a62a1685ab087b8 (diff)
downloadfreebsd-ports-gnome-a9fd83de963b18316e2aed2acbda41fb122f3410.tar.gz
freebsd-ports-gnome-a9fd83de963b18316e2aed2acbda41fb122f3410.tar.zst
freebsd-ports-gnome-a9fd83de963b18316e2aed2acbda41fb122f3410.zip
- Remove AWL support code [1]
- change PKGNAMEPREFIX = p5 to ? to allow slave ports - Fix sa-update behaviour when disk full PR: ports/160282 Submitted by: Michael Scheidell <scheidell@secnap.net> (maintainer), [1] Jason Helfman
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-Mail-SpamAssassin/Makefile7
-rw-r--r--mail/p5-Mail-SpamAssassin/files/patch-bug665550
2 files changed, 52 insertions, 5 deletions
diff --git a/mail/p5-Mail-SpamAssassin/Makefile b/mail/p5-Mail-SpamAssassin/Makefile
index 9385884e0225..cec21770921a 100644
--- a/mail/p5-Mail-SpamAssassin/Makefile
+++ b/mail/p5-Mail-SpamAssassin/Makefile
@@ -7,11 +7,11 @@
PORTNAME= Mail-SpamAssassin
PORTVERSION= 3.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail perl5
MASTER_SITES= ${MASTER_SITE_APACHE:S/$/:apache/} ${MASTER_SITE_PERL_CPAN:S/$/:cpan/}
MASTER_SITE_SUBDIR= spamassassin/source/:apache Mail/:cpan
-PKGNAMEPREFIX= p5-
+PKGNAMEPREFIX?= p5-
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:apache,cpan
MAINTAINER= scheidell@secnap.net
@@ -266,9 +266,6 @@ post-patch:
.if defined(WITH_DCC)
${REINPLACE_CMD} -e '/DCC/s/^#loadplugin/loadplugin/' ${WRKSRC}/rules/v310.pre
.endif
-.if !defined(WITH_AWL)
- ${REINPLACE_CMD} -e '/AWL/s/^loadplugin/#loadplugin/' ${WRKSRC}/rules/v310.pre
-.endif
.if defined(WITH_SACOMPILE)
${REINPLACE_CMD} -e '/Rule2XSBody/s/^# loadplugin/loadplugin/' ${WRKSRC}/rules/v320.pre
.endif
diff --git a/mail/p5-Mail-SpamAssassin/files/patch-bug6655 b/mail/p5-Mail-SpamAssassin/files/patch-bug6655
new file mode 100644
index 000000000000..9006f72274fb
--- /dev/null
+++ b/mail/p5-Mail-SpamAssassin/files/patch-bug6655
@@ -0,0 +1,50 @@
+$FreeBSD$
+
+https://issues.apache.org/SpamAssassin/show_bug.cgi?id=6655
+
+--- lib/Mail/SpamAssassin/Util.pm 2011-06-06 19:59:17.000000000 -0400
++++ lib/Mail/SpamAssassin/Util.pm 2011-08-26 17:12:19.000000000 -0400
+@@ -1025,6 +1024,8 @@
+ return;
+ }
+
++ opendir(my $dh, $tmpdir) || die "Could not open $tmpdir: $!";
++ closedir $dh;
+ my ($reportfile, $tmpfile);
+ my $umask = umask 077;
+
+@@ -1052,7 +1053,10 @@
+
+ # ensure the file handle is not semi-open in some way
+ if ($tmpfile) {
+- close $tmpfile or info("error closing $reportfile: $!");
++ if (! close $tmpfile) {
++ info("error closing $reportfile: $!");
++ $tmpfile=undef;
++ }
+ }
+ }
+
+--- sa-update.raw 2011-06-24 13:38:50.000000000 -0400
++++ sa-update.raw 2011-08-29 09:38:50.000000000 -0400
+@@ -677,9 +677,9 @@
+
+ # Write the content out to a temp file for GPG/Archive::Tar interaction
+ dbg("channel: populating temp content file");
+- open(TMP, ">$content_file") || die "fatal: can't write to content temp file $content_file: $!\n";
++ open(TMP, ">$content_file") || die "fatal: couldn't create content temp file $content_file: $!\n";
+ binmode TMP;
+- print TMP $content;
++ print TMP $content || die "fatal: can't write to content temp file $content_file: $!\n";
+ close(TMP);
+
+ # to sign : gpg -bas file
+@@ -695,7 +695,7 @@
+ die "fatal: couldn't create temp file for GPG signature: $!\n";
+ }
+ binmode $tfh;
+- print $tfh $GPG;
++ print $tfh $GPG || die "fatal: can't write temp file for GPG signature: $!\n";
+ close($tfh);
+
+ dbg("gpg: calling gpg");