aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-03-01 04:15:44 +0800
committeroliver <oliver@FreeBSD.org>2005-03-01 04:15:44 +0800
commitbe44406d240008e8932d3c09266e4d42077dc195 (patch)
tree620ae3102c3693690842b8e1ce6c94b826563b34 /mail
parent15c3b1d7eb5fc4a5f61ef9c5dba0214be8f917ed (diff)
downloadfreebsd-ports-gnome-be44406d240008e8932d3c09266e4d42077dc195.tar.gz
freebsd-ports-gnome-be44406d240008e8932d3c09266e4d42077dc195.tar.zst
freebsd-ports-gnome-be44406d240008e8932d3c09266e4d42077dc195.zip
OPTIONS'ify
PR: 78155 Submitted by: Miguel Mendez <flynn@energyhq.es.eu.org>
Diffstat (limited to 'mail')
-rw-r--r--mail/sylpheed2-devel/Makefile26
-rw-r--r--mail/sylpheed2/Makefile26
-rw-r--r--mail/sylpheed3/Makefile26
3 files changed, 33 insertions, 45 deletions
diff --git a/mail/sylpheed2-devel/Makefile b/mail/sylpheed2-devel/Makefile
index b775faf6d3f3..230a3cdeda5a 100644
--- a/mail/sylpheed2-devel/Makefile
+++ b/mail/sylpheed2-devel/Makefile
@@ -40,12 +40,20 @@ CONFIGURE_ARGS= --enable-ipv6 \
CONFLICTS= sylpheed-1.[0-8]* sylpheed-gtk2-[0-9]*
-.if !defined(WITHOUT_SSL)
-USE_OPENSSL= yes
-.endif
+OPTIONS= GPGME "Enable GnuPG support using GPGME." off \
+ COMPFACE "Enable X-Face support." off \
+ JPILOT "Enable JPilot support." off \
+ LDAP "Enable LDAP support." off \
+ SSL "Enable OpenSSL support." off
.include <bsd.port.pre.mk>
+.if defined(WITH_SSL)
+# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+CONFIGURE_ARGS+=--enable-ssl
+.endif
+
.if defined(WITH_GPGME)
LIB_DEPENDS+= gpgme.14:${PORTSDIR}/security/gpgme
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
@@ -83,18 +91,6 @@ MAKEFILES= Makefile.in ac/Makefile.in faq/Makefile.in faq/de/Makefile.in \
faq/it/Makefile.in manual/Makefile.in manual/en/Makefile.in \
manual/ja/Makefile.in src/Makefile.in
-pre-everything::
- @${ECHO} ""
- @${ECHO} "You may use the following build options:"
- @${ECHO} ""
- @${ECHO} " WITH_GPGME=yes Enable GnuPG support using GPGME."
- @${ECHO} " WITH_COMPFACE=yes Enable X-Face support."
- @${ECHO} " WITH_JPILOT=yes Enable JPilot support."
- @${ECHO} " WITH_LDAP=yes Enable LDAP support."
- @${ECHO} ""
- @${ECHO} " WITHOUT_SSL=yes Disable OpenSSL support."
- @${ECHO} ""
-
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
s|-lresolv||g; s|-lpisock\"|-liconv &|g; ' ${WRKSRC}/configure
diff --git a/mail/sylpheed2/Makefile b/mail/sylpheed2/Makefile
index b775faf6d3f3..230a3cdeda5a 100644
--- a/mail/sylpheed2/Makefile
+++ b/mail/sylpheed2/Makefile
@@ -40,12 +40,20 @@ CONFIGURE_ARGS= --enable-ipv6 \
CONFLICTS= sylpheed-1.[0-8]* sylpheed-gtk2-[0-9]*
-.if !defined(WITHOUT_SSL)
-USE_OPENSSL= yes
-.endif
+OPTIONS= GPGME "Enable GnuPG support using GPGME." off \
+ COMPFACE "Enable X-Face support." off \
+ JPILOT "Enable JPilot support." off \
+ LDAP "Enable LDAP support." off \
+ SSL "Enable OpenSSL support." off
.include <bsd.port.pre.mk>
+.if defined(WITH_SSL)
+# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+CONFIGURE_ARGS+=--enable-ssl
+.endif
+
.if defined(WITH_GPGME)
LIB_DEPENDS+= gpgme.14:${PORTSDIR}/security/gpgme
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
@@ -83,18 +91,6 @@ MAKEFILES= Makefile.in ac/Makefile.in faq/Makefile.in faq/de/Makefile.in \
faq/it/Makefile.in manual/Makefile.in manual/en/Makefile.in \
manual/ja/Makefile.in src/Makefile.in
-pre-everything::
- @${ECHO} ""
- @${ECHO} "You may use the following build options:"
- @${ECHO} ""
- @${ECHO} " WITH_GPGME=yes Enable GnuPG support using GPGME."
- @${ECHO} " WITH_COMPFACE=yes Enable X-Face support."
- @${ECHO} " WITH_JPILOT=yes Enable JPilot support."
- @${ECHO} " WITH_LDAP=yes Enable LDAP support."
- @${ECHO} ""
- @${ECHO} " WITHOUT_SSL=yes Disable OpenSSL support."
- @${ECHO} ""
-
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
s|-lresolv||g; s|-lpisock\"|-liconv &|g; ' ${WRKSRC}/configure
diff --git a/mail/sylpheed3/Makefile b/mail/sylpheed3/Makefile
index b775faf6d3f3..230a3cdeda5a 100644
--- a/mail/sylpheed3/Makefile
+++ b/mail/sylpheed3/Makefile
@@ -40,12 +40,20 @@ CONFIGURE_ARGS= --enable-ipv6 \
CONFLICTS= sylpheed-1.[0-8]* sylpheed-gtk2-[0-9]*
-.if !defined(WITHOUT_SSL)
-USE_OPENSSL= yes
-.endif
+OPTIONS= GPGME "Enable GnuPG support using GPGME." off \
+ COMPFACE "Enable X-Face support." off \
+ JPILOT "Enable JPilot support." off \
+ LDAP "Enable LDAP support." off \
+ SSL "Enable OpenSSL support." off
.include <bsd.port.pre.mk>
+.if defined(WITH_SSL)
+# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+CONFIGURE_ARGS+=--enable-ssl
+.endif
+
.if defined(WITH_GPGME)
LIB_DEPENDS+= gpgme.14:${PORTSDIR}/security/gpgme
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
@@ -83,18 +91,6 @@ MAKEFILES= Makefile.in ac/Makefile.in faq/Makefile.in faq/de/Makefile.in \
faq/it/Makefile.in manual/Makefile.in manual/en/Makefile.in \
manual/ja/Makefile.in src/Makefile.in
-pre-everything::
- @${ECHO} ""
- @${ECHO} "You may use the following build options:"
- @${ECHO} ""
- @${ECHO} " WITH_GPGME=yes Enable GnuPG support using GPGME."
- @${ECHO} " WITH_COMPFACE=yes Enable X-Face support."
- @${ECHO} " WITH_JPILOT=yes Enable JPilot support."
- @${ECHO} " WITH_LDAP=yes Enable LDAP support."
- @${ECHO} ""
- @${ECHO} " WITHOUT_SSL=yes Disable OpenSSL support."
- @${ECHO} ""
-
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
s|-lresolv||g; s|-lpisock\"|-liconv &|g; ' ${WRKSRC}/configure