aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2006-10-08 10:45:58 +0800
committermnag <mnag@FreeBSD.org>2006-10-08 10:45:58 +0800
commitc315c483dd9e112e95153ca597db7ef84263f7ab (patch)
tree694f9e7a9f07b403291ffafac5147fcab5c51cbd /mail
parent1f1a68f763f7b5d88e0d0bb1f4876e3d826a3b46 (diff)
downloadfreebsd-ports-gnome-c315c483dd9e112e95153ca597db7ef84263f7ab.tar.gz
freebsd-ports-gnome-c315c483dd9e112e95153ca597db7ef84263f7ab.tar.zst
freebsd-ports-gnome-c315c483dd9e112e95153ca597db7ef84263f7ab.zip
- Update to 0.5.3
- portlint(1)
Diffstat (limited to 'mail')
-rw-r--r--mail/pfqueue/Makefile6
-rw-r--r--mail/pfqueue/distinfo6
-rw-r--r--mail/pfqueue/files/patch-pfqlib.h10
3 files changed, 16 insertions, 6 deletions
diff --git a/mail/pfqueue/Makefile b/mail/pfqueue/Makefile
index fbea15eb950c..b86ff85bf9f1 100644
--- a/mail/pfqueue/Makefile
+++ b/mail/pfqueue/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pfqueue
-PORTVERSION= 0.5.2
-PORTREVISION= 2
+PORTVERSION= 0.5.3
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,11 +15,12 @@ MAINTAINER= mnag@FreeBSD.org
COMMENT= A console-based tool for handling Postfix 1, Postfix 2 and Exim queues
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= pfqueue.1
+MAN5= pfqueue.conf.5
post-patch:
@${REINPLACE_CMD} -e "s|-lc_r|${PTHREAD_LIBS}|g" \
diff --git a/mail/pfqueue/distinfo b/mail/pfqueue/distinfo
index c7505fca3af7..194e8805bfe0 100644
--- a/mail/pfqueue/distinfo
+++ b/mail/pfqueue/distinfo
@@ -1,3 +1,3 @@
-MD5 (pfqueue-0.5.2.tar.gz) = 93f762746357473c8aa456f7a7066c81
-SHA256 (pfqueue-0.5.2.tar.gz) = f8b071cf79af21dc1b4cf8ebb5e43675e7c8a4cbc85a7e33202892e44e37f561
-SIZE (pfqueue-0.5.2.tar.gz) = 288924
+MD5 (pfqueue-0.5.3.tar.gz) = 7700198871f91cf28e0164f8e776dd55
+SHA256 (pfqueue-0.5.3.tar.gz) = 05dc8d02fc40a2b666147a4c3a69f5f7c94d86445f9c6a059dc0b0baff60a7e1
+SIZE (pfqueue-0.5.3.tar.gz) = 292616
diff --git a/mail/pfqueue/files/patch-pfqlib.h b/mail/pfqueue/files/patch-pfqlib.h
new file mode 100644
index 000000000000..6f647e51904e
--- /dev/null
+++ b/mail/pfqueue/files/patch-pfqlib.h
@@ -0,0 +1,10 @@
+--- pfqlib.h.orig Sat Oct 7 23:40:07 2006
++++ pfqlib.h Sat Oct 7 23:40:42 2006
+@@ -7,6 +7,7 @@
+ #define __PFQLIB_H
+
+ #include <time.h>
++#include <sys/types.h>
+ #include <regex.h>
+ #include <sys/types.h>
+ #include "pfregex.h"