aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-08-02 10:50:14 +0800
committerdanfe <danfe@FreeBSD.org>2013-08-02 10:50:14 +0800
commitca3b30d5f362aa4e0ca81e21c9500439f09656ea (patch)
tree87a34b7f47681d779854f8a0a26fbb978f439f59 /mail
parent465e9ffcc42e1039e6800d8a285e19f38bc09163 (diff)
downloadfreebsd-ports-gnome-ca3b30d5f362aa4e0ca81e21c9500439f09656ea.tar.gz
freebsd-ports-gnome-ca3b30d5f362aa4e0ca81e21c9500439f09656ea.tar.zst
freebsd-ports-gnome-ca3b30d5f362aa4e0ca81e21c9500439f09656ea.zip
- Unbreak parallel (-jX) builds by removing bogus "clean" from ALL_TARGET
- Avoid using not-quite-compatible :L modifier in WRKSRC assignment - Add LICENSE (GPLv2), properly define and handle portdocs and examples - Generally clean up Makefile and port description while I am here
Diffstat (limited to 'mail')
-rw-r--r--mail/wmpop3/Makefile25
-rw-r--r--mail/wmpop3/pkg-descr6
2 files changed, 18 insertions, 13 deletions
diff --git a/mail/wmpop3/Makefile b/mail/wmpop3/Makefile
index c3045bff874f..aec2ed3a3a03 100644
--- a/mail/wmpop3/Makefile
+++ b/mail/wmpop3/Makefile
@@ -1,7 +1,6 @@
# Created by: Jim Mock <jim@FreeBSD.org>
# $FreeBSD$
-
PORTNAME= wmpop3
PORTVERSION= 0.5.6a
PORTREVISION= 4
@@ -10,26 +9,32 @@ MASTER_SITES= #
DISTNAME= WMPop3-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= POP3 mail check for the Window Maker dock
+COMMENT= Dockapp to check email via POP3 protocol
-WRKSRC= ${WRKDIR}/${DISTNAME:L}/wmpop3
+LICENSE= GPLv2
USE_CSTD= gnu89
USE_XORG= xpm
-ALL_TARGET= clean all
-MAKE_JOBS_UNSAFE= yes
-PLIST_FILES= bin/wmpop3 %%EXAMPLESDIR%%/wmpop3rc
-PLIST_DIRS= %%EXAMPLESDIR%%
-PORTDOCS= README
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME}
+
+PLIST_FILES= bin/wmpop3
+PORTDOCS= CHANGE_LOG README
+PORTEXAMPLES= wmpop3rc
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.options.mk>
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmpop3 ${PREFIX}/bin
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/wmpop3rc ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
+.endif
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/../,} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/mail/wmpop3/pkg-descr b/mail/wmpop3/pkg-descr
index 41e4b1c8f48a..23b47101e0c2 100644
--- a/mail/wmpop3/pkg-descr
+++ b/mail/wmpop3/pkg-descr
@@ -1,3 +1,3 @@
-WMPop3 is a POP3 mail box checker. It will connect to a POP3 server
-to check if you have mail, if you do then it will alert you of new
-mail and how many messages are currently in your mail box.
+WMPop3 is a POP3 mail box checker. It will connect to a POP3 server to
+check if you have mail, if you do then it will alert you of new mail and
+how many messages are currently in your mailbox.