aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormarkm <markm@FreeBSD.org>2001-04-17 18:59:45 +0800
committermarkm <markm@FreeBSD.org>2001-04-17 18:59:45 +0800
commitd00ab0103e1a7e456bf7093d94a59a9fb43119e2 (patch)
tree7d5a232c1a80e8ecd5e0b990d2579b4686cd6f83 /mail
parent6593996ba077814d9f5e2e595573072bd84986c9 (diff)
downloadfreebsd-ports-gnome-d00ab0103e1a7e456bf7093d94a59a9fb43119e2.tar.gz
freebsd-ports-gnome-d00ab0103e1a7e456bf7093d94a59a9fb43119e2.tar.zst
freebsd-ports-gnome-d00ab0103e1a7e456bf7093d94a59a9fb43119e2.zip
Add Ian Freislich's very good POP Daemon. For those of you tired
of lousy, insecure popd's, this is a "must-see". It also has great scalability to larger installations.
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/popd/Makefile23
-rw-r--r--mail/popd/distinfo1
-rw-r--r--mail/popd/pkg-comment1
-rw-r--r--mail/popd/pkg-descr6
-rw-r--r--mail/popd/pkg-plist1
6 files changed, 33 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index fbbebf0680dc..855e74a43821 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -115,6 +115,7 @@
SUBDIR += pop3gwd
SUBDIR += pop3lite
SUBDIR += popa3d
+ SUBDIR += popd
SUBDIR += poppassd
SUBDIR += popper
SUBDIR += poppwd
diff --git a/mail/popd/Makefile b/mail/popd/Makefile
new file mode 100644
index 000000000000..124dd342a239
--- /dev/null
+++ b/mail/popd/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: popd
+# Date created: 17 April 2001
+# Whom: ianf@za.uu.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= popd
+PORTVERSION= 1.02
+CATEGORIES= mail
+MASTER_SITES= ftp://ftp3.za.freebsd.org/pub/popd/
+
+MAINTAINER= ianf@za.uu.net
+
+MAN8= popd.8
+
+do-build:
+ cd ${WRKSRC}; make -DNOMANCOMPRESS
+
+do-install:
+ cd ${WRKSRC}; make -DNOMANCOMPRESS BINDIR=${PREFIX}/libexec MANDIR=${PREFIX}/man/man install
+
+.include <bsd.port.mk>
diff --git a/mail/popd/distinfo b/mail/popd/distinfo
new file mode 100644
index 000000000000..e1d1f3061a66
--- /dev/null
+++ b/mail/popd/distinfo
@@ -0,0 +1 @@
+MD5 (popd-1.02.tar.gz) = 3d7b797048f28c3f3ef69d462621c975
diff --git a/mail/popd/pkg-comment b/mail/popd/pkg-comment
new file mode 100644
index 000000000000..18d2fc1e8cd8
--- /dev/null
+++ b/mail/popd/pkg-comment
@@ -0,0 +1 @@
+Very fast, highly configurable POP3 server (fully RFC1939 compliant)
diff --git a/mail/popd/pkg-descr b/mail/popd/pkg-descr
new file mode 100644
index 000000000000..3bfcc6948747
--- /dev/null
+++ b/mail/popd/pkg-descr
@@ -0,0 +1,6 @@
+The popd server is a fast, full RFC1939 implimentation.
+
+Popd allows mail for users in multiple domains to be served from
+one server in `virtual' mode. It allows for mail to be expired
+from the server when users collect mail older than a specified
+time, falsification of UIDL information and removal of old mail.
diff --git a/mail/popd/pkg-plist b/mail/popd/pkg-plist
new file mode 100644
index 000000000000..42cc7976fe17
--- /dev/null
+++ b/mail/popd/pkg-plist
@@ -0,0 +1 @@
+libexec/popd