aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
committerkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
commitf6ac0b4935ea004895ab5cc2800059b8d12c82ba (patch)
tree91894094142566c88cf43e76bf56bd120a3c8119 /mail
parenta202830df7532e2bb404143c7bf5ee68b97df9bf (diff)
downloadfreebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.gz
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.zst
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.zip
Move inclusion of bsd.port.pre.mk later in the file for conditional BROKEN
tag. Early inclusion caused problems for some ports, so to be safe I'm updating all of them. Pointy hat to: kris
Diffstat (limited to 'mail')
-rw-r--r--mail/dkimap4/Makefile12
-rw-r--r--mail/filtermail/Makefile12
-rw-r--r--mail/ftrack/Makefile12
-rw-r--r--mail/liamail/Makefile12
-rw-r--r--mail/mailsync/Makefile12
-rw-r--r--mail/ml/Makefile8
6 files changed, 34 insertions, 34 deletions
diff --git a/mail/dkimap4/Makefile b/mail/dkimap4/Makefile
index b74b1e0e69ba..41e8ec0fc60c 100644
--- a/mail/dkimap4/Makefile
+++ b/mail/dkimap4/Makefile
@@ -16,12 +16,6 @@ EXTRACT_SUFX= .tgz
MAINTAINER= d.marks@student.umist.ac.uk
COMMENT= IMAP4rev1 and POP3 server from the DBOX BBS package
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -39,6 +33,12 @@ MAKE_ARGS+= SPOOLDIR="${SPOOLDIR}"
DOCS= README
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/movemail/movemail ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/dkimap4/dkimap4 ${PREFIX}/libexec
diff --git a/mail/filtermail/Makefile b/mail/filtermail/Makefile
index 88297476b272..c131918a7c3e 100644
--- a/mail/filtermail/Makefile
+++ b/mail/filtermail/Makefile
@@ -23,12 +23,6 @@ LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext \
iconv:${PORTSDIR}/converters/libiconv \
gnugetopt:${PORTSDIR}/devel/libgnugetopt
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
@@ -45,4 +39,10 @@ MAN5= filtermailrc.5 filtermailex.5
EXTRACT_AFTER_ARGS= | ${SED} 's/[mM][aA][iI][lL][fF][iI][lL][tT][eE][rR]/filtermail/g' | ${TAR} -xf -
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
.include <bsd.port.post.mk>
diff --git a/mail/ftrack/Makefile b/mail/ftrack/Makefile
index 9fd1e0ec3550..f8ef2d87b0fd 100644
--- a/mail/ftrack/Makefile
+++ b/mail/ftrack/Makefile
@@ -16,12 +16,6 @@ COMMENT= FTN Messages tracker
BUILD_DEPENDS= ${LOCALBASE}/lib/libsmapi.a:${PORTSDIR}/mail/smapi
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_ZIP= yes
USE_REINPLACE= yes
USE_GMAKE= yes
@@ -29,6 +23,12 @@ ALL_TARGET= ftrack
MAKEFILE= ${WRKSRC}/MakeFiles/FreeBSD/Makefile
EXTRACT_AFTER_ARGS= -d ${WRKSRC}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
pre-patch:
${REINPLACE_CMD} -e "s@-I../../hpp -I../../.. -O3@-Ihpp -I${LOCALBASE}/include ${CFLAGS}@g; \
s@../../src/@src/@g; s@g\+\+@${CC}@g; \
diff --git a/mail/liamail/Makefile b/mail/liamail/Makefile
index 6391e6218e29..ba9a8acac069 100644
--- a/mail/liamail/Makefile
+++ b/mail/liamail/Makefile
@@ -15,12 +15,6 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= kde@freebsd.org
COMMENT= A graphical mail client
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
USE_REINPLACE= yes
@@ -31,6 +25,12 @@ CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
QTDIR="${X11BASE}"
USE_GMAKE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s/qt.so/qt2.so/g" ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s/-lqt/-lqt2/g" ${WRKSRC}/src/Makefile.in
diff --git a/mail/mailsync/Makefile b/mail/mailsync/Makefile
index 11e92fe6fecc..ce4c8f24715e 100644
--- a/mail/mailsync/Makefile
+++ b/mail/mailsync/Makefile
@@ -17,12 +17,6 @@ COMMENT= Mailsync is a way of keeping a collection of mailboxes synchronized
LIB_DEPENDS= c-client4.8:${PORTSDIR}/mail/cclient
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
@@ -33,6 +27,12 @@ ALL_TARGET= default
MAN1= mailsync.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g' \
${WRKSRC}/examples/mailsync \
diff --git a/mail/ml/Makefile b/mail/ml/Makefile
index db36eb31f3ef..6574a66d2558 100644
--- a/mail/ml/Makefile
+++ b/mail/ml/Makefile
@@ -14,16 +14,16 @@ MASTER_SITES= http://ftp.rge.com/pub/mail/ml/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= An X11 IMAP client
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+USE_IMAKE= yes
+USE_MOTIF= yes
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile"
.endif
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
-USE_IMAKE= yes
-USE_MOTIF= yes
-
pre-configure:
@${ECHO_MSG} "===> Building c-client"
@( cd ${WRKSRC}/../imap-4; make bsi )