aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-01-06 08:56:42 +0800
committerscheidell <scheidell@FreeBSD.org>2012-01-06 08:56:42 +0800
commit0df2f041c04913572df492e031df9762818e6c9b (patch)
tree5dcd61f4ada6e9b4fa54790d02c554804a864e78 /mail
parent192bb2eb98a41864706b64fe7efec8d952b6ca2e (diff)
downloadfreebsd-ports-gnome-0df2f041c04913572df492e031df9762818e6c9b.tar.gz
freebsd-ports-gnome-0df2f041c04913572df492e031df9762818e6c9b.tar.zst
freebsd-ports-gnome-0df2f041c04913572df492e031df9762818e6c9b.zip
- Add option knob to suggest to rcorder that it start dovecot first
PR: ports/163200 Submitted by: Spil <spil.oss@gmail.com> Approved by: gabor (mentor)
Diffstat (limited to 'mail')
-rw-r--r--mail/up-imapproxy/Makefile13
-rw-r--r--mail/up-imapproxy/files/imapproxyd.sh.in2
2 files changed, 13 insertions, 2 deletions
diff --git a/mail/up-imapproxy/Makefile b/mail/up-imapproxy/Makefile
index a4ff313df1b3..9703a7522626 100644
--- a/mail/up-imapproxy/Makefile
+++ b/mail/up-imapproxy/Makefile
@@ -27,6 +27,17 @@ SUB_FILES= pkg-message
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+OPTIONS= DOVECOT "Use with dovecot2" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DOVECOT)
+SUB_LIST+= DOVECOT="dovecot"
+RUN_DEPENDS+= dovecot>=1.0:${PORTSDIR}/mail/dovecot2
+.else
+SUB_LIST+= DOVECOT=""
+.endif
+
do-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -36,4 +47,4 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/scripts/imapproxy.conf ${PREFIX}/etc/imapproxyd.conf.sample
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/up-imapproxy/files/imapproxyd.sh.in b/mail/up-imapproxy/files/imapproxyd.sh.in
index ac9576496e1c..c9bebba1ced5 100644
--- a/mail/up-imapproxy/files/imapproxyd.sh.in
+++ b/mail/up-imapproxy/files/imapproxyd.sh.in
@@ -3,7 +3,7 @@
# $FreeBSD$
#
# PROVIDE: imapproxyd
-# REQUIRE: DAEMON courier_imap_imapd courier_imap_imapd_ssl cyrus_imapd inetd
+# REQUIRE: DAEMON courier_imap_imapd courier_imap_imapd_ssl cyrus_imapd inetd %%DOVECOT%%
# KEYWORD: shutdown
#