aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2005-04-13 03:42:04 +0800
committeradamw <adamw@FreeBSD.org>2005-04-13 03:42:04 +0800
commit12871fdfa07a3c859124ceeaed2f277d5deeb2ea (patch)
tree3ef58c3b447df164be85547eb9ce6438f94dbb9c /mail
parent2e716c9bb4b13dc7a1fc22b9d6eabe5a2c25576e (diff)
downloadfreebsd-ports-gnome-12871fdfa07a3c859124ceeaed2f277d5deeb2ea.tar.gz
freebsd-ports-gnome-12871fdfa07a3c859124ceeaed2f277d5deeb2ea.tar.zst
freebsd-ports-gnome-12871fdfa07a3c859124ceeaed2f277d5deeb2ea.zip
* Fix the plist.
* Error out in the corner case that the thunderbird port dir is not sitting in ../thunderbird * Quiet the installation phase so the pkg-message is more legible * Bump PORTREVISION for the plist change. Hopefully I've gotten it right this time *shakes head*
Diffstat (limited to 'mail')
-rw-r--r--mail/moztraybiff/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/mail/moztraybiff/Makefile b/mail/moztraybiff/Makefile
index 22fb26e3bd03..6c01549273d1 100644
--- a/mail/moztraybiff/Makefile
+++ b/mail/moztraybiff/Makefile
@@ -7,7 +7,7 @@
PORTNAME= moztraybiff
PORTVERSION= 1.0.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail gnome
MASTER_SITES= http://mozdev.oregonstate.edu/moztraybiff/
DISTNAME= mozTrayBiff-${PORTVERSION}
@@ -19,7 +19,11 @@ BUILD_DEPENDS= ${X11BASE}/lib/thunderbird/lib/thunderbird-${TBVER}/components/li
zip:${PORTSDIR}/archivers/zip
RUN_DEPENDS= ${X11BASE}/lib/thunderbird/lib/thunderbird-${TBVER}/components/libwidget_gtk2.so:${PORTSDIR}/mail/thunderbird
+.if !exists(../thunderbird/Makefile)
+BROKEN= ${PORTNAME} needs the Thunderbird port in order to build
+.else
TBVER!= cd ../thunderbird && ${MAKE} -V PORTVERSION
+.endif
USE_X_PREFIX= yes
USE_GMAKE= yes
@@ -28,8 +32,8 @@ USE_REINPLACE= yes
MAKE_ARGS+= MOZILLA_PLATFORM=tbird
FILENAME= mozTrayBiff-${PORTVERSION}-FreeBSD-tb${TBVER}.xpi
-PLIST_FILES= ${DATADIR}/${FILENAME}
-PLIST_DIRS= ${DATADIR}
+PLIST_FILES= share/${PORTNAME}/${FILENAME}
+PLIST_DIRS= share/${PORTNAME}
PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
@@ -43,11 +47,11 @@ post-patch:
${WRKSRC}/components/Makefile
post-build:
- ${SED} 's|%%DATADIR%%|${DATADIR}|' ${PKGDIR}/pkg-message > ${PKGMESSAGE}
+ @${SED} 's|%%DATADIR%%|${DATADIR}|' ${PKGDIR}/pkg-message > ${PKGMESSAGE}
do-install:
- ${MKDIR} ${DATADIR}
- ${INSTALL} -m 644 ${WRKSRC}/${FILENAME} ${DATADIR}
+ @${MKDIR} ${DATADIR}
+ @${INSTALL} -m 644 ${WRKSRC}/${FILENAME} ${DATADIR}
post-install:
@${CAT} ${PKGMESSAGE}