aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-01-30 00:41:18 +0800
committerpav <pav@FreeBSD.org>2005-01-30 00:41:18 +0800
commit2d48543fe382e23eb2fed97f10dbc0ac70a06125 (patch)
treeab1316b99357a7501d0b1a63fa0ac528a2f01103 /mail
parent6aa5a3dda8f35114706a493abf33b7d0e3c981ee (diff)
downloadfreebsd-ports-gnome-2d48543fe382e23eb2fed97f10dbc0ac70a06125.tar.gz
freebsd-ports-gnome-2d48543fe382e23eb2fed97f10dbc0ac70a06125.tar.zst
freebsd-ports-gnome-2d48543fe382e23eb2fed97f10dbc0ac70a06125.zip
Small C program which is used to alter your mime-encoded mailpacks
- Insert disclaimers - Insert arbitary X-headers - Modify existing headers - Remove attachments based on filename or content-type - Replace attachments based on filename PR: ports/76661 Submitted by: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/altermime/Makefile37
-rw-r--r--mail/altermime/distinfo2
-rw-r--r--mail/altermime/pkg-descr15
4 files changed, 55 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index a0c22f3d0600..3c2f9c64ae12 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -8,6 +8,7 @@
SUBDIR += addresses
SUBDIR += aileron
SUBDIR += akpop3d
+ SUBDIR += altermime
SUBDIR += althea
SUBDIR += annoyance-filter
SUBDIR += anomy-sanitizer
diff --git a/mail/altermime/Makefile b/mail/altermime/Makefile
new file mode 100644
index 000000000000..4c09727ff3d7
--- /dev/null
+++ b/mail/altermime/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: altermime
+# Date created: 2005-01-25
+# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= altermime
+PORTVERSION= 0.3.5
+CATEGORIES= mail textproc
+MASTER_SITES= http://www.pldaniels.com/altermime/
+
+MAINTAINER= itetcu@people.tecnik93.com
+COMMENT= Small C program which is used to alter your mime-encoded mailpacks
+
+PLIST_FILES= bin/altermime
+
+USE_REINPLACE= yes
+
+PORTDOCS= CHANGELOG LICENCE README
+
+post-patch:
+ @${REINPLACE_CMD} -e "s/CFLAGS=-Wall -g/CFLAGS=-Wall ${CFLAGS}/" ${WRKSRC}/Makefile
+
+do-build:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} -f Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${LOCALBASE}/bin
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/altermime/distinfo b/mail/altermime/distinfo
new file mode 100644
index 000000000000..c9a2f3511b67
--- /dev/null
+++ b/mail/altermime/distinfo
@@ -0,0 +1,2 @@
+MD5 (altermime-0.3.5.tar.gz) = 7c178b25514e86d0e7e432ee94aa013f
+SIZE (altermime-0.3.5.tar.gz) = 66253
diff --git a/mail/altermime/pkg-descr b/mail/altermime/pkg-descr
new file mode 100644
index 000000000000..82281ff26aef
--- /dev/null
+++ b/mail/altermime/pkg-descr
@@ -0,0 +1,15 @@
+What can alterMIME do?
+
+- Insert disclaimers
+- Insert arbitary X-headers
+- Modify existing headers
+- Remove attachments based on filename or content-type
+- Replace attachments based on filename
+
+For using with postfix see:
+http://www.paw.co.za/docs/howtos/postfix-altermime/postfix-altermime-howto.html
+
+WWW: http://www.pldaniels.com/altermime/
+
+-IOnut
+<itetcu@people.tecnik93.com>