aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorjmelo <jmelo@FreeBSD.org>2006-11-06 20:36:43 +0800
committerjmelo <jmelo@FreeBSD.org>2006-11-06 20:36:43 +0800
commit2dd22bf0c69525359a56d2f58fc5c736f597f445 (patch)
tree0c58ebae0e299903772800e5cd92c15968c86d12 /mail
parent745e825168c4eab3ace99ae364606248df4f0938 (diff)
downloadfreebsd-ports-gnome-2dd22bf0c69525359a56d2f58fc5c736f597f445.tar.gz
freebsd-ports-gnome-2dd22bf0c69525359a56d2f58fc5c736f597f445.tar.zst
freebsd-ports-gnome-2dd22bf0c69525359a56d2f58fc5c736f597f445.zip
- Fix codec error on python 2.5.
PR: ports/104429 Submitted by: NIIMI Satoshi <sa2c@sa2c.net>
Diffstat (limited to 'mail')
-rw-r--r--mail/mailman/Makefile5
-rw-r--r--mail/mailman/files/patch-misc::paths.py.in41
-rw-r--r--mail/mailman/pkg-plist4
3 files changed, 46 insertions, 4 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index c14a74b0df9a..fcf23df37db6 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mailman
DISTVERSION= 2.1.9
+PORTREVISION= 1
CATEGORIES?= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.list.org/
@@ -25,7 +26,7 @@ OPTIONS= SENDMAIL "for use with sendmail" off \
HTDIG "htdig integration patches" off
HAS_CONFIGURE= yes
-USE_PYTHON= 2.4
+USE_PYTHON= yes
CONFIGURE_ARGS= --prefix=${MAILMANDIR} --with-python=${PYTHON_CMD} \
--with-username=${MM_USERNAME} \
--with-groupname=${MM_GROUPNAME} \
@@ -95,7 +96,7 @@ RUN_DEPENDS+= ${PYTHONPREFIX_SITELIBDIR}/cjkcodecs.pth:${PORTSDIR}/converters/py
.endif
.if defined(WITH_HTDIG)
-BROKEN= patch to mailman 2.1.9 was not released yet, please remove htdig option and try again.
+BROKEN= patch to mailman 2.1.9 was not released yet, please remove htdig option and try again.
PATCH_SITES+= http://www.openinfo.co.uk/mm/patches/444879/:patch1 \
http://www.openinfo.co.uk/mm/patches/444884/:patch2
PATCHFILES+= indexing-2.1.6-0.1.patch.gz:patch1 \
diff --git a/mail/mailman/files/patch-misc::paths.py.in b/mail/mailman/files/patch-misc::paths.py.in
new file mode 100644
index 000000000000..f7db8a1d5d8c
--- /dev/null
+++ b/mail/mailman/files/patch-misc::paths.py.in
@@ -0,0 +1,41 @@
+Index: misc/paths.py.in
+--- branches/Release_2_1-maint/mailman/misc/paths.py.in 2005/12/30 18:50:08 7694
++++ branches/Release_2_1-maint/mailman/misc/paths.py.in 2006/10/12 00:48:48 8056
+@@ -35,6 +35,19 @@
+ if exec_prefix == '${prefix}':
+ exec_prefix = prefix
+
++# Check if ja/ko codecs are available before changing path.
++try:
++ s = unicode('OK', 'iso-2022-jp')
++ jaok = True
++except LookupError:
++ jaok = False
++
++try:
++ s = unicode('OK', 'euc-kr')
++ kook = True
++except LookupError:
++ kook = False
++
+ # Hack the path to include the parent directory of the $prefix/Mailman package
+ # directory.
+ sys.path.insert(0, prefix)
+@@ -53,12 +66,14 @@
+ # In a normal interactive Python environment, the japanese.pth and korean.pth
+ # files would be imported automatically. But because we inhibit the importing
+ # of the site module, we need to be explicit about importing these codecs.
+-import japanese
++if not jaok:
++ import japanese
+ # As of KoreanCodecs 2.0.5, you had to do the second import to get the Korean
+ # codecs installed, however leave the first import in there in case an upgrade
+ # changes this.
+-import korean
+-import korean.aliases
++if not kook:
++ import korean
++ import korean.aliases
+ # Arabic and Hebrew (RFC-1556) encoding aliases. (temporary solution)
+ import encodings.aliases
+ encodings.aliases.aliases.update({
diff --git a/mail/mailman/pkg-plist b/mail/mailman/pkg-plist
index f0e8c7369dea..6b30b8d84b85 100644
--- a/mail/mailman/pkg-plist
+++ b/mail/mailman/pkg-plist
@@ -642,7 +642,7 @@
%%MMDIR%%/templates/ar/admindbdetails.html
%%MMDIR%%/templates/ar/admindbpreamble.html
%%MMDIR%%/templates/ar/admindbsummary.html
-%%MMDIR%%/templates/ar/admlogin.html
+%%MMDIR%%/templates/ar/admlogin.html
%%MMDIR%%/templates/ar/archidxentry.html
%%MMDIR%%/templates/ar/archidxfoot.html
%%MMDIR%%/templates/ar/archidxhead.html
@@ -651,7 +651,7 @@
%%MMDIR%%/templates/ar/archtoc.html
%%MMDIR%%/templates/ar/archtocentry.html
%%MMDIR%%/templates/ar/archtocnombox.html
-%%MMDIR%%/templates/ar/article.html
+%%MMDIR%%/templates/ar/article.html
%%MMDIR%%/templates/ar/emptyarchive.html
%%MMDIR%%/templates/ar/headfoot.html
%%MMDIR%%/templates/ar/listinfo.html