aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-07-05 07:04:48 +0800
committergarga <garga@FreeBSD.org>2006-07-05 07:04:48 +0800
commit4d632c7d57cd41db76307ac53bf7b6b8d3805917 (patch)
tree5e50c37f9a86d5a81db8803679f5966829f9eab3 /mail
parenta8136e5b792e9263486017196eb62fc16faf66e1 (diff)
downloadfreebsd-ports-gnome-4d632c7d57cd41db76307ac53bf7b6b8d3805917.tar.gz
freebsd-ports-gnome-4d632c7d57cd41db76307ac53bf7b6b8d3805917.tar.zst
freebsd-ports-gnome-4d632c7d57cd41db76307ac53bf7b6b8d3805917.zip
Checks for updates to your currently running plugins by parsing the
SM site, and gives a description of any recent changes that have been made to the plugin. Also displays the current stable version of SM and lets you know what version of SM you are running. WWW: http://www.squirrelmail.org/plugin_view.php?id=68 PR: ports/99563 Submitted by: Thomas Abthorpe <thomas@goodking.ca>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/squirrelmail-pupdate-plugin/Makefile76
-rw-r--r--mail/squirrelmail-pupdate-plugin/distinfo3
-rw-r--r--mail/squirrelmail-pupdate-plugin/files/pkg-message.in5
-rw-r--r--mail/squirrelmail-pupdate-plugin/pkg-descr8
-rw-r--r--mail/squirrelmail-pupdate-plugin/pkg-plist20
6 files changed, 113 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 4c8a57f6c5ba..ac089dfb92a1 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -518,6 +518,7 @@
SUBDIR += squirrelmail-newuser_wiz-plugin
SUBDIR += squirrelmail-notes-plugin
SUBDIR += squirrelmail-notify-plugin
+ SUBDIR += squirrelmail-pupdate-plugin
SUBDIR += squirrelmail-quota_usage-plugin
SUBDIR += squirrelmail-secure_login-plugin
SUBDIR += squirrelmail-vlogin-plugin
diff --git a/mail/squirrelmail-pupdate-plugin/Makefile b/mail/squirrelmail-pupdate-plugin/Makefile
new file mode 100644
index 000000000000..5e7d97141001
--- /dev/null
+++ b/mail/squirrelmail-pupdate-plugin/Makefile
@@ -0,0 +1,76 @@
+# New ports collection makefile for: squirrelmail-pupdate-plugin
+# Date created: 2006-06-27
+# Whom: Thomas Abthorpe <thomas@goodking.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTVERSION= 0.7
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}.${PORTVERSION}-1.4.2
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= thomas@goodking.ca
+COMMENT= Checks for plugin updates by parsing the SM site
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
+ ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+
+SQUIRREL_PLUGIN_NAME= pupdate
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
+.else
+.ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
+.else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= "SQUIRRELDIR=squirrelmail"
+.endif
+.endif
+
+SUB_FILES= pkg-message
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+ @${ECHO} ""
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/squirrelmail-pupdate-plugin/distinfo b/mail/squirrelmail-pupdate-plugin/distinfo
new file mode 100644
index 000000000000..c514e931b30f
--- /dev/null
+++ b/mail/squirrelmail-pupdate-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/pupdate.0.7-1.4.2.tar.gz) = c5b8015e040929b97b2ec6e840f0fb1b
+SHA256 (squirrelmail/pupdate.0.7-1.4.2.tar.gz) = acd0de8f96b14cc300ea674118dbf415beb0053577facd15b5cdef49e0e54158
+SIZE (squirrelmail/pupdate.0.7-1.4.2.tar.gz) = 12337
diff --git a/mail/squirrelmail-pupdate-plugin/files/pkg-message.in b/mail/squirrelmail-pupdate-plugin/files/pkg-message.in
new file mode 100644
index 000000000000..a1274c89c101
--- /dev/null
+++ b/mail/squirrelmail-pupdate-plugin/files/pkg-message.in
@@ -0,0 +1,5 @@
+For the port to work properly you must copy the file
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/pupdate/config.php.sample
+to
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/pupdate/config.php
+and edit the configuration to meet your needs.
diff --git a/mail/squirrelmail-pupdate-plugin/pkg-descr b/mail/squirrelmail-pupdate-plugin/pkg-descr
new file mode 100644
index 000000000000..fff656b6c5dd
--- /dev/null
+++ b/mail/squirrelmail-pupdate-plugin/pkg-descr
@@ -0,0 +1,8 @@
+Checks for updates to your currently running plugins by parsing the
+SM site, and gives a description of any recent changes that have
+been made to the plugin.
+
+Also displays the current stable version of SM and lets you know
+what version of SM you are running.
+
+WWW: http://www.squirrelmail.org/plugin_view.php?id=68
diff --git a/mail/squirrelmail-pupdate-plugin/pkg-plist b/mail/squirrelmail-pupdate-plugin/pkg-plist
new file mode 100644
index 000000000000..0011274cdf9a
--- /dev/null
+++ b/mail/squirrelmail-pupdate-plugin/pkg-plist
@@ -0,0 +1,20 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin pupdate; fi
+%%SQUIRRELDIR%%/plugins/pupdate/docs/index.php
+%%SQUIRRELDIR%%/plugins/pupdate/docs/INSTALL
+%%SQUIRRELDIR%%/plugins/pupdate/docs/README
+%%SQUIRRELDIR%%/plugins/pupdate/udata/core.dat
+%%SQUIRRELDIR%%/plugins/pupdate/udata/defaultdirs.dat
+%%SQUIRRELDIR%%/plugins/pupdate/udata/pluginlist.dat
+%%SQUIRRELDIR%%/plugins/pupdate/udata/index.php
+%%SQUIRRELDIR%%/plugins/pupdate/udata/pluginlist2.dat
+%%SQUIRRELDIR%%/plugins/pupdate/udata/defaultdirs2.dat
+%%SQUIRRELDIR%%/plugins/pupdate/update.php
+%%SQUIRRELDIR%%/plugins/pupdate/version
+%%SQUIRRELDIR%%/plugins/pupdate/optblock.php
+%%SQUIRRELDIR%%/plugins/pupdate/index.php
+%%SQUIRRELDIR%%/plugins/pupdate/config.php.sample
+%%SQUIRRELDIR%%/plugins/pupdate/setup.php
+@dirrm %%SQUIRRELDIR%%/plugins/pupdate/docs
+@dirrm %%SQUIRRELDIR%%/plugins/pupdate/udata
+@dirrm %%SQUIRRELDIR%%/plugins/pupdate
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin pupdate; fi