aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-11-01 08:12:59 +0800
committerclsung <clsung@FreeBSD.org>2006-11-01 08:12:59 +0800
commit51afaee0d734b4b6c1b38cf13e581962c82d4480 (patch)
treeea7b359365b684c03c755cb3b8139435f91f8f5a /mail
parent57224ca7678eea5c20a206597c6b2216286502ec (diff)
downloadfreebsd-ports-gnome-51afaee0d734b4b6c1b38cf13e581962c82d4480.tar.gz
freebsd-ports-gnome-51afaee0d734b4b6c1b38cf13e581962c82d4480.tar.zst
freebsd-ports-gnome-51afaee0d734b4b6c1b38cf13e581962c82d4480.zip
Net::SMTP_auth implements a client interface to the SMTP and ESMTP protocol
AUTH service extension, enabling a perl5 application to talk to and authenticate against SMTP servers. This documentation assumes that you are familiar with the concepts of the SMTP protocol described in RFC821 and with the AUTH service extension described in RFC2554. WWW: http://search.cpan.org/dist/Net-SMTP_auth/
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Net-SMTP_auth/Makefile37
-rw-r--r--mail/p5-Net-SMTP_auth/distinfo3
-rw-r--r--mail/p5-Net-SMTP_auth/pkg-descr7
-rw-r--r--mail/p5-Net-SMTP_auth/pkg-plist6
5 files changed, 54 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 5c25dc42c9fc..54f0fa781d71 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -348,6 +348,7 @@
SUBDIR += p5-Net-QMTP
SUBDIR += p5-Net-SMTP-Server
SUBDIR += p5-Net-SMTP-TLS
+ SUBDIR += p5-Net-SMTP_auth
SUBDIR += p5-Net-Server-Mail
SUBDIR += p5-POE-Component-Client-POP3
SUBDIR += p5-POE-Component-Client-SMTP
diff --git a/mail/p5-Net-SMTP_auth/Makefile b/mail/p5-Net-SMTP_auth/Makefile
new file mode 100644
index 000000000000..e87a8e367a8d
--- /dev/null
+++ b/mail/p5-Net-SMTP_auth/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Net-SMTP_auth
+# Date created: 2006-10-31
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SMTP_auth
+PORTVERSION= 0.08
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Simple Mail Transfer Protocol Client with AUTHentication
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL \
+ ${SITE_PERL}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-HMAC
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::SMTP_auth.3
+
+.include <bsd.port.pre.mk>
+
+#.if ${PERL_LEVEL} < 500600
+#IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 then try again
+#.endif
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS+= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-Net-SMTP_auth/distinfo b/mail/p5-Net-SMTP_auth/distinfo
new file mode 100644
index 000000000000..a0a98c9d33e6
--- /dev/null
+++ b/mail/p5-Net-SMTP_auth/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-SMTP_auth-0.08.tar.gz) = 23a911893c92c7c26ab9a78882691d9c
+SHA256 (Net-SMTP_auth-0.08.tar.gz) = d6ff0b477394801f97b63a985c223989d904e24a10ff8ddcb3b52de8fb025a03
+SIZE (Net-SMTP_auth-0.08.tar.gz) = 5365
diff --git a/mail/p5-Net-SMTP_auth/pkg-descr b/mail/p5-Net-SMTP_auth/pkg-descr
new file mode 100644
index 000000000000..baab12808247
--- /dev/null
+++ b/mail/p5-Net-SMTP_auth/pkg-descr
@@ -0,0 +1,7 @@
+Net::SMTP_auth implements a client interface to the SMTP and ESMTP protocol
+AUTH service extension, enabling a perl5 application to talk to and
+authenticate against SMTP servers. This documentation assumes that you are
+familiar with the concepts of the SMTP protocol described in RFC821 and with
+the AUTH service extension described in RFC2554.
+
+WWW: http://search.cpan.org/dist/Net-SMTP_auth/
diff --git a/mail/p5-Net-SMTP_auth/pkg-plist b/mail/p5-Net-SMTP_auth/pkg-plist
new file mode 100644
index 000000000000..138a54786733
--- /dev/null
+++ b/mail/p5-Net-SMTP_auth/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SMTP_auth/.packlist
+%%SITE_PERL%%/Net/SMTP_auth.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SMTP_auth
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net