aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2008-08-10 17:48:15 +0800
committerache <ache@FreeBSD.org>2008-08-10 17:48:15 +0800
commit651f84e2fa1b8d7975819e81fb0500166befa734 (patch)
treeb3634def760ca35000fba4f76fe21fdef5a8e970 /mail
parentabfb2a42d3cee2ee6a6c2442d2957bf4501ec533 (diff)
downloadfreebsd-ports-gnome-651f84e2fa1b8d7975819e81fb0500166befa734.tar.gz
freebsd-ports-gnome-651f84e2fa1b8d7975819e81fb0500166befa734.tar.zst
freebsd-ports-gnome-651f84e2fa1b8d7975819e81fb0500166befa734.zip
Use sendmail/bsd.milter.mk to fix dependence for various sendmail port
options. Submitted by: Dirk Meyer <dirk.meyer@dinoex.sub.org>
Diffstat (limited to 'mail')
-rw-r--r--mail/milter-greylist/Makefile25
1 files changed, 5 insertions, 20 deletions
diff --git a/mail/milter-greylist/Makefile b/mail/milter-greylist/Makefile
index 1bb88334d32b..fc138368e41d 100644
--- a/mail/milter-greylist/Makefile
+++ b/mail/milter-greylist/Makefile
@@ -35,24 +35,6 @@ MAN5= greylist.conf.5
MAN8= milter-greylist.8
.endif
-.if !defined(WITH_SENDMAIL_BASE) && \
- !defined(WITH_SENDMAIL_PORT) && \
- !exists(${LOCALBASE}/lib/libmilter.a)
-WITH_SENDMAIL_BASE=yes
-.endif
-
-.if defined(WITH_SENDMAIL_BASE)
-.if exists(/usr/lib/libmilter.a)
-_MILT_DEP=
-MILTERBASE= /usr
-.else
-BROKEN= Base system sendmail not found or too old, rebuild with WITH_SENDMAIL_PORT=yes
-.endif
-.else
-_MILT_DEP= ${LOCALBASE}/lib/libmilter.a:${PORTSDIR}/mail/sendmail
-MILTERBASE?= ${LOCALBASE}
-.endif
-
##
# If you have a reentrant resolver (starting with RELENG_5_2) you can use SPF
##
@@ -69,7 +51,6 @@ BUILD_DEPENDS+= curl>=7.18:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --with-curl=${LOCALBASE}
.endif
RUN_DEPENDS+= ${BUILD_DEPENDS}
-BUILD_DEPENDS+= ${_MILT_DEP}
CFLAGS+= ${PTHREAD_CFLAGS}
LIBS+= ${PTHREAD_LIBS}
@@ -120,4 +101,8 @@ post-install:
) || ${TRUE}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
+
+.include <bsd.port.post.mk>