aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-05-02 23:46:02 +0800
committergarga <garga@FreeBSD.org>2006-05-02 23:46:02 +0800
commit65f483ac84f61ad2b4ce72ce5f758004da40a24c (patch)
treec3fa802f6934c7fef25698a8f3345b2f08a01b1d /mail
parent551a083a8da5e863881ab58c55abd2e418231a71 (diff)
downloadfreebsd-ports-gnome-65f483ac84f61ad2b4ce72ce5f758004da40a24c.tar.gz
freebsd-ports-gnome-65f483ac84f61ad2b4ce72ce5f758004da40a24c.tar.zst
freebsd-ports-gnome-65f483ac84f61ad2b4ce72ce5f758004da40a24c.zip
Lens is a mail filter written in Ruby. Lens can filter an
incoming mail when it is received and filter mails in a Maildir. Author: Toshiyuki Masui WWW: http://pitecan.com/Lens/ PR: ports/95150 Submitted by: TAKATSU Tomonari <tota@rtfm.jp>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/lens/Makefile36
-rw-r--r--mail/lens/distinfo3
-rw-r--r--mail/lens/pkg-descr5
-rw-r--r--mail/lens/pkg-plist12
5 files changed, 57 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 2ab249e03741..901ef06b3185 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -154,6 +154,7 @@
SUBDIR += kiltdown
SUBDIR += kshowmail
SUBDIR += lbdb
+ SUBDIR += lens
SUBDIR += libdomainkeys
SUBDIR += libesmtp
SUBDIR += libetpan
diff --git a/mail/lens/Makefile b/mail/lens/Makefile
new file mode 100644
index 000000000000..716fcfcdbebe
--- /dev/null
+++ b/mail/lens/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Lens
+# Date created: 2006-03-31
+# Whom: TAKATSU Tomonari <tota@rtfm.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lens
+PORTVERSION= 0.2
+CATEGORIES= mail ruby
+MASTER_SITES= http://pitecan.com/Lens/
+
+MAINTAINER= tota@rtfm.jp
+COMMENT= A mail filter written in Ruby
+
+NO_BUILD= yes
+USE_RUBY= yes
+
+LIB_FILES= lens.rb maildir.rb message.rb parsedate.rb classify.rb
+RUBY_SHEBANG_FILES= lens
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/lens ${PREFIX}/bin
+ @${MKDIR} ${RUBY_SITELIBDIR}/lens
+.for f in ${LIB_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_SITELIBDIR}/lens
+.endfor
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/lensrc.sample ${EXAMPLESDIR}/dot.lensrc
+ ${INSTALL_DATA} ${WRKSRC}/commandmailrc.sample ${EXAMPLESDIR}/dot.commandmailrc
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/index.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/lens/distinfo b/mail/lens/distinfo
new file mode 100644
index 000000000000..c44cb4ff5393
--- /dev/null
+++ b/mail/lens/distinfo
@@ -0,0 +1,3 @@
+MD5 (lens-0.2.tar.gz) = cf2b45f038d65233e91b78d56abb5ba8
+SHA256 (lens-0.2.tar.gz) = e3c559ade7246784d03e7139a0fad253e77cc25594fee54f896b182c86244d52
+SIZE (lens-0.2.tar.gz) = 7786
diff --git a/mail/lens/pkg-descr b/mail/lens/pkg-descr
new file mode 100644
index 000000000000..7bf508f14770
--- /dev/null
+++ b/mail/lens/pkg-descr
@@ -0,0 +1,5 @@
+Lens is a mail filter written in Ruby. Lens can filter an
+incoming mail when it is received and filter mails in a Maildir.
+
+Author: Toshiyuki Masui
+WWW: http://pitecan.com/Lens/
diff --git a/mail/lens/pkg-plist b/mail/lens/pkg-plist
new file mode 100644
index 000000000000..42ebe78ef1d1
--- /dev/null
+++ b/mail/lens/pkg-plist
@@ -0,0 +1,12 @@
+bin/lens
+%%RUBY_SITELIBDIR%%/lens/classify.rb
+%%RUBY_SITELIBDIR%%/lens/lens.rb
+%%RUBY_SITELIBDIR%%/lens/maildir.rb
+%%RUBY_SITELIBDIR%%/lens/message.rb
+%%RUBY_SITELIBDIR%%/lens/parsedate.rb
+@dirrm %%RUBY_SITELIBDIR%%/lens
+%%EXAMPLESDIR%%/dot.commandmailrc
+%%EXAMPLESDIR%%/dot.lensrc
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%