aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-10-05 14:42:57 +0800
committerreg <reg@FreeBSD.org>2000-10-05 14:42:57 +0800
commit72ce7050d03c812e37966786e11996a90713afea (patch)
tree9ec01d647da1c4e80223e31fc766740c2a43ebff /mail
parent97830337b8c0333a12d15a49ea1f9c9cdc3dfddf (diff)
downloadfreebsd-ports-gnome-72ce7050d03c812e37966786e11996a90713afea.tar.gz
freebsd-ports-gnome-72ce7050d03c812e37966786e11996a90713afea.tar.zst
freebsd-ports-gnome-72ce7050d03c812e37966786e11996a90713afea.zip
Implement USE_GTK, part 2.
Diffstat (limited to 'mail')
-rw-r--r--mail/gbuffy/Makefile11
-rw-r--r--mail/spruce/Makefile13
2 files changed, 8 insertions, 16 deletions
diff --git a/mail/gbuffy/Makefile b/mail/gbuffy/Makefile
index 424dbcff2ebf..e9e90322ce16 100644
--- a/mail/gbuffy/Makefile
+++ b/mail/gbuffy/Makefile
@@ -12,17 +12,12 @@ MASTER_SITES= http://www.fiction.net/blong/programs/gbuffy/
MAINTAINER= kaj@Raditex.se
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- PropList.2:${PORTSDIR}/devel/libPropList \
+LIB_DEPENDS= PropList.2:${PORTSDIR}/devel/libPropList \
compface.1:${PORTSDIR}/mail/faces
-GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
USE_X_PREFIX= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
- GTK_CONFIG="${GTK_CONFIG}" \
- GLIB_CONFIG="${GLIB_CONFIG}"
+USE_GTK= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
diff --git a/mail/spruce/Makefile b/mail/spruce/Makefile
index c4ce40b345ea..707f01163541 100644
--- a/mail/spruce/Makefile
+++ b/mail/spruce/Makefile
@@ -13,17 +13,14 @@ MASTER_SITES= http://www.xtorshun.org/spruce/v0.6/ \
MAINTAINER= erich@tacni.net
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
-
-GTK_CONFIG= ${X11BASE}/bin/gtk12-config
-GLIB_CONFIG= ${LOCALBASE}/bin/glib12-config
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= GTK_CONFIG=${GTK_CONFIG} GLIB_CONFIG=${GLIB_CONFIG} \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
- CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
USE_GMAKE= yes
+USE_GTK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
MAN1= spruce.1