aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-05-30 22:41:41 +0800
committerkwm <kwm@FreeBSD.org>2014-05-30 22:41:41 +0800
commitb7fe28a16ab0c19be04a88a4a0085628db4d9597 (patch)
tree7c2e18465d51997afbf070d8a1563f97d62408b2 /mail
parent2f9886e13ba538ec0325e6dad7b43c7a7eb6988d (diff)
downloadfreebsd-ports-gnome-b7fe28a16ab0c19be04a88a4a0085628db4d9597.tar.gz
freebsd-ports-gnome-b7fe28a16ab0c19be04a88a4a0085628db4d9597.tar.zst
freebsd-ports-gnome-b7fe28a16ab0c19be04a88a4a0085628db4d9597.zip
Switch libmapi to use samba 4.1 by default, provide option if samba
4.0 is prefered. Lightly based on a patch by: Joe Maloney
Diffstat (limited to 'mail')
-rw-r--r--mail/libmapi/Makefile18
-rw-r--r--mail/libmapi/pkg-plist30
2 files changed, 30 insertions, 18 deletions
diff --git a/mail/libmapi/Makefile b/mail/libmapi/Makefile
index b9fb6bba7ab9..288bdef6afe2 100644
--- a/mail/libmapi/Makefile
+++ b/mail/libmapi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libmapi
PORTVERSION= 2.1
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://tracker.openchange.org/attachments/download/${DOWNLOADCODE}/
DISTNAME= openchange-${PORTVERSION}-${CODENAME}
@@ -10,13 +11,13 @@ DISTNAME= openchange-${PORTVERSION}-${CODENAME}
MAINTAINER= kwm@FreeBSD.org
COMMENT= Open Source implementation of Microsoft Exchange protocols
-BUILD_DEPENDS= samba4>=4.0.1:${PORTSDIR}/net/samba4 \
+BUILD_DEPENDS= ${SAMBA_DEP} \
p5-Parse-Pidl>=4.0.1:${PORTSDIR}/devel/p5-Parse-Pidl
LIB_DEPENDS= libical.so:${PORTSDIR}/devel/libical \
libtdb.so:${PORTSDIR}/databases/tdb \
libtevent.so:${PORTSDIR}/devel/tevent \
libtalloc.so:${PORTSDIR}/devel/talloc
-RUN_DEPENDS= samba4>=4.0.1:${PORTSDIR}/net/samba4
+RUN_DEPENDS= ${SAMBA_DEP}
CODENAME= QUADRANT
DOWNLOADCODE= 244
@@ -37,13 +38,24 @@ SHEBANG_FILES= libmapi/conf/mparse.pl \
setup/openchange_provision
OPTIONS_SUB= yes
-OPTIONS_DEFINE= BOOST DOXYGEN
+OPTIONS_DEFINE= BOOST DOXYGEN SAMBA40
OPTIONS_DEFAULT=BOOST
BOOST_LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
BOOST_CONFIGURE_ENV_OFF= ov_cv_boost_thread=no
BOOST_DESC= libmapi C++ library (needs boost)
DOXYGEN_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
DOXYGEN_CONFIGURE_ENV_OFF= ac_cv_path_DOXYGEN=""
+SAMBA40_DESC= Build agains samba 4.0 instead of 4.1
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSAMBA40}
+SAMBA_DEP= samba4>=4.0.1:${PORTSDIR}/net/samba4
+PLIST_SUB+= SAMBA=samba4
+.else
+SAMBA_DEP= samba41>=4.1.0:${PORTSDIR}/net/samba41
+PLIST_SUB+= SAMBA=samba41
+.endif
CONFIGURE_ARGS+= --disable-pymapi
# --enable-openchange-qt4 Compile OpenChange Qt4 wrapper.
diff --git a/mail/libmapi/pkg-plist b/mail/libmapi/pkg-plist
index 0874ebc15a03..798fae79376f 100644
--- a/mail/libmapi/pkg-plist
+++ b/mail/libmapi/pkg-plist
@@ -118,20 +118,20 @@ share/openchange/pictures/header.jpg
share/openchange/pictures/middle_bg.jpg
share/openchange/pictures/nav_tab.gif
share/openchange/pictures/pixel_grey.gif
-share/samba4/setup/AD/oc_provision_configuration.ldif
-share/samba4/setup/AD/oc_provision_configuration_finalize.ldif
-share/samba4/setup/AD/oc_provision_schema.ldif
-share/samba4/setup/AD/oc_provision_schema_attributes.ldif
-share/samba4/setup/AD/oc_provision_schema_auxiliary_class.ldif
-share/samba4/setup/AD/oc_provision_schema_container.ldif
-share/samba4/setup/AD/oc_provision_schema_modify.ldif
-share/samba4/setup/AD/oc_provision_schema_objectCategory.ldif
-share/samba4/setup/AD/oc_provision_schema_possSuperior.ldif
-share/samba4/setup/AD/oc_provision_schema_sub_CfgProtocol.ldif
-share/samba4/setup/AD/oc_provision_schema_sub_mailGateway.ldif
-share/samba4/setup/AD/oc_provision_schema_subcontainer.ldif
-share/samba4/setup/AD/prefixMap.txt
-share/samba4/setup/AD/provision_schema_basedn_modify.ldif
+share/%%SAMBA%%/setup/AD/oc_provision_configuration.ldif
+share/%%SAMBA%%/setup/AD/oc_provision_configuration_finalize.ldif
+share/%%SAMBA%%/setup/AD/oc_provision_schema.ldif
+share/%%SAMBA%%/setup/AD/oc_provision_schema_attributes.ldif
+share/%%SAMBA%%/setup/AD/oc_provision_schema_auxiliary_class.ldif
+share/%%SAMBA%%/setup/AD/oc_provision_schema_container.ldif
+share/%%SAMBA%%/setup/AD/oc_provision_schema_modify.ldif
+share/%%SAMBA%%/setup/AD/oc_provision_schema_objectCategory.ldif
+share/%%SAMBA%%/setup/AD/oc_provision_schema_possSuperior.ldif
+share/%%SAMBA%%/setup/AD/oc_provision_schema_sub_CfgProtocol.ldif
+share/%%SAMBA%%/setup/AD/oc_provision_schema_sub_mailGateway.ldif
+share/%%SAMBA%%/setup/AD/oc_provision_schema_subcontainer.ldif
+share/%%SAMBA%%/setup/AD/prefixMap.txt
+share/%%SAMBA%%/setup/AD/provision_schema_basedn_modify.ldif
share/setup/mapistore/mapistore_namedprops.ldif
share/setup/openchangedb/oc_provision_openchange_init.ldif
share/setup/openchangedb/oc_provision_openchange_mailbox.ldif
@@ -141,7 +141,7 @@ share/setup/profiles/oc_profiles_schema.ldif
@dirrm share/setup/openchangedb
@dirrm share/setup/mapistore
@dirrm share/setup
-@dirrm share/samba4/setup/AD
+@dirrm share/%%SAMBA%%/setup/AD
@dirrm share/openchange/pictures
@dirrm share/openchange
@dirrm share/mapitest/lzxpress