aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-10-07 13:45:04 +0800
committerlinimon <linimon@FreeBSD.org>2007-10-07 13:45:04 +0800
commite9b556135b3e4068be9ec53d65e526a353da19e6 (patch)
tree3631800b38966f03de424f6228f938054f94dd22 /mail
parent6c105d7853336dcccdbcc998e9ac6da17d4439db (diff)
downloadfreebsd-ports-gnome-e9b556135b3e4068be9ec53d65e526a353da19e6.tar.gz
freebsd-ports-gnome-e9b556135b3e4068be9ec53d65e526a353da19e6.tar.zst
freebsd-ports-gnome-e9b556135b3e4068be9ec53d65e526a353da19e6.zip
Set USE_PERL5/WANT_PERL as appropriate, for ports that either depend on
perl unconditonally, or conditionally. To be able to conditionalize the inclusion of bsd.perl.mk, they now need to be defined before the inclusion of bsd.port.pre.mk. Hat: portmgr
Diffstat (limited to 'mail')
-rw-r--r--mail/couriergraph/Makefile1
-rw-r--r--mail/lightning/Makefile1
-rw-r--r--mail/ovs/Makefile1
-rw-r--r--mail/postfix-policyd-weight/Makefile1
-rw-r--r--mail/spampd/Makefile1
-rw-r--r--mail/sympa5/Makefile48
-rw-r--r--mail/thunderbird-esr/Makefile1
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--mail/thunderbird3/Makefile1
9 files changed, 32 insertions, 24 deletions
diff --git a/mail/couriergraph/Makefile b/mail/couriergraph/Makefile
index 3776da4becaa..759cfe659372 100644
--- a/mail/couriergraph/Makefile
+++ b/mail/couriergraph/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= ${SITE_PERL}/RRDp.pm:${PORTSDIR}/databases/rrdtool \
${SITE_PERL}/File/Tail.pm:${PORTSDIR}/devel/p5-File-Tail
NO_BUILD= yes
+USE_PERL5= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
DATADIR?= /var/db/couriergraph
diff --git a/mail/lightning/Makefile b/mail/lightning/Makefile
index 51b20cb0dcf6..4f99a694b426 100644
--- a/mail/lightning/Makefile
+++ b/mail/lightning/Makefile
@@ -25,6 +25,7 @@ HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_BZIP2= yes
WANT_GNOME= yes
+WANT_PERL= yes
LIGHTNING_DIR= lib/thunderbird/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
MOZILLA= thunderbird
MOZILLA_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/icons/default.xpm
diff --git a/mail/ovs/Makefile b/mail/ovs/Makefile
index 78d8fee79af0..aaa17333f1c4 100644
--- a/mail/ovs/Makefile
+++ b/mail/ovs/Makefile
@@ -17,6 +17,7 @@ RUN_DEPENDS= ${SITE_PERL}/RRDp.pm:${PORTSDIR}/databases/rrdtool \
${SITE_PERL}/File/Tail.pm:${PORTSDIR}/devel/p5-File-Tail
NO_BUILD= yes
+USE_PERL5= yes
CGIDIR?= ${PREFIX}/www/cgi-bin
DATADIR?= /var/db/ovs
diff --git a/mail/postfix-policyd-weight/Makefile b/mail/postfix-policyd-weight/Makefile
index 36f9829ea80a..fc4b818a3363 100644
--- a/mail/postfix-policyd-weight/Makefile
+++ b/mail/postfix-policyd-weight/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
SUB_FILES= pkg-message
PLIST_FILES= bin/${PORTNAME} etc/${PORTNAME}.conf.sample
+USE_PERL5= yes
USE_RC_SUBR+= policyd-weight
MAN8+= policyd-weight.8
diff --git a/mail/spampd/Makefile b/mail/spampd/Makefile
index aeed1659ea63..4702fd2d3c81 100644
--- a/mail/spampd/Makefile
+++ b/mail/spampd/Makefile
@@ -19,6 +19,7 @@ RUN_DEPENDS= spamc:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
NO_BUILD= yes
PLIST_FILES= sbin/spampd
+USE_PERL5= yes
USE_RC_SUBR= spampd
do-install:
diff --git a/mail/sympa5/Makefile b/mail/sympa5/Makefile
index b9be45db2a3e..cf0203be92f5 100644
--- a/mail/sympa5/Makefile
+++ b/mail/sympa5/Makefile
@@ -31,6 +31,30 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
LATEST_LINK= sympa5
USE_APACHE= 1.3+
+HAS_CONFIGURE= yes
+USE_PERL5= 5.8.6+
+CONFIGURE_ARGS+=--prefix=${PREFIX} \
+ --with-confdir=${PREFIX}/etc/sympa \
+ --with-initdir=${PREFIX}/etc/rc.d \
+ --with-etcdir=${PREFIX}/etc/sympa \
+ --with-cgidir=${PREFIX}/sympa/cgi-bin \
+ --with-iconsdir=${PREFIX}/sympa/icons \
+ --with-sbindir=${PREFIX}/sbin \
+ --with-libdir=${PREFIX}/lib/sympa \
+ --with-libexecdir=${PREFIX}/libexec/sympa \
+ --with-datadir=${DATADIR} \
+ --with-expldir=${PREFIX}/sympa/expl \
+ --with-lockdir=/var/spool/lock \
+ --with-piddir=/var/run \
+ --with-localedir=${PREFIX}/share/locale \
+ --with-docdir=${DOCSDIR} \
+ --with-sampledir=${EXAMPLESDIR} \
+ --with-spooldir=${PREFIX}/sympa/spool
+CONFIGURE_ENV+= lt_cv_sys_max_cmd_len=${CONFIGURE_MAX_CMD_LEN}
+MAKE_ENV?= PERL_EXTUTILS_AUTOINSTALL=--skip
+
+MAN8= alias_manager.8 archived.8 bounced.8 sympa.8
+
CONFLICTS= sympa-4* sympa-5.[0-2]*
DB_TYPE?=mysql
@@ -66,30 +90,6 @@ BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-
.endif
.endif
-HAS_CONFIGURE= yes
-USE_PERL5= 5.8.6+
-CONFIGURE_ARGS+=--prefix=${PREFIX} \
- --with-confdir=${PREFIX}/etc/sympa \
- --with-initdir=${PREFIX}/etc/rc.d \
- --with-etcdir=${PREFIX}/etc/sympa \
- --with-cgidir=${PREFIX}/sympa/cgi-bin \
- --with-iconsdir=${PREFIX}/sympa/icons \
- --with-sbindir=${PREFIX}/sbin \
- --with-libdir=${PREFIX}/lib/sympa \
- --with-libexecdir=${PREFIX}/libexec/sympa \
- --with-datadir=${DATADIR} \
- --with-expldir=${PREFIX}/sympa/expl \
- --with-lockdir=/var/spool/lock \
- --with-piddir=/var/run \
- --with-localedir=${PREFIX}/share/locale \
- --with-docdir=${DOCSDIR} \
- --with-sampledir=${EXAMPLESDIR} \
- --with-spooldir=${PREFIX}/sympa/spool
-CONFIGURE_ENV+= lt_cv_sys_max_cmd_len=${CONFIGURE_MAX_CMD_LEN}
-MAKE_ENV?= PERL_EXTUTILS_AUTOINSTALL=--skip
-
-MAN8= alias_manager.8 archived.8 bounced.8 sympa.8
-
pre-fetch:
@${ECHO} ""
@${ECHO} "You may use the following build options:"
diff --git a/mail/thunderbird-esr/Makefile b/mail/thunderbird-esr/Makefile
index 11b760257317..2b0d361cd7ef 100644
--- a/mail/thunderbird-esr/Makefile
+++ b/mail/thunderbird-esr/Makefile
@@ -24,6 +24,7 @@ HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GCC= 3.4+
+WANT_PERL= yes
MOZ_EXTENSIONS= wallet,spellcheck,xmlextras,webservices
MOZ_PROTOCOLS= http,file,jar,viewsource,res,data
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 11b760257317..2b0d361cd7ef 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -24,6 +24,7 @@ HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GCC= 3.4+
+WANT_PERL= yes
MOZ_EXTENSIONS= wallet,spellcheck,xmlextras,webservices
MOZ_PROTOCOLS= http,file,jar,viewsource,res,data
diff --git a/mail/thunderbird3/Makefile b/mail/thunderbird3/Makefile
index 11b760257317..2b0d361cd7ef 100644
--- a/mail/thunderbird3/Makefile
+++ b/mail/thunderbird3/Makefile
@@ -24,6 +24,7 @@ HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GCC= 3.4+
+WANT_PERL= yes
MOZ_EXTENSIONS= wallet,spellcheck,xmlextras,webservices
MOZ_PROTOCOLS= http,file,jar,viewsource,res,data