aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-08-26 22:06:08 +0800
committertijl <tijl@FreeBSD.org>2014-08-26 22:06:08 +0800
commitf8357b5cbaa160ccdf9943cac099f5e092c591da (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /mail
parent89a7d6ecbdde724b92ca6650493f56cf68855f35 (diff)
downloadfreebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.tar.gz
freebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.tar.zst
freebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'mail')
-rw-r--r--mail/deforaos-mailer/Makefile5
-rw-r--r--mail/gnubiff/Makefile2
-rw-r--r--mail/mail-notification/files/patch-jbsrc-jb.c10
3 files changed, 14 insertions, 3 deletions
diff --git a/mail/deforaos-mailer/Makefile b/mail/deforaos-mailer/Makefile
index 526efe519066..f5fb52d05b64 100644
--- a/mail/deforaos-mailer/Makefile
+++ b/mail/deforaos-mailer/Makefile
@@ -33,7 +33,8 @@ MAKE_JOBS_UNSAFE= yes
post-patch:
@${REINPLACE_CMD} -e 's|/lib/|/libdata/|g' \
${WRKSRC}/data/pkgconfig.sh
- @${REINPLACE_CMD} 's|`pkg-config --libs openssl` -lssl|-lssl -lcrypto|' \
- ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} 's/-lssl/& -lcrypto/' \
+ ${WRKSRC}/src/Makefile ${WRKSRC}/src/account/Makefile \
+ ${WRKSRC}/src/plugins/Makefile ${WRKSRC}/tests/Makefile
.include <bsd.port.mk>
diff --git a/mail/gnubiff/Makefile b/mail/gnubiff/Makefile
index 73a14c6b5e87..309975632008 100644
--- a/mail/gnubiff/Makefile
+++ b/mail/gnubiff/Makefile
@@ -18,7 +18,7 @@ USE_GNOME= intlhack libglade2 esound
USES= fam gmake pathfix pkgconfig
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lX11
# CXXFLAGS needed to work round issue with gcc and openssl 0.9.8a
# /usr/local/include/openssl/sha.h:173: error: ISO C++ does not support `long long'
diff --git a/mail/mail-notification/files/patch-jbsrc-jb.c b/mail/mail-notification/files/patch-jbsrc-jb.c
new file mode 100644
index 000000000000..1b755b97f41a
--- /dev/null
+++ b/mail/mail-notification/files/patch-jbsrc-jb.c
@@ -0,0 +1,10 @@
+--- jbsrc/jb.c.orig
++++ jbsrc/jb.c
+@@ -444,6 +444,7 @@
+ jb_compile_options_add_ldflags(object->compile_options, "-Wl,--export-dynamic");
+
+ jb_compile_options_add_libs(object->compile_options, "-lm");
++ jb_compile_options_add_libs(object->compile_options, "-lX11");
+
+ jb_compile_options_add_package(object->compile_options, "gettext");
+ jb_compile_options_add_package(object->compile_options, "gnome");