aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2011-07-01 02:13:19 +0800
committerflo <flo@FreeBSD.org>2011-07-01 02:13:19 +0800
commit0250b780654823e44510b7fb06ba81886711d652 (patch)
tree2b4dabcc3686ede76d81e68adfd25c192fdec2ec /mail
parent7c9f469b0fe8db8effdc8f16af84d71a2ada5181 (diff)
downloadfreebsd-ports-gnome-0250b780654823e44510b7fb06ba81886711d652.tar.gz
freebsd-ports-gnome-0250b780654823e44510b7fb06ba81886711d652.tar.zst
freebsd-ports-gnome-0250b780654823e44510b7fb06ba81886711d652.zip
add missing files and add a forgotten patch to remove 6.X support
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird3/Makefile7
-rw-r--r--mail/thunderbird3/files/patch-directory-sdks-c-sdk-ldap-libraries-libldap-Makefile.in13
-rw-r--r--mail/thunderbird3/files/patch-directory-sdks-c-sdk-ldap-libraries-libprldap-Makefile.in14
-rw-r--r--mail/thunderbird3/files/patch-mozilla-js-ctypes-libffi-configure14
-rw-r--r--mail/thunderbird3/files/patch-mozilla-js-src-jslock.cpp18
-rw-r--r--mail/thunderbird3/files/patch-mozilla-security_nss_lib_freebl_mpi_mpcpucache.c43
6 files changed, 102 insertions, 7 deletions
diff --git a/mail/thunderbird3/Makefile b/mail/thunderbird3/Makefile
index fea7ad6d9c77..a4252d88a22a 100644
--- a/mail/thunderbird3/Makefile
+++ b/mail/thunderbird3/Makefile
@@ -57,13 +57,6 @@ OPTIONS=
WRKSRC= ${WRKDIR}/comm-1.9.2
MOZSRC:= ${WRKSRC}/mozilla
-.if ${OSVERSION} < 700000
-LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
-EXTRA_PATCHES= ${FILESDIR}/releng6_pulseaudio
-.else
-EXTRA_PATCHES= ${FILESDIR}/liboggplay_oss
-.endif
-
.if ${ARCH} == powerpc64
.if ${OSVERSION} < 900033
BROKEN= Needs binutils 2.17.50 to build
diff --git a/mail/thunderbird3/files/patch-directory-sdks-c-sdk-ldap-libraries-libldap-Makefile.in b/mail/thunderbird3/files/patch-directory-sdks-c-sdk-ldap-libraries-libldap-Makefile.in
new file mode 100644
index 000000000000..8a065107cd16
--- /dev/null
+++ b/mail/thunderbird3/files/patch-directory-sdks-c-sdk-ldap-libraries-libldap-Makefile.in
@@ -0,0 +1,13 @@
+--- directory/sdks/c-sdk/ldap/libraries/libldap/Makefile.in.orig 2009-11-10 09:56:42.000000000 +0100
++++ directory/sdks/c-sdk/ldap/libraries/libldap/Makefile.in 2009-11-10 09:58:15.000000000 +0100
+@@ -254,6 +254,10 @@
+ EXTRA_LIBS = -L$(dist_libdir) -l$(LBER_LIBNAME) -lbe
+ endif
+
++ifeq ($(OS_ARCH), FreeBSD)
++EXTRA_LIBS = -L$(dist_libdir) -l$(LBER_LIBNAME) -lpthread
++endif
++
+ ifeq ($(OS_ARCH), NetBSD)
+ EXTRA_LIBS = -L$(dist_libdir) -l$(LBER_LIBNAME)
+ endif
diff --git a/mail/thunderbird3/files/patch-directory-sdks-c-sdk-ldap-libraries-libprldap-Makefile.in b/mail/thunderbird3/files/patch-directory-sdks-c-sdk-ldap-libraries-libprldap-Makefile.in
new file mode 100644
index 000000000000..ff5e375f156b
--- /dev/null
+++ b/mail/thunderbird3/files/patch-directory-sdks-c-sdk-ldap-libraries-libprldap-Makefile.in
@@ -0,0 +1,14 @@
+--- directory/sdks/c-sdk/ldap/libraries/libprldap/Makefile.in.orig 2008-09-11 16:38:35.000000000 +0200
++++ directory/sdks/c-sdk/ldap/libraries/libprldap/Makefile.in 2009-12-09 08:53:46.000000000 +0100
+@@ -147,6 +147,11 @@
+ CUSTOM_LIBS=1
+ endif
+
++ifeq ($(OS_ARCH), FreeBSD)
++EXTRA_LIBS = -L$(dist_libdir) -l$(LBER_LIBNAME) -lpthread
++CUSTOM_LIBS=1
++endif
++
+ # no extra libs on HP-UX
+ ifeq ($(OS_ARCH), HP-UX)
+ CUSTOM_LIBS=1
diff --git a/mail/thunderbird3/files/patch-mozilla-js-ctypes-libffi-configure b/mail/thunderbird3/files/patch-mozilla-js-ctypes-libffi-configure
new file mode 100644
index 000000000000..6a86c5e6fc39
--- /dev/null
+++ b/mail/thunderbird3/files/patch-mozilla-js-ctypes-libffi-configure
@@ -0,0 +1,14 @@
+B
+--- mozilla/js/ctypes/libffi/configure.orig 2011-02-26 21:17:36.000000000 +0100
++++ mozilla/js/ctypes/libffi/configure 2011-02-26 21:18:35.000000000 +0100
+@@ -21036,6 +21036,9 @@
+
+ powerpc-*-freebsd*)
+ TARGET=POWERPC_FREEBSD; TARGETDIR=powerpc
+ ;;
++ powerpc64-*-freebsd*)
++ TARGET=POWERPC; TARGETDIR=powerpc
++ ;;
+ powerpc*-*-rtems*)
+ TARGET=POWERPC; TARGETDIR=powerpc
+ ;;
diff --git a/mail/thunderbird3/files/patch-mozilla-js-src-jslock.cpp b/mail/thunderbird3/files/patch-mozilla-js-src-jslock.cpp
new file mode 100644
index 000000000000..03f5c60cccf8
--- /dev/null
+++ b/mail/thunderbird3/files/patch-mozilla-js-src-jslock.cpp
@@ -0,0 +1,18 @@
+--- mozilla/js/src/jslock.cpp.orig 2010-01-23 20:35:45.000000000 +0100
++++ mozilla/js/src/jslock.cpp 2010-01-23 20:37:35.000000000 +0100
+@@ -160,8 +160,13 @@
+ unsigned int res;
+
+ __asm__ __volatile__ (
+- "stbar\n"
+- "cas [%1],%2,%3\n"
++ "membar #StoreLoad | #LoadLoad\n"
++# if defined (__sparc64__)
++ "casx [%1],%2,%3\n"
++# else
++ "cas [%1],%2,%3\n" /* 32-bit version */
++# endif
++ "membar #StoreLoad | #LoadLoad\n"
+ "cmp %2,%3\n"
+ "be,a 1f\n"
+ "mov 1,%0\n"
diff --git a/mail/thunderbird3/files/patch-mozilla-security_nss_lib_freebl_mpi_mpcpucache.c b/mail/thunderbird3/files/patch-mozilla-security_nss_lib_freebl_mpi_mpcpucache.c
new file mode 100644
index 000000000000..e79b29942155
--- /dev/null
+++ b/mail/thunderbird3/files/patch-mozilla-security_nss_lib_freebl_mpi_mpcpucache.c
@@ -0,0 +1,43 @@
+--- mozilla/security/nss/lib/freebl/mpi/mpcpucache.c.orig 2011-02-26 23:13:08.000000000 +0100
++++ mozilla/security/nss/lib/freebl/mpi/mpcpucache.c 2011-02-26 23:18:46.000000000 +0100
+@@ -733,6 +733,32 @@
+ #endif
+
+ #if defined(__ppc64__)
++#if defined(__FreeBSD__)
++#include <sys/stddef.h>
++#include <sys/sysctl.h>
++
++#include <machine/cpu.h>
++#include <machine/md_var.h>
++
++unsigned long
++s_mpi_getProcessorLineSize()
++{
++ static int cacheline_size = 0;
++ static int cachemib[] = { CTL_MACHDEP, CPU_CACHELINE };
++ int clen;
++
++ if (cacheline_size > 0)
++ return cacheline_size;
++
++ clen = sizeof(cacheline_size);
++ if (sysctl(cachemib, sizeof(cachemib) / sizeof(cachemib[0]),
++ &cacheline_size, &clen, NULL, 0) < 0 || !cacheline_size)
++ return 128; /* guess */
++
++ return cacheline_size;
++}
++#else /* __FreeBSD__ */
++
+ /*
+ * Sigh, The PPC has some really nice features to help us determine cache
+ * size, since it had lots of direct control functions to do so. The POWER
+@@ -786,6 +812,7 @@
+ return 0;
+ }
+
++#endif /* __FreeBSD__ */
+ #define MPI_GET_PROCESSOR_LINE_SIZE_DEFINED 1
+ #endif
+