aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2003-04-07 02:15:30 +0800
committerleeym <leeym@FreeBSD.org>2003-04-07 02:15:30 +0800
commit1c78829f1b07ab11e680884fb0d32c790abd089e (patch)
treebe596c95c173a8dfa25a01029ef2b4329d1fcf08 /mail
parent13331697fa335334b05205f192a2ba5ca9e39b78 (diff)
downloadfreebsd-ports-gnome-1c78829f1b07ab11e680884fb0d32c790abd089e.tar.gz
freebsd-ports-gnome-1c78829f1b07ab11e680884fb0d32c790abd089e.tar.zst
freebsd-ports-gnome-1c78829f1b07ab11e680884fb0d32c790abd089e.zip
use cpio(1) instead of tar(1), avoid owner's problem when the port is built
and installed by different user. Submitted by: David Magda <dmagda@magda.ca>
Diffstat (limited to 'mail')
-rw-r--r--mail/openwebmail/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/mail/openwebmail/Makefile b/mail/openwebmail/Makefile
index 700d15befb4c..dedc171a99ef 100644
--- a/mail/openwebmail/Makefile
+++ b/mail/openwebmail/Makefile
@@ -80,11 +80,9 @@ post-patch:
.endif
do-install:
- @${MKDIR} ${OWCGIDIR:S,${PORTNAME},,}
- @cd ${WRKSRC}/cgi-bin && ${TAR} cf - ${PORTNAME} | (cd ${OWCGIDIR:S,${PORTNAME},,}; ${TAR} xf -)
- @${MKDIR} ${OWDATADIR:S,${PORTNAME},,}
- @cd ${WRKSRC}/data && ${TAR} cf - ${PORTNAME} | (cd ${OWDATADIR:S,${PORTNAME},,}; ${TAR} xf -)
- @${CHOWN} -R root:mail ${OWCGIDIR}
+ @${MKDIR} ${OWCGIDIR} ${OWDATADIR}
+ @cd ${WRKSRC}/cgi-bin/openwebmail && ${FIND} . | cpio -dpum -R ${BINOWN}:mail ${OWCGIDIR}
+ @cd ${WRKSRC}/data/openwebmail && ${FIND} . | cpio -dpum -R ${SHAREOWN}:${SHAREGRP} ${OWDATADIR}
@${CHMOD} 0770 ${OWCGIDIR}/etc/sessions ${OWCGIDIR}/etc/users
@${CHMOD} 4755 ${OWCGIDIR}/openwebmail*pl
@${PERL} ${OWCGIDIR}/uty/wrapsuid.pl ${OWCGIDIR}