aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2017-02-24 23:24:18 +0800
committeradamw <adamw@FreeBSD.org>2017-02-24 23:24:18 +0800
commit1fee92561923154c58a7d6786b2e57a2592a0255 (patch)
tree4507e864c1942003e5f996f483bb95c1d76a6851 /mail
parentbea23107275636ffa22e3cfe8facc9877d558401 (diff)
downloadfreebsd-ports-gnome-1fee92561923154c58a7d6786b2e57a2592a0255.tar.gz
freebsd-ports-gnome-1fee92561923154c58a7d6786b2e57a2592a0255.tar.zst
freebsd-ports-gnome-1fee92561923154c58a7d6786b2e57a2592a0255.zip
Update dovecot2 to 2.2.28, and bump PORTREVISION on the plugins.
* director: "doveadm director move" to same host now refreshes user's timeout. This allows keeping user constantly in the same backend by just periodically moving the user there. * When new mailbox is created, use initially INBOX's dovecot.index.cache caching decisions. * Expunging mails writes GUID to dovecot.index.log now only if the GUID is quickly available from index/cache. * pop3c: Increase timeout for PASS command to 5 minutes. * Mail access errors are no longer ignored when searching or sorting. With IMAP the untagged SEARCH/SORT reply is still sent the same as before, but NO reply is returned instead of OK. + Make dovecot.list.index's filename configurable. This is needed when there are multiple namespaces pointing to the same mail root (e.g. lazy_expunge namespace for mdbox). + Add size.virtual to dovecot.index when folder vsizes are accessed (e.g. quota=count). This is mainly a workaround to avoid slow quota recalculation performance when message sizes get lost from dovecot.index.cache due to corruption or some other reason. + auth: Support OAUTHBEARER and XOAUTH2 mechanisms. Also support them in lib-dsasl for client side. + auth: Support filtering by SASL mechanism: passdb { mechanisms } + Shrink the mail processes' memory usage by not storing settings duplicated unnecessarily many times. + imap: Add imap_fetch_failure setting to control what happens when FETCH fails for some mails (see example-config). + imap: Include info about last command in disconnection log line. + imap: Created new SEARCH=X-MIMEPART extension. It's currently not advertised by default, since it's not fully implemented. + fts-solr: Add support for basic authentication. + Cassandra: Support automatically retrying failed queries if execution_retry_interval and execution_retry_times are set. + doveadm: Added "mailbox path" command. + mail_log plugin: If plugin { mail_log_cached_only=yes }, log the wanted fields only if it doesn't require opening the email. + mail_vsize_bg_after_count setting added (see example-config). + mail_sort_max_read_count setting added (see example-config). + pop3c: Added pop3c_features=no-pipelining setting to prevent using PIPELINING extension even though it's advertised. - Index files: day_first_uid wasn't updated correctly since v2.2.26. This caused dovecot.index.cache to be non-optimal. - imap: SEARCH/SORT may have assert-crashed in client_check_command_hangs - imap: FETCH X-MAILBOX may have assert-crashed in virtual mailboxes. - imap: Running time in tagged command reply was often wrongly 0. - search: Using NOT n:* or NOT UID n:* wasn't handled correctly - director: doveadm director kick was broken - director: Fix crash when using director_flush_socket - director: Fix some bugs when moving users between backends - imapc: Various error handling fixes and improvements - master: doveadm process status output had a lot of duplicates. - autoexpunge: If mailbox's rename timestamp is newer than mail's save-timestamp, use it instead. This is useful when autoexpunging e.g. Trash/* and an entire mailbox is deleted by renaming it under Trash to prevent it from being autoexpunged too early. - autoexpunge: Multiple processes may have been trying to expunge the same mails simultaneously. This was problematic especially with lazy_expunge plugin. - auth: %{passdb:*} was empty in auth-worker processes - auth-policy: hashed_password was always sent empty. - dict-sql: Merge multiple UPDATEs to a single statement if possible. - fts-solr: Escape {} chars when sending queries - fts: fts_autoindex_exclude = \Special-use caused crashes - doveadm-server: Fix leaks and other problems when process is reused for multiple requests (service_count != 1) - sdbox: Fix assert-crash on mailbox create race - lda/lmtp: deliver_log_format values weren't entirely correct if Sieve was used. especially %{storage_id} was broken. - lmtp_user_concurrency_limit didn't work if userdb changed username
Diffstat (limited to 'mail')
-rw-r--r--mail/dovecot2-antispam-plugin/Makefile2
-rw-r--r--mail/dovecot2-pigeonhole/Makefile2
-rw-r--r--mail/dovecot2/Makefile3
-rw-r--r--mail/dovecot2/distinfo6
-rw-r--r--mail/dovecot2/files/patch-src_lib-ssl-iostream_dovecot-openssl-common.c13
-rw-r--r--mail/dovecot2/pkg-plist8
6 files changed, 14 insertions, 20 deletions
diff --git a/mail/dovecot2-antispam-plugin/Makefile b/mail/dovecot2-antispam-plugin/Makefile
index ac3ac4a089a5..20d9fd00cd82 100644
--- a/mail/dovecot2-antispam-plugin/Makefile
+++ b/mail/dovecot2-antispam-plugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dovecot2-antispam-plugin
PORTVERSION= 20130429
-PORTREVISION= 24
+PORTREVISION= 25
CATEGORIES= mail
MASTER_SITES= http://olgeni.olgeni.com/~olgeni/distfiles/ \
LOCAL/olgeni
diff --git a/mail/dovecot2-pigeonhole/Makefile b/mail/dovecot2-pigeonhole/Makefile
index 815504996d55..be916a5706e8 100644
--- a/mail/dovecot2-pigeonhole/Makefile
+++ b/mail/dovecot2-pigeonhole/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dovecot-pigeonhole
PORTVERSION= 0.4.16
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= mail
MASTER_SITES= http://pigeonhole.dovecot.org/releases/${DOVECOTVERSION}/
DISTNAME= ${PORTNAME:C/-/-${DOVECOTVERSION}-/}-${PORTVERSION}
diff --git a/mail/dovecot2/Makefile b/mail/dovecot2/Makefile
index 43d99b6d3a77..149b91fce9ed 100644
--- a/mail/dovecot2/Makefile
+++ b/mail/dovecot2/Makefile
@@ -13,8 +13,7 @@
######################################################################
PORTNAME= dovecot
-PORTVERSION= 2.2.27
-PORTREVISION= 4
+PORTVERSION= 2.2.28
CATEGORIES= mail ipv6
MASTER_SITES= https://www.dovecot.org/releases/${PORTVERSION:R}/
PKGNAMESUFFIX= 2
diff --git a/mail/dovecot2/distinfo b/mail/dovecot2/distinfo
index 9cba396e4d36..d2fdc3dbdec9 100644
--- a/mail/dovecot2/distinfo
+++ b/mail/dovecot2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1480788212
-SHA256 (dovecot-2.2.27.tar.gz) = 897f92a87cda4b27b243f8149ce0ba7b7e71a2be8fb7994eb0a025e54cde18e9
-SIZE (dovecot-2.2.27.tar.gz) = 5794668
+TIMESTAMP = 1487948861
+SHA256 (dovecot-2.2.28.tar.gz) = e0288f59e326ab87cb3881fdabadafe542f4dc7ab9996db13863a439ebbc1f25
+SIZE (dovecot-2.2.28.tar.gz) = 5921992
diff --git a/mail/dovecot2/files/patch-src_lib-ssl-iostream_dovecot-openssl-common.c b/mail/dovecot2/files/patch-src_lib-ssl-iostream_dovecot-openssl-common.c
deleted file mode 100644
index 9478bcf38531..000000000000
--- a/mail/dovecot2/files/patch-src_lib-ssl-iostream_dovecot-openssl-common.c
+++ /dev/null
@@ -1,13 +0,0 @@
-This fixes building against LibreSSL.
-
---- src/lib-ssl-iostream/dovecot-openssl-common.c.orig 2016-12-03 18:13:25 UTC
-+++ src/lib-ssl-iostream/dovecot-openssl-common.c
-@@ -101,7 +101,7 @@ bool dovecot_openssl_common_global_unref
- ERR_remove_thread_state(NULL);
- #endif
- ERR_free_strings();
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
- OPENSSL_cleanup();
- #endif
- return FALSE;
diff --git a/mail/dovecot2/pkg-plist b/mail/dovecot2/pkg-plist
index 9761ff61d41c..1d146e37dcf5 100644
--- a/mail/dovecot2/pkg-plist
+++ b/mail/dovecot2/pkg-plist
@@ -96,6 +96,7 @@ include/dovecot/dcrypt.h
include/dovecot/db-checkpassword.h
include/dovecot/db-dict.h
include/dovecot/db-ldap.h
+include/dovecot/db-oauth2.h
include/dovecot/db-passwd-file.h
include/dovecot/db-sql.h
include/dovecot/dbox-attachment.h
@@ -339,6 +340,9 @@ include/dovecot/mail-index-view-private.h
include/dovecot/mail-index.h
include/dovecot/mail-namespace.h
include/dovecot/mail-search-build.h
+include/dovecot/mail-search-mime-build.h
+include/dovecot/mail-search-mime-register.h
+include/dovecot/mail-search-mime.h
include/dovecot/mail-search-parser-private.h
include/dovecot/mail-search-parser.h
include/dovecot/mail-search-register.h
@@ -385,6 +389,7 @@ include/dovecot/maildir-settings.h
include/dovecot/maildir-storage.h
include/dovecot/maildir-sync.h
include/dovecot/maildir-uidlist.h
+include/dovecot/malloc-overflow.h
include/dovecot/master-auth.h
include/dovecot/master-instance.h
include/dovecot/master-interface.h
@@ -427,6 +432,7 @@ include/dovecot/message-header-parser.h
include/dovecot/message-id.h
include/dovecot/message-parser.h
include/dovecot/message-part.h
+include/dovecot/message-part-data.h
include/dovecot/message-part-serialize.h
include/dovecot/message-search.h
include/dovecot/message-size.h
@@ -443,6 +449,7 @@ include/dovecot/nfs-workarounds.h
include/dovecot/notify-plugin-private.h
include/dovecot/notify-plugin.h
include/dovecot/numpack.h
+include/dovecot/oauth2.h
include/dovecot/ostream-cmp.h
include/dovecot/ostream-dot.h
include/dovecot/ostream-encrypt.h
@@ -634,6 +641,7 @@ lib/dovecot/lib95_imap_stats_plugin.a
lib/dovecot/lib95_imap_stats_plugin.so
lib/dovecot/lib99_welcome_plugin.a
lib/dovecot/lib99_welcome_plugin.so
+lib/dovecot/libdcrypt_openssl.a
lib/dovecot/libdcrypt_openssl.so
lib/dovecot/libdovecot-compression.a
lib/dovecot/libdovecot-compression.so