aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-06-03 07:51:36 +0800
committermiwi <miwi@FreeBSD.org>2008-06-03 07:51:36 +0800
commit29b1deea557eb71ad39ec8ac9c11242ea65ac293 (patch)
tree02ae271a33b87174db8cce7ee4926612f2d09b37 /mail
parent90834e04f97d103beb4443d948ec829edd8357aa (diff)
downloadfreebsd-ports-gnome-29b1deea557eb71ad39ec8ac9c11242ea65ac293.tar.gz
freebsd-ports-gnome-29b1deea557eb71ad39ec8ac9c11242ea65ac293.tar.zst
freebsd-ports-gnome-29b1deea557eb71ad39ec8ac9c11242ea65ac293.zip
- Fix bug 'can not replay with quote' (bugid 1587)
- Bump PORTREVISION PR: 124221 Reported by: David <r3nd1n@gmail.com> Approved by: netchild implicit
Diffstat (limited to 'mail')
-rw-r--r--mail/claws-mail/Makefile1
-rw-r--r--mail/claws-mail/files/patch-src_compose.c29
-rw-r--r--mail/claws-mail/files/patch-src_prefs_common.c31
3 files changed, 61 insertions, 0 deletions
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 8b3134397517..955758bc0b8e 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -7,6 +7,7 @@
PORTNAME= claws-mail
PORTVERSION= 3.4.0
+PORTREVISION= 1
CATEGORIES= mail news ipv6
MASTER_SITES= SF
MASTER_SITE_SUBDIR= sylpheed-claws
diff --git a/mail/claws-mail/files/patch-src_compose.c b/mail/claws-mail/files/patch-src_compose.c
new file mode 100644
index 000000000000..d3c6a9939677
--- /dev/null
+++ b/mail/claws-mail/files/patch-src_compose.c
@@ -0,0 +1,29 @@
+--- src/compose.c 2008/04/30 06:46:01 1.382.2.446
++++ src/compose.c 2008/05/04 15:58:59 1.382.2.447
+@@ -1591,7 +1591,7 @@
+
+ } else {
+ qmark = prefs_common.quotemark;
+- body_fmt = prefs_common.quotefmt;
++ body_fmt = gettext(prefs_common.quotefmt);
+ }
+ }
+
+@@ -1746,7 +1746,7 @@
+ g_free(msgfile);
+ } else {
+ const gchar *qmark = NULL;
+- const gchar *body_fmt = prefs_common.fw_quotefmt;
++ const gchar *body_fmt = gettext(prefs_common.fw_quotefmt);
+ MsgInfo *full_msginfo;
+
+ full_msginfo = procmsg_msginfo_get_full_info(msginfo);
+@@ -1767,7 +1767,7 @@
+
+ } else {
+ qmark = prefs_common.fw_quotemark;
+- body_fmt = prefs_common.fw_quotefmt;
++ body_fmt = gettext(prefs_common.fw_quotefmt);
+ }
+
+ /* empty quotemark is not allowed */
diff --git a/mail/claws-mail/files/patch-src_prefs_common.c b/mail/claws-mail/files/patch-src_prefs_common.c
new file mode 100644
index 000000000000..4a5f21ffe602
--- /dev/null
+++ b/mail/claws-mail/files/patch-src_prefs_common.c
@@ -0,0 +1,31 @@
+--- src/prefs_common.c 2008/04/24 05:39:34 1.204.2.167
++++ src/prefs_common.c 2008/05/04 15:59:02 1.204.2.168
+@@ -226,7 +226,7 @@
+ NULL, NULL, NULL},
+ {"compose_subject_format", "",
+ &prefs_common.compose_subject_format, P_STRING, NULL, NULL, NULL},
+- {"compose_body_format", NULL,
++ {"compose_body_format", N_("Hello,\\n"),
+ &prefs_common.compose_body_format, P_STRING, NULL, NULL, NULL},
+
+ {"linewrap_length", "72", &prefs_common.linewrap_len, P_INT,
+@@ -293,12 +293,16 @@
+ /* Quote */
+ {"reply_quote_mark", "> ", &prefs_common.quotemark, P_STRING,
+ NULL, NULL, NULL},
+- {"reply_quote_format", NULL,
++ {"reply_quote_format", N_("On %d\\n%f wrote:\\n\\n%q"),
+ &prefs_common.quotefmt, P_STRING, NULL, NULL, NULL},
+
+ {"forward_quote_mark", "> ", &prefs_common.fw_quotemark, P_STRING,
+ NULL, NULL, NULL},
+- {"forward_quote_format", NULL, &prefs_common.fw_quotefmt, P_STRING,
++ {"forward_quote_format",
++ N_("\\n\\nBegin forwarded message:\\n\\n"
++ "?d{Date: %d\\n}?f{From: %f\\n}?t{To: %t\\n}?c{Cc: %c\\n}"
++ "?n{Newsgroups: %n\\n}?s{Subject: %s\\n}\\n\\n%M"),
++ &prefs_common.fw_quotefmt, P_STRING,
+ NULL, NULL, NULL},
+ {"quote_chars", ">", &prefs_common.quote_chars, P_STRING,
+ NULL, NULL, NULL},
+