aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-01-29 06:04:19 +0800
committerdinoex <dinoex@FreeBSD.org>2003-01-29 06:04:19 +0800
commit4cdea90123c815bb79bb47b084a8165547c1c3ba (patch)
treeb69bdfeae02b1e882e3180580ea97036c2077a45 /mail
parentb78e609de614fe078278c2ba6d755b4b17c64b8f (diff)
downloadfreebsd-ports-gnome-4cdea90123c815bb79bb47b084a8165547c1c3ba.tar.gz
freebsd-ports-gnome-4cdea90123c815bb79bb47b084a8165547c1c3ba.tar.zst
freebsd-ports-gnome-4cdea90123c815bb79bb47b084a8165547c1c3ba.zip
- Update to 0.5.9
- Fix bug found by nunotex@pt-quorum.com - discussion at http://marc.theaimsgroup.com/?l=popa3d-users&m=104354856516116&w=2 - Extend Documentation
Diffstat (limited to 'mail')
-rw-r--r--mail/popa3d/Makefile7
-rw-r--r--mail/popa3d/distinfo2
-rw-r--r--mail/popa3d/files/POPAUTH15
-rw-r--r--mail/popa3d/files/patch-mailbox.c18
-rw-r--r--mail/popa3d/pkg-plist1
5 files changed, 34 insertions, 9 deletions
diff --git a/mail/popa3d/Makefile b/mail/popa3d/Makefile
index be98a96c2a43..d5c72b36341c 100644
--- a/mail/popa3d/Makefile
+++ b/mail/popa3d/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= popa3d
-PORTVERSION= 0.5.1
-PORTREVISION= 1
+PORTVERSION= 0.5.9
CATEGORIES= mail
MASTER_SITES= http://www.openwall.com/popa3d/ \
ftp://ftp.openwall.com/pub/projects/popa3d/ \
@@ -24,6 +23,9 @@ PLIST= ${WRKDIR}/.PLIST.more
CFLAGS+= -DPREFIX=${PREFIX}
.if defined(SMTP_AFTER_POP3)
EXTRA_PATCHES+= ${FILESDIR}/pop-before-sendmail.patch
+PLIST_SUB+= SMTP_AFTER_POP3=""
+.else
+PLIST_SUB+= SMTP_AFTER_POP3="@comment "
.endif
pre-configure:
@@ -33,7 +35,6 @@ pre-configure:
@${ECHO_CMD} "@dirrm empty" >>${PLIST}
.endif
.if defined(SMTP_AFTER_POP3)
- @${ECHO_CMD} "%%PORTDOCS%%share/doc/popa3d/POPAUTH" >>${PLIST}
@${ECHO_CMD} "@cwd ${CFDIR}" >>${PLIST}
@${ECHO_CMD} "hack/popauth.m4" >>${PLIST}
.endif
diff --git a/mail/popa3d/distinfo b/mail/popa3d/distinfo
index af78d633aaf4..f62a75ff3a7a 100644
--- a/mail/popa3d/distinfo
+++ b/mail/popa3d/distinfo
@@ -1 +1 @@
-MD5 (popa3d-0.5.1.tar.gz) = 4b664763ed7569c93be8f5f7f2431aea
+MD5 (popa3d-0.5.9.tar.gz) = 571fbbd04d7e262fa0411c9e9c63259d
diff --git a/mail/popa3d/files/POPAUTH b/mail/popa3d/files/POPAUTH
index e7be0da34b80..ebe866ba6022 100644
--- a/mail/popa3d/files/POPAUTH
+++ b/mail/popa3d/files/POPAUTH
@@ -28,11 +28,6 @@ the timestamp of the authentication as RHS (which the sendmail-hack
ignores). This timestamp is then used to remove old IPs which are older
than VALIDTIME seconds (defined in the Makefile).
- Testing
-
-You can check the state by using the following command:
-$ makemap -u hash popauth
-
Disclaimer
This hack has been in production use for a week on our server and though
@@ -52,3 +47,13 @@ at garry@glendown.de
G.Glendown / Dec 15th 2000
+ Testing
+
+You can check the state by using the following command:
+$ makemap -u hash popauth
+
+On very low volume servers you may clean up the databse by setup a cron job:
+cd /etc/mail && find popauth.db -mmin +6 -exec \
+ makemap hash popauth.db <popauth ";"
+
+Dirk Meyer / Jan 19th 2003
diff --git a/mail/popa3d/files/patch-mailbox.c b/mail/popa3d/files/patch-mailbox.c
new file mode 100644
index 000000000000..f2cc9fe60868
--- /dev/null
+++ b/mail/popa3d/files/patch-mailbox.c
@@ -0,0 +1,18 @@
+--- mailbox.c.old Sun Sep 8 13:52:57 2002
++++ mailbox.c Sun Jan 26 07:30:26 2003
+@@ -227,6 +227,7 @@
+ if (!msg.data_offset) break;
+ msg.raw_size = offset - msg.raw_offset;
+ msg.data_size = offset - body - msg.data_offset;
++ msg.size -= body << 1;
+ MD5_Final(msg.hash, &hash);
+ if (db_op(&msg)) break;
+ }
+@@ -319,6 +320,7 @@
+ if (!msg.data_offset) return 1;
+ msg.raw_size = offset - msg.raw_offset;
+ msg.data_size = offset - (blank & body) - msg.data_offset;
++ msg.size -= (blank & body) << 1;
+ MD5_Final(msg.hash, &hash);
+ if (db_op(&msg)) return 1;
+
diff --git a/mail/popa3d/pkg-plist b/mail/popa3d/pkg-plist
index ed48f930d33b..2c7325249877 100644
--- a/mail/popa3d/pkg-plist
+++ b/mail/popa3d/pkg-plist
@@ -2,4 +2,5 @@
libexec/popa3d
%%PORTDOCS%%share/doc/popa3d/DESIGN
%%PORTDOCS%%share/doc/popa3d/LICENSE
+%%SMTP_AFTER_POP3%%%%PORTDOCS%%share/doc/popa3d/POPAUTH
%%PORTDOCS%%@dirrm share/doc/popa3d