aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2003-11-22 06:47:14 +0800
committeroliver <oliver@FreeBSD.org>2003-11-22 06:47:14 +0800
commit58d8fe6e3a22fca5845ed24b307953638863ceec (patch)
treeab874c0e319e5645b614816af80fa2d31c2cb9c8 /mail
parent489f33ffcc7aedbf37ad9266460e12953df1fb56 (diff)
downloadfreebsd-ports-gnome-58d8fe6e3a22fca5845ed24b307953638863ceec.tar.gz
freebsd-ports-gnome-58d8fe6e3a22fca5845ed24b307953638863ceec.tar.zst
freebsd-ports-gnome-58d8fe6e3a22fca5845ed24b307953638863ceec.zip
utilize USE_OPENLDAP
Diffstat (limited to 'mail')
-rw-r--r--mail/courier-imap/Makefile26
-rw-r--r--mail/sylpheed/Makefile4
-rw-r--r--mail/sylpheed2-devel/Makefile4
-rw-r--r--mail/sylpheed2/Makefile4
-rw-r--r--mail/sylpheed3/Makefile4
5 files changed, 10 insertions, 32 deletions
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index fdf498958e5a..e39a46a5383b 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -32,10 +32,7 @@ USE_GMAKE= yes
# WITH_VPOPMAIL: Build in vpopmail support
# WITH_MYSQL: Build in mysql support
# WITH_POSTGRESQL: Build in postgresql support
-# WITH_LDAP: Build in ldap support with openldap 2.1
-# WITH_LDAP21: Build in ldap support with openldap 2.1
-# WITH_LDAP20: Build in ldap support with openldap 2.0
-# WITH_LDAP1: Build in ldap support with openldap 1.x
+# WITH_LDAP: Build in ldap support with openldap
# WITH_FAM: Build in fam support for IDLE command
# WITH_TRASHQUOTA: Include deleted mails in the quota
#
@@ -84,26 +81,7 @@ CONFIGURE_ARGS+=--with-trashquota
.endif
.if defined(WITH_LDAP)
-WITH_LDAP21= yes
-.endif
-
-.if !defined(WITH_LDAP1) && !defined(WITH_LDAP20) && !defined(WITH_LDAP21)
-CONFIGURE_ARGS+=--without-authldap
-PLIST_SUB+= LDAPFLAG="@comment "
-.else
-CONFIGURE_ARGS+=--with-authldap
-PLIST_SUB+= LDAPFLAG=""
-
-.if defined(WITH_LDAP21)
-LIB_DEPENDS= ldap.2:${PORTSDIR}/net/openldap21-client \
- lber.2:${PORTSDIR}/net/openldap21-client
-.elseif defined(WITH_LDAP20)
-LIB_DEPENDS= ldap.2:${PORTSDIR}/net/openldap20-client \
- lber.2:${PORTSDIR}/net/openldap20-client
-.else
-LIB_DEPENDS= ldap.1:${PORTSDIR}/net/openldap12 \
- lber.1:${PORTSDIR}/net/openldap12
-.endif
+USE_OPENLDAP= yes
.endif
.if !defined(WITH_MYSQL)
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index fc5ce39ed952..2c93f12e6298 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -68,10 +68,10 @@ LIB_DEPENDS+= pisock.8:${PORTSDIR}/palm/pilot-link
RUN_DEPENDS+= jpilot:${PORTSDIR}/palm/jpilot
CONFIGURE_ARGS+=--enable-jpilot
.else
-CONFIGURE_ARGS+= --disable-jpilot
+CONFIGURE_ARGS+=--disable-jpilot
.endif
.if defined(WITH_LDAP)
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20-client
+USE_OPENLDAP= yes
CONFIGURE_ARGS+=--enable-ldap
.else
CONFIGURE_ARGS+=--disable-ldap
diff --git a/mail/sylpheed2-devel/Makefile b/mail/sylpheed2-devel/Makefile
index fc5ce39ed952..2c93f12e6298 100644
--- a/mail/sylpheed2-devel/Makefile
+++ b/mail/sylpheed2-devel/Makefile
@@ -68,10 +68,10 @@ LIB_DEPENDS+= pisock.8:${PORTSDIR}/palm/pilot-link
RUN_DEPENDS+= jpilot:${PORTSDIR}/palm/jpilot
CONFIGURE_ARGS+=--enable-jpilot
.else
-CONFIGURE_ARGS+= --disable-jpilot
+CONFIGURE_ARGS+=--disable-jpilot
.endif
.if defined(WITH_LDAP)
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20-client
+USE_OPENLDAP= yes
CONFIGURE_ARGS+=--enable-ldap
.else
CONFIGURE_ARGS+=--disable-ldap
diff --git a/mail/sylpheed2/Makefile b/mail/sylpheed2/Makefile
index fc5ce39ed952..2c93f12e6298 100644
--- a/mail/sylpheed2/Makefile
+++ b/mail/sylpheed2/Makefile
@@ -68,10 +68,10 @@ LIB_DEPENDS+= pisock.8:${PORTSDIR}/palm/pilot-link
RUN_DEPENDS+= jpilot:${PORTSDIR}/palm/jpilot
CONFIGURE_ARGS+=--enable-jpilot
.else
-CONFIGURE_ARGS+= --disable-jpilot
+CONFIGURE_ARGS+=--disable-jpilot
.endif
.if defined(WITH_LDAP)
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20-client
+USE_OPENLDAP= yes
CONFIGURE_ARGS+=--enable-ldap
.else
CONFIGURE_ARGS+=--disable-ldap
diff --git a/mail/sylpheed3/Makefile b/mail/sylpheed3/Makefile
index fc5ce39ed952..2c93f12e6298 100644
--- a/mail/sylpheed3/Makefile
+++ b/mail/sylpheed3/Makefile
@@ -68,10 +68,10 @@ LIB_DEPENDS+= pisock.8:${PORTSDIR}/palm/pilot-link
RUN_DEPENDS+= jpilot:${PORTSDIR}/palm/jpilot
CONFIGURE_ARGS+=--enable-jpilot
.else
-CONFIGURE_ARGS+= --disable-jpilot
+CONFIGURE_ARGS+=--disable-jpilot
.endif
.if defined(WITH_LDAP)
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20-client
+USE_OPENLDAP= yes
CONFIGURE_ARGS+=--enable-ldap
.else
CONFIGURE_ARGS+=--disable-ldap