aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2004-01-04 04:30:39 +0800
committerdougb <dougb@FreeBSD.org>2004-01-04 04:30:39 +0800
commit62eb6e43b2b08f13800cf75eb92678f40bbbecbf (patch)
treee3da7934a7a20c517121bc63ab9ed122d0f88ca8 /mail
parent3560384e3eab90846a9f70b8f7b3176176542285 (diff)
downloadfreebsd-ports-gnome-62eb6e43b2b08f13800cf75eb92678f40bbbecbf.tar.gz
freebsd-ports-gnome-62eb6e43b2b08f13800cf75eb92678f40bbbecbf.tar.zst
freebsd-ports-gnome-62eb6e43b2b08f13800cf75eb92678f40bbbecbf.zip
Adjust the dependency check on p5-Net-DNS to take into account its
new PERL_ARCH'ified location. In a few cases, standardize on searching for ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm instead of other files.
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-Email-Valid/Makefile2
-rw-r--r--mail/p5-Mail-SpamAssassin-snapshot/Makefile2
-rw-r--r--mail/p5-Mail-SpamAssassin/Makefile2
-rw-r--r--mail/p5-Mail-Spool/Makefile2
-rw-r--r--mail/p5-Mail-Verify/Makefile2
-rw-r--r--mail/p5-Net-SMTP-Server/Makefile2
-rw-r--r--mail/ricochet/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/mail/p5-Email-Valid/Makefile b/mail/p5-Email-Valid/Makefile
index bbd6dd8f36b1..dd1db0e6f8b5 100644
--- a/mail/p5-Email-Valid/Makefile
+++ b/mail/p5-Email-Valid/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Check validity of Internet email addresses
-BUILD_DEPENDS= ${SITE_PERL}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
${SITE_PERL}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools
RUN_DEPENDS= ${BUILD_DEPENDS}
diff --git a/mail/p5-Mail-SpamAssassin-snapshot/Makefile b/mail/p5-Mail-SpamAssassin-snapshot/Makefile
index 0d73fe1b7231..9806b6a4c823 100644
--- a/mail/p5-Mail-SpamAssassin-snapshot/Makefile
+++ b/mail/p5-Mail-SpamAssassin-snapshot/Makefile
@@ -20,7 +20,7 @@ COMMENT= A highly efficient mail filter for identifying spam
IGNORE= Please use the 2.60 release version instead
-BUILD_DEPENDS= ${SITE_PERL}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
${SITE_PERL}/Mail/Internet.pm:${PORTSDIR}/mail/p5-Mail-Tools
RUN_DEPENDS= ${BUILD_DEPENDS} \
diff --git a/mail/p5-Mail-SpamAssassin/Makefile b/mail/p5-Mail-SpamAssassin/Makefile
index 620212f43bc3..6b496197f742 100644
--- a/mail/p5-Mail-SpamAssassin/Makefile
+++ b/mail/p5-Mail-SpamAssassin/Makefile
@@ -16,7 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A highly efficient mail filter for identifying spam
-BUILD_DEPENDS= ${SITE_PERL}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
${SITE_PERL}/Mail/Internet.pm:${PORTSDIR}/mail/p5-Mail-Tools
RUN_DEPENDS= ${BUILD_DEPENDS} \
diff --git a/mail/p5-Mail-Spool/Makefile b/mail/p5-Mail-Spool/Makefile
index fa7a064afe3f..3d4fd0efca25 100644
--- a/mail/p5-Mail-Spool/Makefile
+++ b/mail/p5-Mail-Spool/Makefile
@@ -17,7 +17,7 @@ COMMENT= A "pure perl" implementation of mail spooling, unspooling and sending
BUILD_DEPENDS= ${SITE_PERL}/File/NFSLock.pm:${PORTSDIR}/devel/p5-File-NFSLock \
${SITE_PERL}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools \
- ${SITE_PERL}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
+ ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/mail/p5-Mail-Verify/Makefile b/mail/p5-Mail-Verify/Makefile
index 665b138f699e..cc01760c195b 100644
--- a/mail/p5-Mail-Verify/Makefile
+++ b/mail/p5-Mail-Verify/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= petef@FreeBSD.org
COMMENT= Perl module to verify email addresses
-BUILD_DEPENDS= ${SITE_PERL}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/mail/p5-Net-SMTP-Server/Makefile b/mail/p5-Net-SMTP-Server/Makefile
index 376fed3f3a58..3dc0ef7003da 100644
--- a/mail/p5-Net-SMTP-Server/Makefile
+++ b/mail/p5-Net-SMTP-Server/Makefile
@@ -16,7 +16,7 @@ DISTNAME= SMTP-Server-${PORTVERSION}
MAINTAINER= erwin@FreeBSD.org
COMMENT= A native Perl SMTP Server
-BUILD_DEPENDS= ${SITE_PERL}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
RUN_DEPENDS= ${BUILD_DEPENDS}
MASTER_SITE_BACKUP+= http://www.macgyver.org/software/perl/
diff --git a/mail/ricochet/Makefile b/mail/ricochet/Makefile
index f9bea4bbda2e..92b1c55d3c0f 100644
--- a/mail/ricochet/Makefile
+++ b/mail/ricochet/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ache@FreeBSD.org
COMMENT= An automated agent for tracing and reporting internet junk mail
RUN_DEPENDS= ${SITE_PERL}/Mail/Internet.pm:${PORTSDIR}/mail/p5-Mail-Tools \
- ${SITE_PERL}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
+ ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
${SITE_PERL}/Text/Template.pm:${PORTSDIR}/textproc/p5-Text-Template \
${SITE_PERL}/Net/XWhois.pm:${PORTSDIR}/net/p5-Net-XWhois \
${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww