aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-05-14 06:00:48 +0800
committeradamw <adamw@FreeBSD.org>2015-05-14 06:00:48 +0800
commit71f2f84302a1984d61dd99c296084a57f42f8f11 (patch)
tree83e57967793706fdd9d4ea07e21258d3361a26d5 /mail
parentb737f7420b12cd3716826d6624089e1fbfdb7e20 (diff)
downloadfreebsd-ports-gnome-71f2f84302a1984d61dd99c296084a57f42f8f11.tar.gz
freebsd-ports-gnome-71f2f84302a1984d61dd99c296084a57f42f8f11.tar.zst
freebsd-ports-gnome-71f2f84302a1984d61dd99c296084a57f42f8f11.zip
Update to 2.2.17.
For a full change list, see: http://dovecot.org/list/dovecot-news/2015-May/000292.html There are two changes that could potentially break setups: * Dovecot no longer checks or warns if a mountpoint is removed. This was causing more trouble than it was worth. Make sure that all the mountpoints that Dovecot accesses aren't writable by mail processes when they're unmounted. * dict server wasn't properly escaping/unescaping data. Fixing this broke backwards compatibility with data that contains line feeds. This hopefully affects only very few installations. If you're using dict to save multiline data (Sieve scripts to SQL), you may be affected. For this release I've introduced many new OPTIONS: * boehm-gc support * CDB database support * icu (for FTS) * libtextcat FTS * disabling kqueue support also disables kqueue fs change notification * databases and FTS plugins moved to their own config sections
Diffstat (limited to 'mail')
-rw-r--r--mail/dovecot2/Makefile44
-rw-r--r--mail/dovecot2/distinfo4
-rw-r--r--mail/dovecot2/pkg-plist15
3 files changed, 51 insertions, 12 deletions
diff --git a/mail/dovecot2/Makefile b/mail/dovecot2/Makefile
index ea936bc17863..557839da8a39 100644
--- a/mail/dovecot2/Makefile
+++ b/mail/dovecot2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= dovecot
-PORTVERSION= 2.2.16
-PORTREVISION= 1
+PORTVERSION= 2.2.17
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/releases/${PORTVERSION:R}/
PKGNAMESUFFIX= 2
@@ -43,24 +42,42 @@ INSTALL_TARGET= install-strip
USERS= dovecot dovenull
GROUPS= ${USERS}
-OPTIONS_DEFINE= KQUEUE SSL VPOPMAIL LDAP LUCENE LZ4 PGSQL MYSQL SQLITE \
- SOLR DOCS EXAMPLES LIBWRAP
-OPTIONS_SINGLE= GSSAPI
-OPTIONS_SINGLE_GSSAPI= GSSAPI_NONE GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT
+OPTIONS_DEFINE= GC KQUEUE LIBWRAP LZ4 SSL VPOPMAIL DOCS EXAMPLES
OPTIONS_DEFAULT=KQUEUE SSL GSSAPI_NONE
OPTIONS_SUB= yes
+OPTIONS_GROUP= DB FTS
+OPTIONS_GROUP_DB= CDB LDAP MYSQL PGSQL SQLITE
+OPTIONS_GROUP_FTS= ICU LUCENE SOLR TEXTCAT
+
+OPTIONS_SINGLE= GSSAPI
+OPTIONS_SINGLE_GSSAPI= GSSAPI_NONE GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT
+
+GC_DESC= Garbage collection with boehm-gc
KQUEUE_DESC= kqueue(2) support
-LUCENE_DESC= CLucene FTS support
LZ4_DESC= LZ4 compression support
-SOLR_DESC= Solr FTS support
VPOPMAIL_DESC= vpopmail support
+DB_DESC= Database support
+CDB_DESC= CDB database support
+
+FTS_DESC= Full text search plugins
+ICU_DESC= Use libicu for FTS unicode normalization
+LUCENE_DESC= CLucene FTS support
+SOLR_DESC= Solr FTS support
+TEXTCAT_DESC= Libtextcat FTS support
+
GSSAPI_NONE_DESC= Build without GSSAPI support
GSSAPI_BASE_DESC= Use GSSAPI from base
GSSAPI_HEIMDAL_DESC= Use Heimdal GSSAPI from security/heimdal
GSSAPI_MIT_DESC= Use MIT GSSAPI from security/krb5
+CDB_CONFIGURE_WITH= cdb
+CDB_LIB_DEPENDS= libcdb.so:${PORTSDIR}/databases/tinycdb
+
+GC_CONFIGURE_WITH= gc
+GC_LIB_DEPENDS= libgc.so:${PORTSDIR}/devel/boehm-gc
+
GSSAPI_NONE_CONFIGURE_ON= --without-gssapi
GSSAPI_BASE_USES= gssapi
GSSAPI_BASE_CONFIGURE_ON= --with-gssapi ${GSSAPI_CONFIGURE_ARGS}
@@ -69,8 +86,12 @@ GSSAPI_HEIMDAL_CONFIGURE_ON= --with-gssapi ${GSSAPI_CONFIGURE_ARGS}
GSSAPI_MIT_USES= gssapi:mit
GSSAPI_MIT_CONFIGURE_ON= --with-gssapi ${GSSAPI_CONFIGURE_ARGS}
-KQUEUE_CONFIGURE_OFF= --with-ioloop=poll
-KQUEUE_CONFIGURE_ON= --with-ioloop=kqueue
+ICU_CONFIGURE_WITH= icu
+ICU_LIB_DEPENDS= libicui18n.so:${PORTSDIR}/devel/icu
+ICU_USES= pkgconfig
+
+KQUEUE_CONFIGURE_OFF= --with-ioloop=poll --with-notify=none
+KQUEUE_CONFIGURE_ON= --with-ioloop=kqueue --with-notify=kqueue
LDAP_USE= OPENLDAP=yes
LDAP_CONFIGURE_WITH= ldap
@@ -100,6 +121,9 @@ SQLITE_CONFIGURE_WITH= sqlite
SSL_CONFIGURE_WITH= ssl=openssl
+TEXTCAT_CONFIGURE_WITH= textcat
+TEXTCAT_LIB_DEPENDS= libtextcat.so:${PORTSDIR}/textproc/libtextcat
+
VPOPMAIL_BUILD_DEPENDS= ${LOCALBASE}/vpopmail/bin/vchkpw:${PORTSDIR}/mail/vpopmail
VPOPMAIL_CONFIGURE_WITH=vpopmail
diff --git a/mail/dovecot2/distinfo b/mail/dovecot2/distinfo
index e76d79d8a8c1..a2f587c8f310 100644
--- a/mail/dovecot2/distinfo
+++ b/mail/dovecot2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dovecot-2.2.16.tar.gz) = 56ce1287a17fa88a2083116db00200deff1a5390af5eac1c8ae3f59a2079cff0
-SIZE (dovecot-2.2.16.tar.gz) = 4830169
+SHA256 (dovecot-2.2.17.tar.gz) = 2f99a598cf0a88fd4dc4a43d208fdbbde7983dc0802a9db830399d4af32a1374
+SIZE (dovecot-2.2.17.tar.gz) = 5098786
diff --git a/mail/dovecot2/pkg-plist b/mail/dovecot2/pkg-plist
index aca16cced4e5..ae024bc08b93 100644
--- a/mail/dovecot2/pkg-plist
+++ b/mail/dovecot2/pkg-plist
@@ -136,6 +136,7 @@ include/dovecot/fts-api.h
include/dovecot/fts-expunge-log.h
include/dovecot/fts-indexer.h
include/dovecot/fts-parser.h
+include/dovecot/fts-user.h
include/dovecot/guid.h
include/dovecot/hash-decl.h
include/dovecot/hash-format.h
@@ -176,6 +177,7 @@ include/dovecot/imap-envelope.h
include/dovecot/imap-expunge.h
include/dovecot/imap-fetch.h
include/dovecot/imap-id.h
+include/dovecot/imap-keepalive.h
include/dovecot/imap-list.h
include/dovecot/imap-match.h
include/dovecot/imap-metadata.h
@@ -246,6 +248,7 @@ include/dovecot/istream-chain.h
include/dovecot/istream-concat.h
include/dovecot/istream-crlf.h
include/dovecot/istream-dot.h
+include/dovecot/istream-file-private.h
include/dovecot/istream-fs-file.h
include/dovecot/istream-hash.h
include/dovecot/istream-header-filter.h
@@ -261,9 +264,11 @@ include/dovecot/istream-seekable.h
include/dovecot/istream-sized.h
include/dovecot/istream-tee.h
include/dovecot/istream-timeout.h
+include/dovecot/istream-unix.h
include/dovecot/istream-zlib.h
include/dovecot/istream.h
include/dovecot/json-parser.h
+include/dovecot/json-tree.h
include/dovecot/lda-settings.h
include/dovecot/lib-signals.h
include/dovecot/lib.h
@@ -308,6 +313,8 @@ include/dovecot/mail-transaction-log.h
include/dovecot/mail-types.h
include/dovecot/mail-user-hash.h
include/dovecot/mail-user.h
+include/dovecot/mailbox-attribute-private.h
+include/dovecot/mailbox-attribute.h
include/dovecot/mailbox-guid-cache.h
include/dovecot/mailbox-list-delete.h
include/dovecot/mailbox-list-fs.h
@@ -415,6 +422,7 @@ include/dovecot/primes.h
include/dovecot/printf-format-fix.h
include/dovecot/priorityq.h
include/dovecot/process-title.h
+include/dovecot/qp-decoder.h
include/dovecot/quota-fs.h
include/dovecot/quota-plugin.h
include/dovecot/quota-private.h
@@ -521,6 +529,8 @@ lib/dovecot/lib20_mail_log_plugin.a
lib/dovecot/lib20_mail_log_plugin.so
lib/dovecot/lib20_mailbox_alias_plugin.a
lib/dovecot/lib20_mailbox_alias_plugin.so
+lib/dovecot/lib20_quota_clone_plugin.a
+lib/dovecot/lib20_quota_clone_plugin.so
lib/dovecot/lib20_replication_plugin.a
lib/dovecot/lib20_replication_plugin.so
lib/dovecot/lib20_virtual_plugin.a
@@ -563,6 +573,8 @@ lib/dovecot/libdovecot.a
lib/dovecot/libdovecot.so
lib/dovecot/libdovecot.so.0
lib/dovecot/libdovecot.so.0.0.0
+lib/dovecot/libfs_compress.a
+lib/dovecot/libfs_compress.so
lib/dovecot/stats/libstats_mail.a
lib/dovecot/stats/libstats_mail.so
libexec/dovecot/aggregator
@@ -645,6 +657,9 @@ man/man1/dsync.1.gz
man/man7/doveadm-search-query.7.gz
sbin/dovecot
share/aclocal/dovecot.m4
+%%DATADIR%%/stopwords/stopwords_en.txt
+%%DATADIR%%/stopwords/stopwords_fi.txt
+%%DATADIR%%/stopwords/stopwords_fr.txt
%%LIBWRAP%%libexec/dovecot/tcpwrap
%%LUCENE%%lib/dovecot/doveadm/lib20_doveadm_fts_lucene_plugin.a
%%LUCENE%%lib/dovecot/doveadm/lib20_doveadm_fts_lucene_plugin.so