aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2010-01-22 00:17:51 +0800
committergahr <gahr@FreeBSD.org>2010-01-22 00:17:51 +0800
commit72586a990a56329afc7cf8cf40c8dc9074ac12ff (patch)
treeebcce45f942111fddbb83b4918616513505c2538 /mail
parent95ff416bf911a511625b81443b3349de650622c1 (diff)
downloadfreebsd-ports-gnome-72586a990a56329afc7cf8cf40c8dc9074ac12ff.tar.gz
freebsd-ports-gnome-72586a990a56329afc7cf8cf40c8dc9074ac12ff.tar.zst
freebsd-ports-gnome-72586a990a56329afc7cf8cf40c8dc9074ac12ff.zip
- Fix utmpx on CURRENT
Diffstat (limited to 'mail')
-rw-r--r--mail/zmailer/Makefile4
-rw-r--r--mail/zmailer/files/extra-utmpx11
2 files changed, 15 insertions, 0 deletions
diff --git a/mail/zmailer/Makefile b/mail/zmailer/Makefile
index dd10b1894c4b..34e0a3ad61ac 100644
--- a/mail/zmailer/Makefile
+++ b/mail/zmailer/Makefile
@@ -23,6 +23,10 @@ USE_PERL5= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 900007
+EXTRA_PATCHES= ${FILESDIR}/extra-utmpx
+.endif
+
.if defined(WITHOUT_SSL)
CONFIGURE_ARGS= --without-openssl
.else
diff --git a/mail/zmailer/files/extra-utmpx b/mail/zmailer/files/extra-utmpx
new file mode 100644
index 000000000000..507a304121b4
--- /dev/null
+++ b/mail/zmailer/files/extra-utmpx
@@ -0,0 +1,11 @@
+--- transports/mailbox/mailbox.c.orig 2010-01-21 14:29:58.000000000 +0100
++++ transports/mailbox/mailbox.c 2010-01-21 14:30:06.000000000 +0100
+@@ -159,7 +159,7 @@
+ #endif /* HAVE_SOCKET */
+
+ #ifdef HAVE_PROTOCOLS_RWHOD_H
+-#include <utmp.h>
++#include <utmpx.h>
+ #include <protocols/rwhod.h>
+ #define RWHODIR "/var/spool/rwho"
+ #define WHDRSIZE (sizeof (wd) - sizeof (wd.wd_we))