aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2005-09-17 03:59:36 +0800
committerobraun <obraun@FreeBSD.org>2005-09-17 03:59:36 +0800
commit7fdca7c6389d0a4d9c35d72ea270a2aad588a1a1 (patch)
tree5887279942bd478e3408325ae70db30c0c6369db /mail
parentfc6e4c62ec6af55e8b7d9a2a425ca73bd3ac9d0d (diff)
downloadfreebsd-ports-gnome-7fdca7c6389d0a4d9c35d72ea270a2aad588a1a1.tar.gz
freebsd-ports-gnome-7fdca7c6389d0a4d9c35d72ea270a2aad588a1a1.tar.zst
freebsd-ports-gnome-7fdca7c6389d0a4d9c35d72ea270a2aad588a1a1.zip
Reawake patches in order to build on -CURRENT.
Diffstat (limited to 'mail')
-rw-r--r--mail/mairix/Makefile10
-rw-r--r--mail/mairix/files/patch-datescan.c91
-rw-r--r--mail/mairix/files/patch-fromcheck.c109
3 files changed, 206 insertions, 4 deletions
diff --git a/mail/mairix/Makefile b/mail/mairix/Makefile
index be6e3fa6e4ec..e284f5fbb765 100644
--- a/mail/mairix/Makefile
+++ b/mail/mairix/Makefile
@@ -1,6 +1,5 @@
-# ports collection Makefile for: mairix
-# Whom: Oliver Braun <obraun@FreeBSD.org>
-# Date created: 2003-03-27
+# ports collection Makefile for: mairix Whom: Oliver Braun
+# <obraun@FreeBSD.org> Date created: 2003-03-27
#
# $FreeBSD$
#
@@ -14,10 +13,13 @@ MAINTAINER= obraun@FreeBSD.org
COMMENT= Indexing and searching in Maildir or MH folders
HAS_CONFIGURE= yes
-USE_BISON= yes
+USE_REINPLACE= yes
CONFIGURE_ENV= CC="${CC}" CFLAGS="${CFLAGS}"
+post-patch:
+ @${REINPLACE_CMD} '/dfasyn/d' ${WRKSRC}/Makefile.in
+
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/mairix ${PREFIX}/bin
@${MKDIR} ${EXAMPLESDIR}
diff --git a/mail/mairix/files/patch-datescan.c b/mail/mairix/files/patch-datescan.c
new file mode 100644
index 000000000000..2fecbcf9ba89
--- /dev/null
+++ b/mail/mairix/files/patch-datescan.c
@@ -0,0 +1,91 @@
+--- /dev/null Mon Feb 16 12:56:01 2004
++++ datescan.c Mon Feb 16 12:55:18 2004
+@@ -0,0 +1,88 @@
++#include "dates.h"
++enum DATESCAN_TYPE datescan_exitval[] = {
++DS_FAILURE, /* State 0 */
++DS_FAILURE, /* State 1 */
++DS_D, /* State 2 */
++DS_D, /* State 3 */
++DS_D, /* State 4 */
++DS_FAILURE, /* State 5 */
++DS_Y, /* State 6 */
++DS_SCALED, /* State 7 */
++DS_D, /* State 8 */
++DS_SCALED, /* State 9 */
++DS_Y, /* State 10 */
++DS_FAILURE, /* State 11 */
++DS_FAILURE, /* State 12 */
++DS_SCALED, /* State 13 */
++DS_FAILURE, /* State 14 */
++DS_FAILURE, /* State 15 */
++DS_M, /* State 16 */
++DS_FAILURE, /* State 17 */
++DS_FAILURE, /* State 18 */
++DS_Y, /* State 19 */
++DS_DM, /* State 20 */
++DS_FAILURE, /* State 21 */
++DS_MD, /* State 22 */
++DS_MD, /* State 23 */
++DS_MD, /* State 24 */
++DS_FAILURE, /* State 25 */
++DS_YM, /* State 26 */
++DS_FAILURE, /* State 27 */
++DS_FAILURE, /* State 28 */
++DS_FAILURE, /* State 29 */
++DS_FAILURE, /* State 30 */
++DS_MY, /* State 31 */
++DS_MD, /* State 32 */
++DS_MY, /* State 33 */
++DS_YYMMDD, /* State 34 */
++DS_YMD, /* State 35 */
++DS_YMD, /* State 36 */
++DS_YMD, /* State 37 */
++DS_DMY, /* State 38 */
++DS_FAILURE, /* State 39 */
++DS_DMY, /* State 40 */
++DS_FAILURE, /* State 41 */
++DS_YYMMDD, /* State 42 */
++DS_FAILURE /* State 43 */
++};
++
++static short datescan_trans[] = {
++ 1, 2, 2, 3, 4, 5, 6, 6,
++ 6, 6, 6, 7, 8, 8, 8, 8,
++ 8, 9, 8, 8, 10, 10, 10, 9,
++ 10, 10, 10, 10, 10, 9, -1, -1,
++ -1, -1, -1, 11, 12, 12, 12, 12,
++ 12, 13, -1, -1, -1, -1, -1, -1,
++ 14, 14, 14, 14, 14, 9, -1, -1,
++ -1, -1, -1, 15, 14, 14, 14, 14,
++ 14, 13, -1, -1, -1, -1, -1, 16,
++ 17, 17, 17, 17, 17, 7, -1, -1,
++ -1, -1, -1, 18, 19, 19, 19, 19,
++ 19, 7, -1, -1, -1, -1, -1, 20,
++ 21, 22, 22, 23, 24, -1, 25, 25,
++ 25, 25, 25, 7, -1, -1, -1, -1,
++ -1, 26, 25, 25, 25, 25, 25, 13,
++ 27, 28, 28, 29, 30, -1, 31, 31,
++ 31, 31, 31, -1, 32, 32, 32, 32,
++ 32, -1, 32, 32, 33, 33, 33, -1,
++ 33, 33, 33, 33, 33, -1, 34, 34,
++ 34, 34, 34, 7, -1, 35, 35, 36,
++ 37, -1, 38, 38, 38, 38, 38, -1,
++ 39, 39, 39, 39, 39, -1, 39, 39,
++ 40, 40, 40, -1, 40, 40, 40, 40,
++ 40, -1, -1, -1, -1, -1, -1, -1,
++ 21, 21, 21, 21, 21, -1, 21, 21,
++ 21, 21, 21, -1, 41, 41, 41, 41,
++ 41, 7, 37, 37, 37, 37, 37, -1,
++ 37, 37, -1, -1, -1, -1, -1, -1,
++ -1, -1, -1, -1, -1, -1, -1, -1,
++ -1, -1, 27, 27, 27, 27, 27, -1,
++ 27, 27, 27, 27, 27, -1, 42, 42,
++ 42, 42, 42, 7, 43, 43, 43, 43,
++ 43, 7, 43, 43, 43, 43, 43, 7
++};
++
++int datescan_next_state(int current_state, int next_token) {
++ if (next_token < 0 || next_token >= 6) return -1;
++ return datescan_trans[6*current_state + next_token];
++}
diff --git a/mail/mairix/files/patch-fromcheck.c b/mail/mairix/files/patch-fromcheck.c
new file mode 100644
index 000000000000..a0d5566bd12e
--- /dev/null
+++ b/mail/mairix/files/patch-fromcheck.c
@@ -0,0 +1,109 @@
+--- /dev/null Mon Feb 16 13:00:10 2004
++++ fromcheck.c Mon Feb 16 13:00:13 2004
+@@ -0,0 +1,106 @@
++#include "fromcheck.h"
++enum fromcheck_result fromcheck_exitval[] = {
++FROMCHECK_FAIL, /* State 0 */
++FROMCHECK_FAIL, /* State 1 */
++FROMCHECK_FAIL, /* State 2 */
++FROMCHECK_FAIL, /* State 3 */
++FROMCHECK_FAIL, /* State 4 */
++FROMCHECK_FAIL, /* State 5 */
++FROMCHECK_FAIL, /* State 6 */
++FROMCHECK_FAIL, /* State 7 */
++FROMCHECK_FAIL, /* State 8 */
++FROMCHECK_FAIL, /* State 9 */
++FROMCHECK_FAIL, /* State 10 */
++FROMCHECK_FAIL, /* State 11 */
++FROMCHECK_FAIL, /* State 12 */
++FROMCHECK_FAIL, /* State 13 */
++FROMCHECK_FAIL, /* State 14 */
++FROMCHECK_FAIL, /* State 15 */
++FROMCHECK_FAIL, /* State 16 */
++FROMCHECK_FAIL, /* State 17 */
++FROMCHECK_FAIL, /* State 18 */
++FROMCHECK_FAIL, /* State 19 */
++FROMCHECK_FAIL, /* State 20 */
++FROMCHECK_FAIL, /* State 21 */
++FROMCHECK_FAIL, /* State 22 */
++FROMCHECK_FAIL, /* State 23 */
++FROMCHECK_FAIL, /* State 24 */
++FROMCHECK_FAIL, /* State 25 */
++FROMCHECK_FAIL, /* State 26 */
++FROMCHECK_FAIL, /* State 27 */
++FROMCHECK_FAIL, /* State 28 */
++FROMCHECK_FAIL, /* State 29 */
++FROMCHECK_FAIL, /* State 30 */
++FROMCHECK_FAIL, /* State 31 */
++FROMCHECK_FAIL, /* State 32 */
++FROMCHECK_FAIL, /* State 33 */
++FROMCHECK_FAIL, /* State 34 */
++FROMCHECK_FAIL, /* State 35 */
++FROMCHECK_FAIL, /* State 36 */
++FROMCHECK_FAIL, /* State 37 */
++FROMCHECK_FAIL, /* State 38 */
++FROMCHECK_FAIL, /* State 39 */
++FROMCHECK_PASS, /* State 40 */
++FROMCHECK_FAIL /* State 41 */
++};
++
++static short fromcheck_trans[] = {
++ -1, -1, 1, -1, -1, 2, 1, 1,
++ 3, 1, -1, -1, 1, 4, -1, -1,
++ 1, 1, 1, 1, -1, -1, 1, -1,
++ -1, 2, 1, 5, 3, 1, -1, -1,
++ 1, 4, -1, 6, 1, 1, 1, 1,
++ -1, -1, 7, -1, -1, -1, 7, 7,
++ 7, 7, -1, -1, 1, 4, -1, -1,
++ 8, 1, 1, 1, -1, -1, -1, -1,
++ -1, 6, -1, 9, -1, -1, -1, -1,
++ 7, -1, -1, 6, 7, 7, 7, 7,
++ -1, -1, 1, 4, -1, -1, 10, 1,
++ 1, 1, -1, -1, -1, -1, -1, -1,
++ 11, -1, -1, -1, -1, -1, 1, 4,
++ -1, 12, 1, 1, 1, 1, -1, -1,
++ -1, -1, -1, -1, 13, -1, -1, -1,
++ -1, -1, -1, -1, -1, 12, -1, 14,
++ -1, -1, -1, -1, -1, -1, -1, 12,
++ -1, -1, -1, -1, -1, -1, -1, -1,
++ -1, -1, 15, -1, -1, -1, -1, -1,
++ -1, -1, -1, -1, 16, -1, -1, -1,
++ -1, -1, -1, -1, -1, 17, -1, -1,
++ -1, -1, -1, -1, 18, -1, -1, 17,
++ -1, -1, -1, -1, -1, -1, 19, -1,
++ -1, 20, -1, -1, -1, -1, -1, -1,
++ -1, -1, -1, 20, -1, -1, -1, -1,
++ -1, -1, 21, -1, -1, 20, -1, -1,
++ -1, -1, -1, -1, 22, -1, -1, -1,
++ -1, -1, -1, -1, -1, -1, -1, -1,
++ 23, -1, -1, -1, -1, -1, -1, -1,
++ 24, -1, -1, -1, -1, -1, -1, -1,
++ -1, -1, 25, -1, -1, -1, -1, -1,
++ -1, -1, -1, -1, -1, -1, 26, 27,
++ -1, -1, -1, -1, -1, -1, 28, -1,
++ -1, -1, -1, -1, -1, -1, -1, -1,
++ 29, -1, -1, 27, -1, 30, 31, -1,
++ -1, -1, 32, -1, -1, -1, -1, -1,
++ -1, -1, -1, -1, 33, -1, -1, -1,
++ -1, -1, -1, -1, -1, -1, 30, -1,
++ -1, 34, 30, 30, -1, -1, -1, -1,
++ 30, -1, -1, -1, 30, 30, -1, -1,
++ -1, -1, -1, -1, -1, 27, -1, -1,
++ -1, -1, -1, -1, 35, -1, -1, -1,
++ -1, -1, -1, -1, -1, -1, 29, -1,
++ -1, 34, -1, 36, 37, -1, -1, -1,
++ 38, -1, -1, -1, -1, -1, -1, -1,
++ -1, -1, 36, -1, -1, 39, 36, 36,
++ -1, -1, -1, -1, 36, -1, -1, -1,
++ 36, 36, -1, -1, 40, 41, -1, -1,
++ -1, 38, -1, -1, -1, -1, -1, -1,
++ 29, -1, -1, 39, -1, -1, -1, -1,
++ -1, -1, -1, -1, -1, -1, -1, -1,
++ -1, -1, 40, -1, -1, -1, -1, -1,
++ -1, -1, -1, -1
++};
++
++int fromcheck_next_state(int current_state, int next_token) {
++ if (next_token < 0 || next_token >= 10) return -1;
++ return fromcheck_trans[10*current_state + next_token];
++}
>Update to 2.31: various additional characters.naddy2010-07-262-6/+5 * Update my email address to my new @FreeBSD.org addyjsa2010-07-251-1/+1 * Fix pkg-messagemakc2010-07-253-18/+21 * Update to 1.05.3.20100621.thierry2010-07-232-4/+4 * Update to 4.30makc2010-07-195-61/+196 * Add RUN_DEPENDS on x11-fonts/fontconfig, which is used in @exec.olgeni2010-07-021-1/+3 * - Use USE_TK.stefan2010-07-011-2/+4 * Remove run time dependency on perl.stefan2010-06-291-1/+2 * - Change my maintainer address.ashish2010-06-111-1/+1 * - Update to 0.5.10jacula2010-06-012-4/+4 * Connect isabellamakc2010-05-251-0/+1 * Add new port x11-fonts/isabella:makc2010-05-254-0/+56 * - Unbroke build with textproc/xmlto installedfluffy2010-05-101-0/+1 * The xfs startup script source still uses the RC_SUBR macro, whichmiwi2010-05-092-1/+2 * - Update to Xorg 7.5miwi2010-05-01113-325/+227 * - Update to 0.5.8jacula2010-04-242-5/+5 * Attach ecofont to the build.wxs2010-04-111-0/+1 * Ecofont is designed to conserve ink and toner by placing minute holes in thewxs2010-04-114-0/+57 * re-assign back to ports@pgollucci2010-04-051-1/+1 * Make fetchable. The original sitemaho2010-03-301-1/+3 * - update to 1.4.1dinoex2010-03-283-3/+3 * Begin the process of deprecating sysutils/rc_subr bydougb2010-03-271-1/+1 * Remove the note about x11-fonts/mathfonts, which has been removed.thierry2010-02-271-2/+0 * Back out until I re-gather error log.cracauer2010-02-131-1/+0 * Add missing dependency. This fixes a configure-time error.cracauer2010-02-131-0/+1 * Standart GOST font. GOST 2.304-81miwi2010-02-136-0/+71 * - update to jpeg-8dinoex2010-02-051-1/+1 * - Remove dead mirrorsamdmi32010-02-041-8/+2 * - some indent changesgarga2010-01-281-4/+4 * - Some indent changesgarga2010-01-281-11/+11 * Update to 1.05.2.20091227.thierry2010-01-153-18/+10 * - Update to 0.5.6pgollucci2010-01-044-27/+27 * - Restore maintainershippav2009-12-311-1/+1 * Remove depends on xorgahze2009-12-211-1/+2 * For ports maintained by ports@FreeBSD.org, remove names and/ordougb2009-12-218-21/+1 * - Remove mention of XF86Configpav2009-12-141-2/+1 * Update to 2.30ahze2009-12-142-4/+4 * Gentium is a typeface family designed to enable the diverse ethnicpav2009-12-076-85/+66 * Presenting GNOME 2.28.1 for FreeBSD. The official release notes for thismarcus2009-11-2910-25/+136 * - Update to 3.1miwi2009-11-202-5/+6 * Upgrade to the latest to make fetchable again.thierry2009-09-244-7/+9 * - Fix fetch by adding correct SF urls for different filesamdmi32009-09-221-6/+6 * Use the default MTREE_FILE.marcus2009-09-091-2/+0 * Move the definition of USE_PERL5_BUILD above the inclusion oflinimon2009-08-301-1/+2 * - Fix some more SF URLs, including ones in PATCH_SITES and comments (for cons...amdmi32009-08-281-1/+1 * - Switch SourceForge ports to the new File Release System: categories startin...amdmi32009-08-229-17/+11 * - Update to 0.6.17amdmi32009-08-084-7/+9 * -Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.mezz2009-08-033-3/+3 * - bump all port that indirectly depends on libjpeg and have not yet been bump...dinoex2009-07-311-1/+1 * - Update maintainer mail adressmiwi2009-07-141-1/+1 * - Reset maintainerpav2009-07-091-1/+1 * - Update to 0.6.16dhn2009-07-083-14/+32 * - Do not needlessly run-depend on perlamdmi32009-06-251-1/+2 * - Update pkg-messagepav2009-06-192-12/+18 * Convert most of remaining ports that depend on xorg-libraries toamdmi32009-06-094-4/+6 * . add linux-f10 ports to the rank of CONFLICTS for linux-fc4 ports;bsam2009-06-031-2/+2 * . add CONFLICTS to linux-f8 infrastructure ports;bsam2009-06-031-0/+3 * Here are new Linux Fedora 10 infrastructure ports.bsam2009-06-024-20/+23 * - Mark most of my ports MAKE_JOBS_SAFE=yespgollucci2009-05-161-0/+2 * - Update to 4.4.1pav2009-05-124-17/+26 * Update to 2.29ahze2009-05-022-4/+4 * Mark these ports has being multiple jobs safe.marcus2009-04-111-0/+1 * - Update to 0.6.15miwi2009-04-033-16/+15 * Here are new Linux Fedora 8 infrastructure ports.bsam2009-04-019-944/+75 * Finish repocopies of new linux-f8 infrastructure ports:bsam2009-04-011-1/+3 * bump PORTREVISION after cmake updatemakc2009-03-251-1/+1 * - Add mirror site while author works on hosting problems.wxs2009-03-241-1/+2 * Welcome to the new linux ports infrastructure which allows usingbsam2009-03-203-6/+3 * - Update MASTER_SITESmiwi2009-03-141-1/+1 * - Reset farrokhi@freebsd.org due to long period of inactivity.miwi2009-03-101-1/+1 * - Use my FreeBSD address on the ports I maintaindhn2009-03-071-1/+1 * The mission of the Scientific and Technical Information Exchange (STIX) fontthierry2009-03-016-0/+123 * Fix a typo.thierry2009-02-281-1/+1 * Upgrade to 1.04 and make fetchable again.thierry2009-02-272-3/+3 * Use my @FreeBSD.org email for the rest of my portsmakc2009-02-211-1/+1 * - Update to 20090215miwi2009-02-202-4/+4 * 2009-01-19 games/emacs-chess: has been broken for more than 6 monthsmiwi2009-02-046-122/+0 * - Use GNOME macro instead of ${MASTER_SITE_GNOME}, removearaujo2009-02-021-1/+1 * - Update download locationpav2009-01-311-1/+1 * Fix path for xfs default configuration file.flz2009-01-292-2/+3 * - update to 20090104 versionpgollucci2009-01-275-495/+15 * Update to 2.28ahze2009-01-262-4/+4 * - Update X.org ports to 7.4+ (few ports are more recent than the katamari).flz2009-01-2431-108/+56 * - Update fntsample to 3.0pav2009-01-212-21/+54 * - Update to 4.1.8amdmi32009-01-173-36/+27 * - Update to maintainer mail adressmiwi2009-01-161-1/+1 * - Fix plist with perl 5.8.9pav2009-01-151-0/+2 * - Add some more contributed programming fontsrafan2009-01-133-9/+54 * Fix the plist, bump the PORTREVISION.mezz2009-01-122-2/+2 * Presenting GNOME 2.24 for FreeBSD.marcus2009-01-108-26/+49 * - USE_GZIP does not need to be defined last few yearspav2009-01-091-1/+0 * Add a patch for removing four bogus Japanese glyphs as a workaround.hrs2008-12-312-0/+95 * Mark broken and deprecated: these fonts are unfetchable and we are notthierry2008-12-302-1/+9 * - Update to 4.28.stefan2008-12-194-204/+182 * Reset gurkan@phys.ethz.ch due to maintainer-timeouts and no response tolinimon2008-12-161-1/+1 * - Improve description a littlepav2008-12-121-1/+4 * Inconsolata is a monospace font.pav2008-12-124-0/+40 * Reset mita@jp.FreeBSD.org due to long period of inactivity.linimon2008-12-081-1/+1 * - use DOCSDIRitetcu2008-11-242-14/+12 * Update to wqy font set:delphij2008-11-037-53/+153 * MonteCarlo is a bitmap font suitable for code editors. All the charactersmiwi2008-11-024-0/+45 * - Fix reference to X11BASE in pkg-descr.lippe2008-10-263-10/+7 * Install the proprietary license text as advertised in pkg-message.stefan2008-10-252-1/+5 * Profont - The ultimate programming font.amdmi32008-10-115-0/+53 * Update to 2.27ahze2008-10-022-4/+4 * - Update to 20080907miwi2008-09-302-4/+4 * Reset infofarmer due to maintainer-timeouts and no response to email.linimon2008-09-074-4/+4 * - Update to 20080820miwi2008-08-264-8/+8 * Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.rafan2008-08-211-2/+0 * Reset conrads@cox.net due to lack of time to work on FreeBSD.linimon2008-08-203-3/+3