aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-26 03:45:11 +0800
committerpav <pav@FreeBSD.org>2003-12-26 03:45:11 +0800
commit925312235e4dff82c335147e76ed265f7a76858d (patch)
treee2604089c2b86a9ad3e9fb669b48ebf6f925e5bf /mail
parenta6f2722fa1e029466276b7b001ec7df89fe0c2af (diff)
downloadfreebsd-ports-gnome-925312235e4dff82c335147e76ed265f7a76858d.tar.gz
freebsd-ports-gnome-925312235e4dff82c335147e76ed265f7a76858d.tar.zst
freebsd-ports-gnome-925312235e4dff82c335147e76ed265f7a76858d.zip
Add mail-notification, an icon for the GNOME Notification Area that
informs users if they have new mail. * multiple folder support * mbox, MH, Maildir and Sylpheed support * POP3 support (if the GNet library is available) * automatic folder format detection * responsive UI (multi-threaded application) * HIG-compliant user interface * themeable stock icons PR: ports/56969 Submitted by: Jean-Yves Lefort <jylefort@brutele.be>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/mail-notification/Makefile53
-rw-r--r--mail/mail-notification/distinfo1
-rw-r--r--mail/mail-notification/pkg-descr17
-rw-r--r--mail/mail-notification/pkg-plist49
5 files changed, 121 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 908db36e8d3c..7dc9829966d0 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -126,6 +126,7 @@
SUBDIR += lmtpd
SUBDIR += lookout
SUBDIR += mahogany
+ SUBDIR += mail-notification
SUBDIR += mail2procmailrc
SUBDIR += mail2sms
SUBDIR += mailagent
diff --git a/mail/mail-notification/Makefile b/mail/mail-notification/Makefile
new file mode 100644
index 000000000000..ba753cb02592
--- /dev/null
+++ b/mail/mail-notification/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: mail-notification
+# Date created: 18 Sep 2003
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mail-notification
+PORTVERSION= 0.3.2
+CATEGORIES= mail
+MASTER_SITES= http://streamtuner.sourceforge.net/mail-notification/
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= A mail notification for the GNOME 2.0 system tray
+
+USE_X_PREFIX= yes
+USE_GNOME= gnomeprefix gnomehack libgnomeui
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_MBOX)
+CONFIGURE_ARGS+= --disable-mbox
+.endif
+.if defined(WITHOUT_MH)
+CONFIGURE_ARGS+= --disable-mh
+.endif
+.if defined(WITHOUT_MAILDIR)
+CONFIGURE_ARGS+= --disable-maildir
+.endif
+.if defined(WITHOUT_POP3)
+CONFIGURE_ARGS+= --disable-pop3
+.else
+LIB_DEPENDS+= gnet-2.0:${PORTSDIR}/net/gnet2
+.endif
+.if defined(WITHOUT_SYLPHEED)
+CONFIGURE_ARGS+= --disable-sylpheed
+.endif
+
+pre-everything::
+ @${ECHO} ""
+ @${ECHO} "You may use the following build options:"
+ @${ECHO} ""
+ @${ECHO} " WITHOUT_MBOX=yes Disable mbox support"
+ @${ECHO} " WITHOUT_MH=yes Disable MH support"
+ @${ECHO} " WITHOUT_MAILDIR=yes Disable Maildir support"
+ @${ECHO} " WITHOUT_POP3=yes Disable POP3 support"
+ @${ECHO} " WITHOUT_SYLPHEED=yes Disable Sylpheed support"
+ @${ECHO} ""
+
+.include <bsd.port.post.mk>
diff --git a/mail/mail-notification/distinfo b/mail/mail-notification/distinfo
new file mode 100644
index 000000000000..188612f377c2
--- /dev/null
+++ b/mail/mail-notification/distinfo
@@ -0,0 +1 @@
+MD5 (mail-notification-0.3.2.tar.gz) = 164e4b8e6407949fcbf79472960d4fb0
diff --git a/mail/mail-notification/pkg-descr b/mail/mail-notification/pkg-descr
new file mode 100644
index 000000000000..d25d85339c1d
--- /dev/null
+++ b/mail/mail-notification/pkg-descr
@@ -0,0 +1,17 @@
+Mail Notification is an icon for the GNOME Notification Area that
+informs users if they have new mail.
+
+Features:
+
+ * multiple folder support
+ * mbox, MH, Maildir and Sylpheed support
+ * POP3 support (if the GNet library is available)
+ * automatic folder format detection
+ * responsive UI (multi-threaded application)
+ * HIG-compliant user interface
+ * themeable stock icons
+
+WWW: http://www.nongnu.org/mailnotify/
+
+- Jean-Yves Lefort
+jylefort@brutele.be
diff --git a/mail/mail-notification/pkg-plist b/mail/mail-notification/pkg-plist
new file mode 100644
index 000000000000..93b9293100b8
--- /dev/null
+++ b/mail/mail-notification/pkg-plist
@@ -0,0 +1,49 @@
+bin/mail-notification
+etc/gconf/gconf.xml.defaults/apps/mail-notification/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/mail-notification/commands/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/mail-notification/commands/new-mail/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/mail-notification/commands/clicked/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/mail-notification/local/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/mail-notification/local/delay/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/mail-notification/remote/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/mail-notification/remote/delay/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/commands/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/commands/new-mail/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/commands/clicked/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/local/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/local/delay/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/remote/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/remote/delay/%gconf.xml
+etc/gconf/schemas/mail-notification.schemas
+share/gnome/applications/mail-notification.desktop
+share/gnome/mail-notification/ui/about-icon.png
+share/gnome/mail-notification/ui/add-icon.png
+share/gnome/mail-notification/ui/add-pop3.glade
+share/gnome/mail-notification/ui/dialog.glade
+share/gnome/mail-notification/ui/logo.png
+share/gnome/mail-notification/ui/mail.png
+share/gnome/mail-notification/ui/menu.glade
+share/gnome/mail-notification/ui/no-mail.png
+share/gnome/mail-notification/ui/preferences-icon.png
+share/gnome/mail-notification/ui/preferences.glade
+share/gnome/pixmaps/mail-notification.png
+share/locale/fr/LC_MESSAGES/mail-notification.mo
+@dirrm etc/gconf/gconf.xml.defaults/apps/mail-notification/commands/new-mail
+@dirrm etc/gconf/gconf.xml.defaults/apps/mail-notification/commands/clicked
+@dirrm etc/gconf/gconf.xml.defaults/apps/mail-notification/commands
+@dirrm etc/gconf/gconf.xml.defaults/apps/mail-notification/local/delay
+@dirrm etc/gconf/gconf.xml.defaults/apps/mail-notification/local
+@dirrm etc/gconf/gconf.xml.defaults/apps/mail-notification/remote/delay
+@dirrm etc/gconf/gconf.xml.defaults/apps/mail-notification/remote
+@dirrm etc/gconf/gconf.xml.defaults/apps/mail-notification
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/commands/new-mail
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/commands/clicked
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/commands
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/local/delay
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/local
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/remote/delay
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/remote
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification
+@dirrm share/gnome/mail-notification/ui
+@dirrm share/gnome/mail-notification