aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2005-08-30 17:55:47 +0800
committerkrion <krion@FreeBSD.org>2005-08-30 17:55:47 +0800
commit96ff4019507eff094970a0394212e57831c2bbd2 (patch)
tree8132b1a412cf8515da033d72e4d1ae5a661cb470 /mail
parent03fa92acc5e3b120bed22ee010324c641f53eea4 (diff)
downloadfreebsd-ports-gnome-96ff4019507eff094970a0394212e57831c2bbd2.tar.gz
freebsd-ports-gnome-96ff4019507eff094970a0394212e57831c2bbd2.tar.zst
freebsd-ports-gnome-96ff4019507eff094970a0394212e57831c2bbd2.zip
Fix distinfo for vvv.quote patch
Fix handling of pgp messages (from mutt's cvs) PR: ports/85465 Submitted by: maintainer
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt-devel/distinfo4
-rw-r--r--mail/mutt-devel/files/patch-pgp.c27
2 files changed, 29 insertions, 2 deletions
diff --git a/mail/mutt-devel/distinfo b/mail/mutt-devel/distinfo
index 7b2d3a41e37d..3a9481c22d55 100644
--- a/mail/mutt-devel/distinfo
+++ b/mail/mutt-devel/distinfo
@@ -6,8 +6,8 @@ MD5 (mutt/patch-1.5.10.vvv.nntp.gz) = ac9a4c8bf25a96648bb08cde4ced4c05
SIZE (mutt/patch-1.5.10.vvv.nntp.gz) = 98153
MD5 (mutt/patch-1.5.10.vvv.initials.gz) = 91eea7344625830bf4231dc1d56cb799
SIZE (mutt/patch-1.5.10.vvv.initials.gz) = 682
-MD5 (mutt/patch-1.5.10.vvv.quote.gz) = 7d9b9c2d52318782d81d2ffb95576d48
-SIZE (mutt/patch-1.5.10.vvv.quote.gz) = 1580
+MD5 (mutt/patch-1.5.10.vvv.quote.gz) = a447f9362a9ef37c8fdc58efa73ed326
+SIZE (mutt/patch-1.5.10.vvv.quote.gz) = 1963
MD5 (mutt/patch-1.5.4.cd.ifdef.1) = a545036cdb55519154d0b35465f52daa
SIZE (mutt/patch-1.5.4.cd.ifdef.1) = 3545
MD5 (mutt/p0-patch-1.5.6.dw.mbox-hook.1) = 9e29a6778ab07a4de3442691e4573fea
diff --git a/mail/mutt-devel/files/patch-pgp.c b/mail/mutt-devel/files/patch-pgp.c
new file mode 100644
index 000000000000..ae926fbc2b1d
--- /dev/null
+++ b/mail/mutt-devel/files/patch-pgp.c
@@ -0,0 +1,27 @@
+--- pgp.c.orig Thu Aug 11 23:22:41 2005
++++ pgp.c Thu Aug 25 08:01:22 2005
+@@ -381,16 +381,21 @@
+ }
+
+ /* treat empty result as sign of failure */
+- rewind (pgpout);
+- if ((c = fgetc (pgpout)) == EOF)
++ if (pgpout)
++ {
++ rewind (pgpout);
++ c = fgetc (pgpout);
++ ungetc (c, pgpout);
++ }
++ if (!clearsign && (!pgpout || c == EOF))
+ {
+ mutt_error _("Could not decrypt PGP message");
++ mutt_sleep (1);
+ pgp_void_passphrase ();
+ rc = -1;
+
+ goto out;
+ }
+- ungetc (c, pgpout);
+ }
+
+ /*