aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2015-01-07 00:09:52 +0800
committerriggs <riggs@FreeBSD.org>2015-01-07 00:09:52 +0800
commit9b81c1bc57144ae1f26171f218a9da75ab51cee2 (patch)
tree1859a4b30c2405d82106b7fb130b81f34263f6cf /mail
parentf3dadeb8adc008b393546b34a226e5ce2442e65a (diff)
downloadfreebsd-ports-gnome-9b81c1bc57144ae1f26171f218a9da75ab51cee2.tar.gz
freebsd-ports-gnome-9b81c1bc57144ae1f26171f218a9da75ab51cee2.tar.zst
freebsd-ports-gnome-9b81c1bc57144ae1f26171f218a9da75ab51cee2.zip
- Update to upstream version 1.2.0
- Remove GNOMEKEYRING OPTION, add LIBSECRET PR: 195876 Submitted by: jbeich@vfemail.net
Diffstat (limited to 'mail')
-rw-r--r--mail/mpop/Makefile14
-rw-r--r--mail/mpop/distinfo4
-rw-r--r--mail/mpop/files/patch-doc-mpop.136
3 files changed, 32 insertions, 22 deletions
diff --git a/mail/mpop/Makefile b/mail/mpop/Makefile
index 73f6482fdea1..5b180778a1f4 100644
--- a/mail/mpop/Makefile
+++ b/mail/mpop/Makefile
@@ -2,30 +2,27 @@
# $FreeBSD$
PORTNAME= mpop
-PORTVERSION= 1.0.29
-PORTREVISION= 2
+DISTVERSION= 1.2.0
CATEGORIES= mail
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Small and fast POP3 client
LICENSE= GPLv3 # (or later)
-USES= pkgconfig tar:bzip2
+USES= gmake pkgconfig tar:xz
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-silent-rules
INFO= mpop
-OPTIONS_DEFINE= GNOMEKEYRING GSASL IDN NLS
+OPTIONS_DEFINE= GSASL IDN LIBSECRET NLS
OPTIONS_RADIO= SSL
OPTIONS_RADIO_SSL= GNUTLS OPENSSL
OPTIONS_DEFAULT= IDN OPENSSL
OPTIONS_SUB= yes
-GNOMEKEYRING_LIB_DEPENDS= libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring
-GNOMEKEYRING_CONFIGURE_WITH= gnome-keyring
GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
GNUTLS_CONFIGURE_ON= --with-ssl=gnutls
GSASL_DESC= SASL authentication support via GNU SASL
@@ -33,6 +30,9 @@ GSASL_LIB_DEPENDS= libgsasl.so:${PORTSDIR}/security/gsasl
GSASL_CONFIGURE_OFF= --without-libgsasl
IDN_LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn
IDN_CONFIGURE_WITH= libidn
+LIBSECRET_DESC= GNOME password management
+LIBSECRET_LIB_DEPENDS= libsecret-1.so:${PORTSDIR}/security/libsecret
+LIBSECRET_CONFIGURE_WITH= libsecret
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
OPENSSL_USE= openssl=yes
diff --git a/mail/mpop/distinfo b/mail/mpop/distinfo
index 5e2fcdc61c18..a9be2b635a13 100644
--- a/mail/mpop/distinfo
+++ b/mail/mpop/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mpop-1.0.29.tar.bz2) = bd7409741629669969b176ed664e0adec449bf434b9f333e74fed534b28690b8
-SIZE (mpop-1.0.29.tar.bz2) = 292369
+SHA256 (mpop-1.2.0.tar.xz) = 9d28817a6950f64aadf10bf5841400701917102181ebf96c136fbd4707c17ba7
+SIZE (mpop-1.2.0.tar.xz) = 264560
diff --git a/mail/mpop/files/patch-doc-mpop.1 b/mail/mpop/files/patch-doc-mpop.1
index 02585e08d934..75539ed7ef86 100644
--- a/mail/mpop/files/patch-doc-mpop.1
+++ b/mail/mpop/files/patch-doc-mpop.1
@@ -1,23 +1,33 @@
--- doc/mpop.1.orig 2009-10-05 16:47:15.000000000 -0300
+++ doc/mpop.1 2009-10-24 12:18:19.000000000 -0200
-@@ -333,6 +333,11 @@
+@@ -305,8 +305,8 @@ intermediate CAs.)
.br
- On Debian based systems, you can install the \fBca\-certificates\fP package and
- use the file \fB/etc/ssl/certs/ca\-certificates.crt\fP.
-++.br
-+On FreeBSD based systems, you can install the \fBsecurity/ca_root_nss\fP port and
-++use the file \fB/usr/local/share/certs/ca-root-nss.crt\fP. Please note that if
-++you are installing mpop from ports with OpenSSL or gnutls support,
-++the \fBsecurity/ca_root_nss\fP port will be installed automaticly.
+ The list of trusted CAs is specified using the \fBtls_trust_file\fP command.
+ Usually there is some system-wide default file available, e.g.
+-/etc/ssl/certs/ca\-certificates.crt on Debian-based systems, but you can
+-also choose to select the trusted CAs yourself.
++/usr/local/share/certs/ca\-root\-nss.crt on FreeBSD and DragonFly systems,
++but you can also choose to select the trusted CAs yourself.
.br
- An empty argument disables this feature.
+ One practical problem with this approach is that the client program should also
+ check if the server certificate has been revoked for some reason, using a
+@@ -350,8 +350,8 @@ or tunnel the session through TLS (\fIof
+ .IP "tls_trust_file \fIfile\fP"
+ Activate server certificate verification using a list of truted Certification
+ Authorities (CAs). The file must be in PEM format. Some systems provide a
+-system-wide default file, e.g. /etc/ssl/certs/ca\-certificates.crt on
+-Debian-based systems with the ca\-certificates package.
++system-wide default file, e.g. /usr/local/share/certs/ca\-root\-nss.crt on
++FreeBSD and DragonFly with ca_root_nss package or security/ca_root_nss port.
+ An empty argument disables this. You should also use \fBtls_crl_file\fP.
.IP "tls_crl_file [\fIfile\fP]"
-@@ -457,7 +462,7 @@
+ Set a certificate revocation list (CRL) file for TLS, to check for revoked
+@@ -542,7 +542,7 @@ tls on
.br
- # Enable full TLS certificate checks.
+ # as in this example, or download the root certificate of your CA and use that.
.br
-tls_trust_file /etc/ssl/certs/ca\-certificates.crt
-+tls_trust_file /usr/local/share/certs/ca-root-nss.crt
++tls_trust_file /usr/local/share/certs/ca\-root\-nss.crt
.br
- # Use the POP3-over-TLS variant instead of the STARTTLS variant.
+
.br