aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-11 05:19:17 +0800
committermarino <marino@FreeBSD.org>2016-09-11 05:19:17 +0800
commit9ca84a7a77d173bcaa2d8a73c94eddd8393f996c (patch)
tree980283aef615a09e263831bb3771055a7de52325 /mail
parenta31399a89fd309c853650e4acbed7544c0d04836 (diff)
downloadfreebsd-ports-gnome-9ca84a7a77d173bcaa2d8a73c94eddd8393f996c.tar.gz
freebsd-ports-gnome-9ca84a7a77d173bcaa2d8a73c94eddd8393f996c.tar.zst
freebsd-ports-gnome-9ca84a7a77d173bcaa2d8a73c94eddd8393f996c.zip
mail/qmail-spamcontrol: document and support SSL requirement
My eyes are bleeding from looking at this qmail stuff. The compiling in the pre-patch target is an essentially nice touch. Approved by: SSL blanket
Diffstat (limited to 'mail')
-rw-r--r--mail/qmail/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index ecc23f4c742d..612eff14c567 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -283,9 +283,12 @@ EXTRA_MAN8= qmail-badloadertypes.8 qmail-badmimetypes.8 qmail-mfrules.8 \
qmail-recipients.8 qmail-smtpam.8
ALL_TARGET+= ${EXTRA_MAN8}
MMAN8+= ${EXTRA_MAN8}
-USES+= perl5
+USES+= perl5 ssl
USE_PERL5= patch build
CFLAGS+= -include /usr/include/errno.h
+CFLAGS+= -I${OPENSSLINC} -L${OPENSSLLIB}
+# Required for the insane pre-patch compiling done by this slave port
+PATCH_DEPENDS+= ${BUILD_DEPENDS:M*ssl*}
.endif
.if defined(SLAVE_LDAP)
@@ -660,6 +663,8 @@ post-extract:
.if defined(SLAVE_SPAMCONTROL)
@cd ${WRKSRC} && ${TAR} -xzf ${DISTDIR}/${DIST_SUBDIR}/${SPAMCONTROL_DIST}
@cd ${WRKDIR} && ${TAR} -xzf ${DISTDIR}/${DIST_SUBDIR}/${UCSPI_SSL_DIST}
+ ${REINPLACE_CMD} -e "s@-lssl@-L${OPENSSLLIB} -lssl@g" \
+ ${UCSPISRC}/src/ssl.lib
.endif
# XXX - Move all the major patch applications to post-extract