aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-02-05 09:14:11 +0800
committeredwin <edwin@FreeBSD.org>2003-02-05 09:14:11 +0800
commitb681b27015d5b3157debf7ec954d818953d3e657 (patch)
tree5feb35b9f3782cc89e155376c69ea4587b924fab /mail
parent087fed99db0955290e9330083cfaedc572e3d953 (diff)
downloadfreebsd-ports-gnome-b681b27015d5b3157debf7ec954d818953d3e657.tar.gz
freebsd-ports-gnome-b681b27015d5b3157debf7ec954d818953d3e657.tar.zst
freebsd-ports-gnome-b681b27015d5b3157debf7ec954d818953d3e657.zip
NEW PORT: msgconvert - .MSG to mbox convertor.
Convert .MSG files to multipart MIME messages. PR: ports/47398 Submitted by: Franz Klammer <root@sisko.webonaut.com>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/msgconvert/Makefile32
-rw-r--r--mail/msgconvert/distinfo1
-rw-r--r--mail/msgconvert/pkg-comment1
-rw-r--r--mail/msgconvert/pkg-descr3
-rw-r--r--mail/msgconvert/pkg-plist1
6 files changed, 39 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 1d915aebe1f5..308f70035614 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -135,6 +135,7 @@
SUBDIR += mmr
SUBDIR += movemail
SUBDIR += mreport
+ SUBDIR += msgconvert
SUBDIR += mulberry
SUBDIR += mutt
SUBDIR += mutt-devel
diff --git a/mail/msgconvert/Makefile b/mail/msgconvert/Makefile
new file mode 100644
index 000000000000..afc13c6dc932
--- /dev/null
+++ b/mail/msgconvert/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: msgconvert
+# Date created: 12 Jan 2003
+# Whom: Franz Klammer <klammer@webonaut.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= msgconvert
+PORTVERSION= 20020831
+CATEGORIES= mail perl5
+MASTER_SITES= http://www.webonaut.com/distfiles/
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION}.pl
+EXTRACT_SUFX= .bz2
+
+MAINTAINER= klammer@webonaut.com
+
+RUN_DEPENDS= ${SITE_PERL}/OLE/Storage_Lite.pm:${PORTSDIR}/devel/p5-OLE-Storage_Lite \
+ ${SITE_PERL}/MIME/Words.pm:${PORTSDIR}/mail/p5-MIME-Tools \
+ ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+USE_BZIP2= yes
+USE_PERL5= yes
+EXTRACT_AFTER_ARGS= > ${PORTNAME}.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}.pl
+
+.include <bsd.port.mk>
diff --git a/mail/msgconvert/distinfo b/mail/msgconvert/distinfo
new file mode 100644
index 000000000000..636bb2b07d18
--- /dev/null
+++ b/mail/msgconvert/distinfo
@@ -0,0 +1 @@
+MD5 (msgconvert-20020831.pl.bz2) = 6bef68b9349dd6c3a02d8f3d1d83c5e2
diff --git a/mail/msgconvert/pkg-comment b/mail/msgconvert/pkg-comment
new file mode 100644
index 000000000000..f04ae64828dd
--- /dev/null
+++ b/mail/msgconvert/pkg-comment
@@ -0,0 +1 @@
+Convert .MSG files to multipart MIME messages (mbox)
diff --git a/mail/msgconvert/pkg-descr b/mail/msgconvert/pkg-descr
new file mode 100644
index 000000000000..dc2271417702
--- /dev/null
+++ b/mail/msgconvert/pkg-descr
@@ -0,0 +1,3 @@
+Convert .MSG files to multipart MIME messages (mbox).
+
+WWW: http://www.xs4all.nl/~mvz/software/msgconv.html
diff --git a/mail/msgconvert/pkg-plist b/mail/msgconvert/pkg-plist
new file mode 100644
index 000000000000..2c45becece40
--- /dev/null
+++ b/mail/msgconvert/pkg-plist
@@ -0,0 +1 @@
+bin/msgconvert.pl