aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-29 23:09:42 +0800
committerpav <pav@FreeBSD.org>2006-04-29 23:09:42 +0800
commitbbb8aa537c5303e3c8092cc67a1bdf58c05cf6c8 (patch)
tree4d3c5f11565bb28277726a86a74b99614f286859 /mail
parentf12715a9a6c4c2a24e1caaf4fb687f6f9ef75e56 (diff)
downloadfreebsd-ports-gnome-bbb8aa537c5303e3c8092cc67a1bdf58c05cf6c8.tar.gz
freebsd-ports-gnome-bbb8aa537c5303e3c8092cc67a1bdf58c05cf6c8.tar.zst
freebsd-ports-gnome-bbb8aa537c5303e3c8092cc67a1bdf58c05cf6c8.zip
This plugin renders HTML mail using the gtkhtml2 rendering widget.
PR: ports/95540 Submitted by: Pawel Pekala <c0rn@o2.pl>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/claws-mail-gtkhtml2_viewer/Makefile37
-rw-r--r--mail/claws-mail-gtkhtml2_viewer/distinfo3
-rw-r--r--mail/claws-mail-gtkhtml2_viewer/files/patch-configure.ac29
-rw-r--r--mail/claws-mail-gtkhtml2_viewer/pkg-descr1
-rw-r--r--mail/sylpheed-claws-gtkhtml2_viewer/Makefile37
-rw-r--r--mail/sylpheed-claws-gtkhtml2_viewer/distinfo3
-rw-r--r--mail/sylpheed-claws-gtkhtml2_viewer/files/patch-configure.ac29
-rw-r--r--mail/sylpheed-claws-gtkhtml2_viewer/pkg-descr1
9 files changed, 141 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 84048a1a652e..28568d0c8292 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -527,6 +527,7 @@
SUBDIR += sylpheed-claws-cachesaver
SUBDIR += sylpheed-claws-etpan_privacy
SUBDIR += sylpheed-claws-fetchinfo
+ SUBDIR += sylpheed-claws-gtkhtml2_viewer
SUBDIR += sylpheed-claws-mailmbox
SUBDIR += sylpheed-claws-newmail
SUBDIR += sylpheed-claws-notification
diff --git a/mail/claws-mail-gtkhtml2_viewer/Makefile b/mail/claws-mail-gtkhtml2_viewer/Makefile
new file mode 100644
index 000000000000..c19e9404cb36
--- /dev/null
+++ b/mail/claws-mail-gtkhtml2_viewer/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: sylpheed-claws-gtkhtml2_viewer
+# Date created: 7 April 2006
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkhtml2_viewer
+PORTVERSION= 0.8
+CATEGORIES= mail
+MASTER_SITES= http://claws.sylpheed.org/downloads/plugins/
+PKGNAMEPREFIX= sylpheed-claws-
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= HTML renderer plugin for sylpheed-claws
+
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= sylpheed-claws>=2.1:${PORTSDIR}/mail/sylpheed-claws
+RUN_DEPENDS= sylpheed-claws>=2.1:${PORTSDIR}/mail/sylpheed-claws
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= autoconf:259
+USE_GNOME= libgtkhtml
+USE_ICONV= yes
+USE_GETTEXT= yes
+
+CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
+ --with-libintl-prefix=${LOCALBASE}
+
+PLIST_FILES= lib/sylpheed-claws/plugins/gtkhtml2_viewer.a \
+ lib/sylpheed-claws/plugins/gtkhtml2_viewer.la \
+ lib/sylpheed-claws/plugins/gtkhtml2_viewer.so \
+ share/locale/es/LC_MESSAGES/gtkhtml2_viewer.mo \
+ share/locale/pt_BR/LC_MESSAGES/gtkhtml2_viewer.mo
+
+.include <bsd.port.mk>
diff --git a/mail/claws-mail-gtkhtml2_viewer/distinfo b/mail/claws-mail-gtkhtml2_viewer/distinfo
new file mode 100644
index 000000000000..d1e2d0aba0c3
--- /dev/null
+++ b/mail/claws-mail-gtkhtml2_viewer/distinfo
@@ -0,0 +1,3 @@
+MD5 (gtkhtml2_viewer-0.8.tar.gz) = 2b5b4fd18cd1bcd853ac077ef53bdc6c
+SHA256 (gtkhtml2_viewer-0.8.tar.gz) = 74015cc8a38f620db14827a651f321d2019c1f000a682db2a168362558597455
+SIZE (gtkhtml2_viewer-0.8.tar.gz) = 365026
diff --git a/mail/claws-mail-gtkhtml2_viewer/files/patch-configure.ac b/mail/claws-mail-gtkhtml2_viewer/files/patch-configure.ac
new file mode 100644
index 000000000000..ce3206ae9834
--- /dev/null
+++ b/mail/claws-mail-gtkhtml2_viewer/files/patch-configure.ac
@@ -0,0 +1,29 @@
+--- configure.ac.orig Thu Apr 6 14:33:18 2006
++++ configure.ac Sun Apr 9 14:04:14 2006
+@@ -33,9 +33,11 @@
+ if test x$PKG_CONFIG = xno ; then
+ AC_MSG_ERROR([*** pkg-config not found. See http://www.freedesktop.org/software/pkgconfig/])
+ fi
+-
+-prefix=$( $PKG_CONFIG --variable=prefix sylpheed-claws )
++if test -z $prefix ; then
++ prefix=$( $PKG_CONFIG --variable=prefix sylpheed-claws )
++fi
+ localedir="${prefix}/share/locale"
++
+ AC_ARG_WITH(localedir,
+ [ --with-localedir=DIR Locale directory],
+ [localedir="$withval"])
+@@ -46,7 +48,11 @@
+ PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 2.0.0.141)
+ AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
+ AC_SUBST(SYLPHEED_CLAWS_LIBS)
+-SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++if test -z $prefix ; then
++ SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++else
++ SYLPHEED_CLAWS_PLUGINDIR=${prefix}/lib/sylpheed-claws/plugins
++fi
+ AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)
+
+ dnl Check for GLib
diff --git a/mail/claws-mail-gtkhtml2_viewer/pkg-descr b/mail/claws-mail-gtkhtml2_viewer/pkg-descr
new file mode 100644
index 000000000000..3af4cb88f8db
--- /dev/null
+++ b/mail/claws-mail-gtkhtml2_viewer/pkg-descr
@@ -0,0 +1 @@
+This plugin renders HTML mail using the gtkhtml2 rendering widget.
diff --git a/mail/sylpheed-claws-gtkhtml2_viewer/Makefile b/mail/sylpheed-claws-gtkhtml2_viewer/Makefile
new file mode 100644
index 000000000000..c19e9404cb36
--- /dev/null
+++ b/mail/sylpheed-claws-gtkhtml2_viewer/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: sylpheed-claws-gtkhtml2_viewer
+# Date created: 7 April 2006
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkhtml2_viewer
+PORTVERSION= 0.8
+CATEGORIES= mail
+MASTER_SITES= http://claws.sylpheed.org/downloads/plugins/
+PKGNAMEPREFIX= sylpheed-claws-
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= HTML renderer plugin for sylpheed-claws
+
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= sylpheed-claws>=2.1:${PORTSDIR}/mail/sylpheed-claws
+RUN_DEPENDS= sylpheed-claws>=2.1:${PORTSDIR}/mail/sylpheed-claws
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= autoconf:259
+USE_GNOME= libgtkhtml
+USE_ICONV= yes
+USE_GETTEXT= yes
+
+CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
+ --with-libintl-prefix=${LOCALBASE}
+
+PLIST_FILES= lib/sylpheed-claws/plugins/gtkhtml2_viewer.a \
+ lib/sylpheed-claws/plugins/gtkhtml2_viewer.la \
+ lib/sylpheed-claws/plugins/gtkhtml2_viewer.so \
+ share/locale/es/LC_MESSAGES/gtkhtml2_viewer.mo \
+ share/locale/pt_BR/LC_MESSAGES/gtkhtml2_viewer.mo
+
+.include <bsd.port.mk>
diff --git a/mail/sylpheed-claws-gtkhtml2_viewer/distinfo b/mail/sylpheed-claws-gtkhtml2_viewer/distinfo
new file mode 100644
index 000000000000..d1e2d0aba0c3
--- /dev/null
+++ b/mail/sylpheed-claws-gtkhtml2_viewer/distinfo
@@ -0,0 +1,3 @@
+MD5 (gtkhtml2_viewer-0.8.tar.gz) = 2b5b4fd18cd1bcd853ac077ef53bdc6c
+SHA256 (gtkhtml2_viewer-0.8.tar.gz) = 74015cc8a38f620db14827a651f321d2019c1f000a682db2a168362558597455
+SIZE (gtkhtml2_viewer-0.8.tar.gz) = 365026
diff --git a/mail/sylpheed-claws-gtkhtml2_viewer/files/patch-configure.ac b/mail/sylpheed-claws-gtkhtml2_viewer/files/patch-configure.ac
new file mode 100644
index 000000000000..ce3206ae9834
--- /dev/null
+++ b/mail/sylpheed-claws-gtkhtml2_viewer/files/patch-configure.ac
@@ -0,0 +1,29 @@
+--- configure.ac.orig Thu Apr 6 14:33:18 2006
++++ configure.ac Sun Apr 9 14:04:14 2006
+@@ -33,9 +33,11 @@
+ if test x$PKG_CONFIG = xno ; then
+ AC_MSG_ERROR([*** pkg-config not found. See http://www.freedesktop.org/software/pkgconfig/])
+ fi
+-
+-prefix=$( $PKG_CONFIG --variable=prefix sylpheed-claws )
++if test -z $prefix ; then
++ prefix=$( $PKG_CONFIG --variable=prefix sylpheed-claws )
++fi
+ localedir="${prefix}/share/locale"
++
+ AC_ARG_WITH(localedir,
+ [ --with-localedir=DIR Locale directory],
+ [localedir="$withval"])
+@@ -46,7 +48,11 @@
+ PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 2.0.0.141)
+ AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
+ AC_SUBST(SYLPHEED_CLAWS_LIBS)
+-SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++if test -z $prefix ; then
++ SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++else
++ SYLPHEED_CLAWS_PLUGINDIR=${prefix}/lib/sylpheed-claws/plugins
++fi
+ AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)
+
+ dnl Check for GLib
diff --git a/mail/sylpheed-claws-gtkhtml2_viewer/pkg-descr b/mail/sylpheed-claws-gtkhtml2_viewer/pkg-descr
new file mode 100644
index 000000000000..3af4cb88f8db
--- /dev/null
+++ b/mail/sylpheed-claws-gtkhtml2_viewer/pkg-descr
@@ -0,0 +1 @@
+This plugin renders HTML mail using the gtkhtml2 rendering widget.