aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-08-16 00:25:10 +0800
committeradamw <adamw@FreeBSD.org>2015-08-16 00:25:10 +0800
commitd161da88d2911f0268cbfc7174aa478fe936c003 (patch)
treebc03784f3c10bbf51438f93629c3a0192eccaef7 /mail
parent24fab6017725f8096c8c9f9935f0d5ab25c3342d (diff)
downloadfreebsd-ports-gnome-d161da88d2911f0268cbfc7174aa478fe936c003.tar.gz
freebsd-ports-gnome-d161da88d2911f0268cbfc7174aa478fe936c003.tar.zst
freebsd-ports-gnome-d161da88d2911f0268cbfc7174aa478fe936c003.zip
Add a patch for SpamAssassin bug #7231 that resolves an incompatibility
with the output of the new Net::DNS version. See https://svn.apache.org/viewvc/spamassassin/branches/3.4/lib/Mail/SpamAssassin/Plugin/URIDNSBL.pm?r1=1694126&r2=1694125&pathrev=1694126&view=patch for more information. PR: 202281 Submitted by: Mark Martinec, author of the upstream patch
Diffstat (limited to 'mail')
-rw-r--r--mail/spamassassin/Makefile2
-rw-r--r--mail/spamassassin/files/patch-bug723127
2 files changed, 28 insertions, 1 deletions
diff --git a/mail/spamassassin/Makefile b/mail/spamassassin/Makefile
index d16ca91ecae9..74daabb46248 100644
--- a/mail/spamassassin/Makefile
+++ b/mail/spamassassin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spamassassin
PORTVERSION= 3.4.1
-PORTREVISION?= 2 # also bump japanese/spamassassin
+PORTREVISION?= 3 # also bump japanese/spamassassin
CATEGORIES?= mail perl5
MASTER_SITES= APACHE/spamassassin/source CPAN/Mail
DISTNAME= Mail-SpamAssassin-${PORTVERSION}
diff --git a/mail/spamassassin/files/patch-bug7231 b/mail/spamassassin/files/patch-bug7231
new file mode 100644
index 000000000000..d20f4d17568e
--- /dev/null
+++ b/mail/spamassassin/files/patch-bug7231
@@ -0,0 +1,27 @@
+--- lib/Mail/SpamAssassin/Plugin/URIDNSBL.pm 2015/08/04 23:14:23 1694125
++++ lib/Mail/SpamAssassin/Plugin/URIDNSBL.pm 2015/08/04 23:16:38 1694126
+@@ -942,9 +942,8 @@
+ next unless (defined($str) && defined($dom));
+ dbg("uridnsbl: got($j) NS for $dom: $str");
+
+- if ($str =~ /IN\s+NS\s+(\S+)/) {
+- my $nsmatch = lc $1;
+- $nsmatch =~ s/\.$//;
++ if ($rr->type eq 'NS') {
++ my $nsmatch = lc $rr->nsdname; # available since at least Net::DNS 0.14
+ my $nsrhblstr = $nsmatch;
+ my $fullnsrhblstr = $nsmatch;
+
+@@ -1025,9 +1024,9 @@
+ }
+ dbg("uridnsbl: complete_a_lookup got(%d) A for %s: %s", $j,$hname,$str);
+
+- local $1;
+- if ($str =~ /IN\s+A\s+(\S+)/) {
+- $self->lookup_dnsbl_for_ip($pms, $ent->{obj}, $1);
++ if ($rr->type eq 'A') {
++ my $ip_address = $rr->rdatastr;
++ $self->lookup_dnsbl_for_ip($pms, $ent->{obj}, $ip_address);
+ }
+ }
+ }