aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2003-11-12 22:13:26 +0800
committerleeym <leeym@FreeBSD.org>2003-11-12 22:13:26 +0800
commite2eef5b0523c4969fb34774e3aa573d233c75708 (patch)
tree977de2f1bc3bbe01ad5ec9d865868c7944ac174e /mail
parentfc05844e1476c7bf9dacbd66cb5e836653be83fb (diff)
downloadfreebsd-ports-gnome-e2eef5b0523c4969fb34774e3aa573d233c75708.tar.gz
freebsd-ports-gnome-e2eef5b0523c4969fb34774e3aa573d233c75708.tar.zst
freebsd-ports-gnome-e2eef5b0523c4969fb34774e3aa573d233c75708.zip
Don't check if perl5 is suid-enabled, just warn the users.
Noticed by: kris@ and tobez@
Diffstat (limited to 'mail')
-rw-r--r--mail/openwebmail/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/mail/openwebmail/Makefile b/mail/openwebmail/Makefile
index 473b6a71c811..db2aac23bac2 100644
--- a/mail/openwebmail/Makefile
+++ b/mail/openwebmail/Makefile
@@ -30,11 +30,6 @@ OWDATADIR= ${PREFIX}/www/data/openwebmail
PATCH_WRKSRC= ${WRKSRC}/cgi-bin/openwebmail
PATCH_STRIP= -p1
PLIST= ${WRKDIR}/.PLIST.${PKGNAME}
-_SUIDPERL_ENABLED!= ${PERL5} -V | ${GREP} d_dosuid | wc -l
-
-.if ${PERL_LEVEL} > 500800 && !defined(_SUIDPERL_ENABLED)
-WITHOUT_SPEEDYCGI=yes
-.endif
.if !defined(WITHOUT_SPEEDYCGI)
BUILD_DEPENDS+= speedy_suid:${PORTSDIR}/www/p5-CGI-SpeedyCGI
@@ -70,6 +65,13 @@ _CUSTOMIZED= yes
.endif
pre-fetch:
+.if ${PERL_LEVEL} > 500800
+ @${ECHO} ""
+ @${ECHO} "WARNING:"
+ @${ECHO} "Please make sure that your perl is built with -DSUIDPERL_ENABLED,"
+ @${ECHO} "otherwise please build openwebmail with WITHOUT_SPEEDYCGI=yes"
+ @${ECHO} ""
+.endif
.if defined(WITH_PAM)
@${ECHO} "PAM support will be added."
.endif
@@ -102,11 +104,11 @@ pre-fetch:
post-patch:
@${MV} ${PATCH_WRKSRC}/etc/openwebmail.conf ${PATCH_WRKSRC}/etc/openwebmail.conf-dist
- @${PERL} -pi.bak -e 's,/usr/local/www/cgi-bin/openwebmail,${OWCGIDIR},g' ${PATCH_WRKSRC}/etc/openwebmail.conf-dist
- @${PERL} -pi.bak -e 's,/usr/local/www/data/openwebmail,${OWDATADIR},g' ${PATCH_WRKSRC}/etc/openwebmail.conf-dist
+ @${PERL} -pi.bak -e 's,${LOCALBASE}/www/cgi-bin/openwebmail,${OWCGIDIR},g' ${PATCH_WRKSRC}/etc/openwebmail.conf-dist
+ @${PERL} -pi.bak -e 's,${LOCALBASE}/www/data/openwebmail,${OWDATADIR},g' ${PATCH_WRKSRC}/etc/openwebmail.conf-dist
.if !defined(WITHOUT_SPEEDYCGI)
@${ECHO} "savedsuid_support no" >> ${PATCH_WRKSRC}/etc/openwebmail.conf-dist
- @${PERL} -pi.bak -e 's,/usr/local/bin/speedy,${LOCALBASE}/bin/speedy_suid,g' ${PATCH_WRKSRC}/openwebmail*pl
+ @${PERL} -pi.bak -e 's,${LOCALBASE}/bin/speedy,${LOCALBASE}/bin/speedy_suid,g' ${PATCH_WRKSRC}/openwebmail*pl
.else
@${PERL} -pi.bak -e 's,/usr/bin/suidperl,${PERL},g' ${PATCH_WRKSRC}/openwebmail*pl
.endif