aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2017-11-22 22:45:17 +0800
committerpi <pi@FreeBSD.org>2017-11-22 22:45:17 +0800
commiteac421054f068d1da52d03318486ad59c1a03f9e (patch)
treef5c9b79795b3bdc1c08dc48742f62a5e965f16d7 /mail
parented75d425cd39a0ae8c9f0a74c80e225b57337fad (diff)
downloadfreebsd-ports-gnome-eac421054f068d1da52d03318486ad59c1a03f9e.tar.gz
freebsd-ports-gnome-eac421054f068d1da52d03318486ad59c1a03f9e.tar.zst
freebsd-ports-gnome-eac421054f068d1da52d03318486ad59c1a03f9e.zip
mail/postfix: use ECHO_CMD instead of ECHO
- When using "make -s install" the build can fail because the essential modifications to the port build are not made correctly. # make -s VECHO true # make -s VECHO_CMD echo PR: 222988 Submitted by: Franco Fichtner <franco@opnsense.org> Approved by: ohauer (maintainer timeout)
Diffstat (limited to 'mail')
-rw-r--r--mail/postfix/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index 5d0528113373..cacab2a23f4c 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -280,7 +280,7 @@ pre-patch:
fi
.endif
- @${ECHO} '<HTML><BODY>See <A HREF="header_checks.5.html">header_checks.5.html</A></BODY></HTML>' \
+ @${ECHO_CMD} '<HTML><BODY>See <A HREF="header_checks.5.html">header_checks.5.html</A></BODY></HTML>' \
> ${WRKSRC}/html/body_checks.5.html
@${REINPLACE_CMD} -E -e 's!^(#define DEF_SGID_GROUP[^"]+)"postdrop"$$!\1"maildrop"!' \
${WRKSRC}/src/global/mail_params.h
@@ -290,12 +290,12 @@ pre-patch:
post-patch:
.for f in ${HTML1}
- @${ECHO} '$$html_directory/$f:f:root:-:644' \
+ @${ECHO_CMD} '$$html_directory/$f:f:root:-:644' \
>> ${WRKSRC}/conf/postfix-files
.endfor
- @${ECHO} '$$manpage_directory/man1/posttls-finger.1:f:root:-:644' \
+ @${ECHO_CMD} '$$manpage_directory/man1/posttls-finger.1:f:root:-:644' \
>> ${WRKSRC}/conf/postfix-files
- @${ECHO} '$$command_directory/posttls-finger:f:root:-:755' \
+ @${ECHO_CMD} '$$command_directory/posttls-finger:f:root:-:755' \
>> ${WRKSRC}/conf/postfix-files
do-configure:
@@ -305,7 +305,7 @@ do-configure:
dynamicmaps=yes \
${POSTFIX_DYN_AUXLIBS} \
AUXLIBS="${POSTFIX_AUXLIBS}" && \
- ${ECHO} "all: default" >> Makefile)
+ ${ECHO_CMD} "all: default" >> Makefile)
pre-install-INST_BASE-on:
${MKDIR} ${STAGEDIR}/etc/rc.d