aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorfluffy <fluffy@FreeBSD.org>2016-05-28 02:29:53 +0800
committerfluffy <fluffy@FreeBSD.org>2016-05-28 02:29:53 +0800
commitec5614435830b3fdbe9d6dd30fcd7a922373b4fd (patch)
treeb2c75ab3e4c649561a288f61bcd9e6e7482af579 /mail
parent1be4a224dbcc6ece2e07a64fdf9847adfa29994c (diff)
downloadfreebsd-ports-gnome-ec5614435830b3fdbe9d6dd30fcd7a922373b4fd.tar.gz
freebsd-ports-gnome-ec5614435830b3fdbe9d6dd30fcd7a922373b4fd.tar.zst
freebsd-ports-gnome-ec5614435830b3fdbe9d6dd30fcd7a922373b4fd.zip
- Unconditionally define PORTREVISION in subports
to skip unneccessary bump slaves by master port touching - Pass master's CONFIGURE_ARGS to slaves - Option to select mail/opensmtpd[-devel] as build/run dependency (and corresponding libasr via this) - Pass pkgconfig dependency only to subports which need it. - Adjust dependencies in subports Submitted by: myself Reviewed by: adamw, gahr Approved by: adamw, gahr, miwi (mentor, implicit) Sponsored by: milk and cookies Differential Revision: https://reviews.freebsd.org/D6607
Diffstat (limited to 'mail')
-rw-r--r--mail/opensmtpd-extras-filter-clamav/Makefile3
-rw-r--r--mail/opensmtpd-extras-filter-dkim/Makefile1
-rw-r--r--mail/opensmtpd-extras-filter-dnsbl/Makefile3
-rw-r--r--mail/opensmtpd-extras-filter-pause/Makefile1
-rw-r--r--mail/opensmtpd-extras-filter-regex/Makefile1
-rw-r--r--mail/opensmtpd-extras-filter-spamassassin/Makefile1
-rw-r--r--mail/opensmtpd-extras-table-mysql/Makefile6
-rw-r--r--mail/opensmtpd-extras-table-passwd/Makefile6
-rw-r--r--mail/opensmtpd-extras-table-postgresql/Makefile5
-rw-r--r--mail/opensmtpd-extras-table-python/Makefile7
-rw-r--r--mail/opensmtpd-extras-table-redis/Makefile7
-rw-r--r--mail/opensmtpd-extras-table-socketmap/Makefile5
-rw-r--r--mail/opensmtpd-extras-table-sqlite/Makefile7
-rw-r--r--mail/opensmtpd-extras/Makefile29
14 files changed, 58 insertions, 24 deletions
diff --git a/mail/opensmtpd-extras-filter-clamav/Makefile b/mail/opensmtpd-extras-filter-clamav/Makefile
index 62a94ff257dc..aacb47cde917 100644
--- a/mail/opensmtpd-extras-filter-clamav/Makefile
+++ b/mail/opensmtpd-extras-filter-clamav/Makefile
@@ -2,10 +2,13 @@
# $FreeBSD$
PKGNAMESUFFIX= -filter-clamav
+PORTREVISION= 1
COMMENT= Check messages with ClamAV in OpenSMTPD
MAINTAINER= adamw@FreeBSD.org
+RUN_DEPENDS= clamscan:security/clamav
+
PLIST_FILES= libexec/opensmtpd/filter-clamav \
man/man8/filter-clamav.8.gz
diff --git a/mail/opensmtpd-extras-filter-dkim/Makefile b/mail/opensmtpd-extras-filter-dkim/Makefile
index be1142bd3be4..55c9f34ddaff 100644
--- a/mail/opensmtpd-extras-filter-dkim/Makefile
+++ b/mail/opensmtpd-extras-filter-dkim/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
PKGNAMESUFFIX= -filter-dkim
+PORTREVISION= 1
COMMENT= DKIM-signing filter for OpenSMTPD
MAINTAINER= adamw@FreeBSD.org
diff --git a/mail/opensmtpd-extras-filter-dnsbl/Makefile b/mail/opensmtpd-extras-filter-dnsbl/Makefile
index ec32c699cd00..ae0a7c11d6bb 100644
--- a/mail/opensmtpd-extras-filter-dnsbl/Makefile
+++ b/mail/opensmtpd-extras-filter-dnsbl/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PKGNAMESUFFIX= -filter-dnsbl
+PORTREVISION= 1
COMMENT= DNSBL-checking filter for OpenSMTPD
MAINTAINER= adamw@FreeBSD.org
-LIB_DEPENDS= libasr.so:dns/libasr
-
PLIST_FILES= libexec/opensmtpd/filter-dnsbl \
man/man8/filter-dnsbl.8.gz
diff --git a/mail/opensmtpd-extras-filter-pause/Makefile b/mail/opensmtpd-extras-filter-pause/Makefile
index c3d7012d4bc2..66d261080637 100644
--- a/mail/opensmtpd-extras-filter-pause/Makefile
+++ b/mail/opensmtpd-extras-filter-pause/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
PKGNAMESUFFIX= -filter-pause
+PORTREVISION= 1
COMMENT= Pause incoming OpenSMTPD messages to reduce spam
MAINTAINER= adamw@FreeBSD.org
diff --git a/mail/opensmtpd-extras-filter-regex/Makefile b/mail/opensmtpd-extras-filter-regex/Makefile
index 13e4af8dbc61..cccb74e792ca 100644
--- a/mail/opensmtpd-extras-filter-regex/Makefile
+++ b/mail/opensmtpd-extras-filter-regex/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
PKGNAMESUFFIX= -filter-regex
+PORTREVISION= 1
COMMENT= Regular expression filter for OpenSMTPD
MAINTAINER= adamw@FreeBSD.org
diff --git a/mail/opensmtpd-extras-filter-spamassassin/Makefile b/mail/opensmtpd-extras-filter-spamassassin/Makefile
index 997258fa7e47..501f3f81e655 100644
--- a/mail/opensmtpd-extras-filter-spamassassin/Makefile
+++ b/mail/opensmtpd-extras-filter-spamassassin/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
PKGNAMESUFFIX= -filter-spamassassin
+PORTREVISION= 1
COMMENT= Spamassassin filter addon for OpenSMTPD
MAINTAINER= adamw@FreeBSD.org
diff --git a/mail/opensmtpd-extras-table-mysql/Makefile b/mail/opensmtpd-extras-table-mysql/Makefile
index b3a1d0895ef9..216729277cdb 100644
--- a/mail/opensmtpd-extras-table-mysql/Makefile
+++ b/mail/opensmtpd-extras-table-mysql/Makefile
@@ -2,12 +2,14 @@
# $FreeBSD$
PKGNAMESUFFIX= -table-mysql
+PORTREVISION= 1
-COMMENT= MySQL table support for opensmtpd
+COMMENT= MySQL table support for OpenSMTPD
PLIST_FILES= libexec/opensmtpd/table-mysql
-CONFIGURE_ARGS= --with-table-mysql
+CONFIGURE_ARGS+= --with-table-mysql
+CFLAGS+= -I${LOCALBASE}/include/mysql
LDFLAGS+= -L${LOCALBASE}/lib/mysql
USES= mysql
diff --git a/mail/opensmtpd-extras-table-passwd/Makefile b/mail/opensmtpd-extras-table-passwd/Makefile
index 41afecb6c8b6..b22335e3978b 100644
--- a/mail/opensmtpd-extras-table-passwd/Makefile
+++ b/mail/opensmtpd-extras-table-passwd/Makefile
@@ -2,14 +2,14 @@
# $FreeBSD$
PKGNAMESUFFIX= -table-passwd
+PORTREVISION= 1
-COMMENT= passwd(5) table support for opensmtpd
+COMMENT= passwd(5) table support for OpenSMTPD
PLIST_FILES= libexec/opensmtpd/table-passwd \
man/man5/table-passwd.5.gz
-CONFIGURE_ARGS= --with-table-passwd
-LDFLAGS+= -L${LOCALBASE}/lib/mysql
+CONFIGURE_ARGS+= --with-table-passwd
MASTERDIR= ${.CURDIR}/../opensmtpd-extras
SLAVE_PORT= yes
diff --git a/mail/opensmtpd-extras-table-postgresql/Makefile b/mail/opensmtpd-extras-table-postgresql/Makefile
index f9374a86d215..65759e254634 100644
--- a/mail/opensmtpd-extras-table-postgresql/Makefile
+++ b/mail/opensmtpd-extras-table-postgresql/Makefile
@@ -2,12 +2,13 @@
# $FreeBSD$
PKGNAMESUFFIX= -table-postgresql
+PORTREVISION= 1
-COMMENT= PostgreSQL table support for opensmtpd
+COMMENT= PostgreSQL table support for OpenSMTPD
PLIST_FILES= libexec/opensmtpd/table-postgres
-CONFIGURE_ARGS= --with-table-postgres
+CONFIGURE_ARGS+= --with-table-postgres
USES= pgsql
diff --git a/mail/opensmtpd-extras-table-python/Makefile b/mail/opensmtpd-extras-table-python/Makefile
index 983b9a6ffe8d..e71dcc0850c0 100644
--- a/mail/opensmtpd-extras-table-python/Makefile
+++ b/mail/opensmtpd-extras-table-python/Makefile
@@ -2,14 +2,15 @@
# $FreeBSD$
PKGNAMESUFFIX= -table-python
+PORTREVISION= 1
-COMMENT= Python table support for opensmtpd
+COMMENT= Python table support for OpenSMTPD
PLIST_FILES= libexec/opensmtpd/table-python
-CONFIGURE_ARGS= --with-table-python --with-python-type=${PYTHON_VERSION}
+CONFIGURE_ARGS+= --with-table-python --with-python-type=${PYTHON_VERSION}
-USES= python
+USES= python pkgconfig
MASTERDIR= ${.CURDIR}/../opensmtpd-extras
SLAVE_PORT= yes
diff --git a/mail/opensmtpd-extras-table-redis/Makefile b/mail/opensmtpd-extras-table-redis/Makefile
index c7c0336cca24..a9a9993cff41 100644
--- a/mail/opensmtpd-extras-table-redis/Makefile
+++ b/mail/opensmtpd-extras-table-redis/Makefile
@@ -2,18 +2,21 @@
# $FreeBSD$
PKGNAMESUFFIX= -table-redis
+PORTREVISION= 1
-COMMENT= Redis table support for opensmtpd
+COMMENT= Redis table support for OpenSMTPD
LIB_DEPENDS= libhiredis.so:databases/hiredis
PLIST_FILES= libexec/opensmtpd/table-redis \
man/man5/table-redis.5.gz
-CONFIGURE_ARGS= --with-table-redis
+CONFIGURE_ARGS+= --with-table-redis
CONFIGURE_ENV= REDIS_CONFIG=${LOCALBASE}/bin/pkgconf
CFLAGS+= -I${LOCALBASE}/include/hiredis
+USES= pkgconfig
+
MASTERDIR= ${.CURDIR}/../opensmtpd-extras
SLAVE_PORT= yes
diff --git a/mail/opensmtpd-extras-table-socketmap/Makefile b/mail/opensmtpd-extras-table-socketmap/Makefile
index 1ebab9eb449e..906d9cca3728 100644
--- a/mail/opensmtpd-extras-table-socketmap/Makefile
+++ b/mail/opensmtpd-extras-table-socketmap/Makefile
@@ -2,13 +2,14 @@
# $FreeBSD$
PKGNAMESUFFIX= -table-socketmap
+PORTREVISION= 1
-COMMENT= Socketmap table support for opensmtpd
+COMMENT= Socketmap table support for OpenSMTPD
PLIST_FILES= libexec/opensmtpd/table-socketmap \
man/man5/table-socketmap.5.gz
-CONFIGURE_ARGS= --with-table-socketmap
+CONFIGURE_ARGS+= --with-table-socketmap
MASTERDIR= ${.CURDIR}/../opensmtpd-extras
SLAVE_PORT= yes
diff --git a/mail/opensmtpd-extras-table-sqlite/Makefile b/mail/opensmtpd-extras-table-sqlite/Makefile
index 302af3ef3597..698f5d3e60c9 100644
--- a/mail/opensmtpd-extras-table-sqlite/Makefile
+++ b/mail/opensmtpd-extras-table-sqlite/Makefile
@@ -2,15 +2,16 @@
# $FreeBSD$
PKGNAMESUFFIX= -table-sqlite
+PORTREVISION= 1
-COMMENT= SQLite table support for opensmtpd
+COMMENT= SQLite table support for OpenSMTPD
PLIST_FILES= libexec/opensmtpd/table-sqlite \
man/man5/table-sqlite.5.gz
-CONFIGURE_ARGS= --with-table-sqlite
+CONFIGURE_ARGS+= --with-table-sqlite
-USES= sqlite
+USES= sqlite pkgconfig
MASTERDIR= ${.CURDIR}/../opensmtpd-extras
SLAVE_PORT= yes
diff --git a/mail/opensmtpd-extras/Makefile b/mail/opensmtpd-extras/Makefile
index 8fa6517d2d0d..d55635b9c157 100644
--- a/mail/opensmtpd-extras/Makefile
+++ b/mail/opensmtpd-extras/Makefile
@@ -3,34 +3,53 @@
PORTNAME= opensmtpd-extras
PORTVERSION= 201605232202
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES+= mail
MASTER_SITES= http://www.opensmtpd.org/archives/
+# NB: Please reset PORTREVISION to 0 in all slave subports
+# while updating PORTVERSION for master port
+
MAINTAINER?= gahr@FreeBSD.org
COMMENT?= Addons for OpenSMTPD
LICENSE?= ISCL
LIB_DEPENDS+= libevent.so:devel/libevent2
-RUN_DEPENDS+= ${LOCALBASE}/sbin/smtpctl:mail/opensmtpd
-USES+= autoreconf libtool pkgconfig
+USES+= autoreconf libtool
USE_OPENSSL= yes
-WITH_OPENSSL_PORT= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --sysconfdir="${PREFIX}/etc/mail"
+
# NB: Please *DO NOT* add the following; they are NOT for end-users:
-# filter-monkey, filter-stub, filter-trace, filter-void
+# filter-stub, filter-trace, filter-void
# queue-null, queue-stub
# scheduler-stub
# table-stub
+
+#
+# Pass OpenSMTPD branch selection to all extras
+#
+OPTIONS_DEFINE= OPENSMTP_DEVEL
+
+OPENSMTP_DEVEL_DESC= Depend on opensmtpd-devel (opensmtpd if off)
+OPENSMTP_DEVEL_BUILD_DEPENDS_OFF= smtpctl:${PORTSDIR}/mail/opensmtpd
+OPENSMTP_DEVEL_RUN_DEPENDS_OFF= smtpctl:${PORTSDIR}/mail/opensmtpd
+OPENSMTP_DEVEL_BUILD_DEPENDS= smtpctl:${PORTSDIR}/mail/opensmtpd-devel
+OPENSMTP_DEVEL_RUN_DEPENDS= smtpctl:${PORTSDIR}/mail/opensmtpd-devel
+
.if empty(SLAVE_PORT)
OPTIONS_GROUP= FILTER TABLE
OPTIONS_GROUP_FILTER= CLAMAV DKIM DNSBL PAUSE REGEX SPAMASSASSIN
OPTIONS_GROUP_TABLE= LDAP MYSQL PASSWD PGSQL PYTHON REDIS SMAP SQLITE
OPTIONS_DEFAULT= ${OPTIONS_GROUP_FILTER} ${OPTIONS_GROUP_TABLE}
+# Groups
+FILTER_DESC= BASE FILTERS
+TABLE_DESC= BASE TABLES
+
# Filters
CLAMAV_DESC= Check messages with ClamAV
DKIM_DESC= Sign messages with DKIM