aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-05-03 01:31:57 +0800
committerpav <pav@FreeBSD.org>2004-05-03 01:31:57 +0800
commited3d6b68c0ded7e141d11106f3931f87f34e3cd7 (patch)
tree1d66de8ef2ec31d00376f21364ed31188f788d04 /mail
parent53e7cd8347ea59a9d40dfeab28b42fa6a5052681 (diff)
downloadfreebsd-ports-gnome-ed3d6b68c0ded7e141d11106f3931f87f34e3cd7.tar.gz
freebsd-ports-gnome-ed3d6b68c0ded7e141d11106f3931f87f34e3cd7.tar.zst
freebsd-ports-gnome-ed3d6b68c0ded7e141d11106f3931f87f34e3cd7.zip
- Update to 2.2-20040422
PR: ports/66094 Submitted by: Vivek Khera <vivek@khera.org> (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/postfix-current/Makefile34
-rw-r--r--mail/postfix-current/distinfo12
-rw-r--r--mail/postfix-current/files/patch-ea13
-rw-r--r--mail/postfix-current/files/patch-eb11
-rw-r--r--mail/postfix-current/files/patch-ed11
-rw-r--r--mail/postfix-current/files/patch-ee13
-rw-r--r--mail/postfix-current/files/patch-ef11
-rw-r--r--mail/postfix-current/files/patch-eg20
-rw-r--r--mail/postfix-current/files/patch-eh11
-rw-r--r--mail/postfix-current/files/patch-main.cf108
-rw-r--r--mail/postfix-current/pkg-install3
-rw-r--r--mail/postfix-current/pkg-plist158
-rw-r--r--mail/postfix-current/scripts/configure.postfix17
13 files changed, 236 insertions, 186 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index d99ec52e42db..3ce5fd8126d3 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -15,10 +15,9 @@
# NOTE: PCRE is enabled by default unless you specifically disable it.
PORTNAME= postfix
-PORTVERSIONRAW= 2.0.19-20040312
+PORTVERSIONRAW= 2.2-20040422
PORTVERSION= ${PORTVERSIONRAW:S/-/./}
PORTEPOCH= 2
-NO_LATEST_LINK= yes
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/experimental/ \
ftp://ftp.aet.tu-cottbus.de/pub/postfix_tls/%SUBDIR%/ \
@@ -33,7 +32,8 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= vivek@khera.org
COMMENT= A secure alternative to widely-used Sendmail
-CONFLICTS= courier-0.* postfix-1.* sendmail-8.* sendmail-*-8.* smail-3.* zmailer-2.*
+CONFLICTS= courier-0.* postfix-1.* postfix-2.0.* postfix-2.1.* sendmail-8.* sendmail-*-8.* smail-3.* zmailer-2.*
+NO_LATEST_LINK= yes
USE_SUBMAKE= yes
USE_REINPLACE= yes
@@ -41,7 +41,8 @@ MAN1= mailq.1 newaliases.1 postalias.1 postcat.1 postconf.1 postdrop.1 \
postfix.1 postkick.1 postlock.1 postlog.1 postmap.1 postqueue.1 \
postsuper.1 sendmail.1
-MAN5= access.5 aliases.5 canonical.5 cidr_table.5 pcre_table.5 \
+MAN5= access.5 aliases.5 canonical.5 cidr_table.5 ldap_table.5 \
+ mysql_table.5 pgsql_table.5 postconf.5 pcre_table.5 \
regexp_table.5 relocated.5 tcp_table.5 transport.5 virtual.5 \
header_checks.5 body_checks.5
@@ -56,6 +57,19 @@ MAN8base=$(MAN8:S/tlsmgr.8//)
CONF1= main.cf master.cf access aliases canonical header_checks relocated \
transport virtual
+README= ADDRESS_CLASS_README ADDRESS_REWRITING_README \
+ ADDRESS_VERIFICATION_README BACKSCATTER_README \
+ BASIC_CONFIGURATION_README BUILTIN_FILTER_README \
+ CONTENT_INSPECTION_README CYRUS_README DATABASE_README DB_README \
+ DEBUG_README ETRN_README FILTER_README INSTALL LDAP_README \
+ LINUX_README LMTP_README LOCAL_RECIPIENT_README MAILDROP_README \
+ MYSQL_README NFS_README OVERVIEW PACKAGE_README PCRE_README \
+ PGSQL_README QMQP_README QSHAPE_README RESTRICTION_CLASS_README \
+ SASL_README SCHEDULER_README SMTPD_ACCESS_README SMTPD_POLICY_README \
+ SMTPD_PROXY_README STANDARD_CONFIGURATION_README TUNING_README \
+ ULTRIX_README UUCP_README VERP_README VIRTUAL_README \
+ XCLIENT_README XFORWARD_README
+
.if !defined(DEBUG)
MAKEFILEFLAGS+= DEBUG=
.endif
@@ -101,9 +115,11 @@ pre-patch:
@${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
${WRKSRC}/man/man8/${file} ${WRKSRC}/html/${file}.html
.endfor
-.for file in faq rate rewrite uce
+.for file in ${README}
@${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
${WRKSRC}/html/${file}.html
+ @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
+ ${WRKSRC}/README_FILES/${file}
.endfor
.for file in ${CONF1}
@${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" ${WRKSRC}/conf/${file}
@@ -135,7 +151,7 @@ do-install:
.for file in ${CONF1}
${INSTALL_DATA} ${WRKSRC}/conf/${file} \
- ${PREFIX}/etc/postfix/sample-${file}
+ ${PREFIX}/etc/postfix/dist-${file}
.endfor
@${INSTALL_SCRIPT} \
@@ -144,14 +160,12 @@ do-install:
# optional TEST binaries
.for file in ${BIN1}
- @${INSTALL_PROGRAM} \
- ${WRKSRC}/src/smtpstone/${file} \
- ${PREFIX}/sbin
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/${file} ${PREFIX}/sbin
.endfor
.if !defined(NOPORTDOCS)
@${INSTALL} -d -o ${DOCOWN} -g ${DOCGRP} -m 555 ${DOCSDIR}
- @cd ${WRKSRC}/html && ${INSTALL_DATA} *.html *.gif ${DOCSDIR} && \
+ @cd ${WRKSRC}/html && ${INSTALL_DATA} *.html *.jpg *.png ${DOCSDIR} && \
${ECHO_MSG} "Installed HTML documentation in ${DOCSDIR}"
.endif
diff --git a/mail/postfix-current/distinfo b/mail/postfix-current/distinfo
index 6b0321790609..e849865435d4 100644
--- a/mail/postfix-current/distinfo
+++ b/mail/postfix-current/distinfo
@@ -1,8 +1,4 @@
-MD5 (postfix/postfix-2.0.19-20040312.tar.gz) = 8ae5bb688e420eb653166073d2805ba9
-SIZE (postfix/postfix-2.0.19-20040312.tar.gz) = 1531471
-MD5 (postfix/ipv6-1.21a-pf-2.0.18-20040209.patch.gz) = 34df7dd001c35f160f3ae29dbf7b982f
-SIZE (postfix/ipv6-1.21a-pf-2.0.18-20040209.patch.gz) = 48839
-MD5 (postfix/tls+ipv6-1.21a-pf-2.0.18-20040209.patch.gz) = 567f90fb9db2181d3c05932f541b4b28
-SIZE (postfix/tls+ipv6-1.21a-pf-2.0.18-20040209.patch.gz) = 254350
-MD5 (postfix/pfixtls-0.8.18-2.0.18-20040205-0.9.7c.tar.gz) = ea0cab58f33477ed4f9117b32b185284
-SIZE (postfix/pfixtls-0.8.18-2.0.18-20040205-0.9.7c.tar.gz) = 233576
+MD5 (postfix/postfix-2.2-20040422.tar.gz) = df2c7485ea47402020ac3c03c38da6e0
+SIZE (postfix/postfix-2.2-20040422.tar.gz) = 2013819
+MD5 (postfix/pfixtls-0.8.18-2.1.0-0.9.7d.tar.gz) = 01785d9636bdae51a906320e581b1e6b
+SIZE (postfix/pfixtls-0.8.18-2.1.0-0.9.7d.tar.gz) = 239141
diff --git a/mail/postfix-current/files/patch-ea b/mail/postfix-current/files/patch-ea
deleted file mode 100644
index 6c3f98d2af4f..000000000000
--- a/mail/postfix-current/files/patch-ea
+++ /dev/null
@@ -1,13 +0,0 @@
-*** ./src/cleanup/cleanup.c.orig Sun May 28 18:33:41 2000
---- ./src/cleanup/cleanup.c Thu Jun 1 21:52:22 2000
-***************
-*** 118,121 ****
- /* FILES
-! /* /etc/postfix/canonical*, canonical mapping table
-! /* /etc/postfix/virtual*, virtual mapping table
- /* LICENSE
---- 118,121 ----
- /* FILES
-! /* !!PREFIX!!/etc/postfix/canonical*, canonical mapping table
-! /* !!PREFIX!!/etc/postfix/virtual*, virtual mapping table
- /* LICENSE
diff --git a/mail/postfix-current/files/patch-eb b/mail/postfix-current/files/patch-eb
deleted file mode 100644
index e67680963d2d..000000000000
--- a/mail/postfix-current/files/patch-eb
+++ /dev/null
@@ -1,11 +0,0 @@
-*** ./src/global/mail_conf.c.orig Sun May 7 18:51:16 2000
---- ./src/global/mail_conf.c Thu Jun 1 22:16:29 2000
-***************
-*** 53,55 ****
- /* FILES
-! /* /etc/postfix: default Postfix configuration directory.
- /* ENVIRONMENT
---- 53,55 ----
- /* FILES
-! /* !!PREFIX!!/etc/postfix: default Postfix configuration directory.
- /* ENVIRONMENT
diff --git a/mail/postfix-current/files/patch-ed b/mail/postfix-current/files/patch-ed
deleted file mode 100644
index f971b62720d8..000000000000
--- a/mail/postfix-current/files/patch-ed
+++ /dev/null
@@ -1,11 +0,0 @@
-*** ./src/local/mailbox.c.orig Fri Apr 28 16:55:53 2000
---- ./src/local/mailbox.c Thu Jun 1 22:37:48 2000
-***************
-*** 15,17 ****
- /* suppression. The default is direct mailbox delivery to
-! /* /var/[spool/]mail/\fIuser\fR; when a \fIhome_mailbox\fR
- /* has been configured, mail is delivered to ~/$\fIhome_mailbox\fR;
---- 15,17 ----
- /* suppression. The default is direct mailbox delivery to
-! /* /var/mail/\fIuser\fR; when a \fIhome_mailbox\fR
- /* has been configured, mail is delivered to ~/$\fIhome_mailbox\fR;
diff --git a/mail/postfix-current/files/patch-ee b/mail/postfix-current/files/patch-ee
deleted file mode 100644
index ef44eac24b73..000000000000
--- a/mail/postfix-current/files/patch-ee
+++ /dev/null
@@ -1,13 +0,0 @@
-*** ./src/master/master.c.orig Tue Mar 7 10:25:07 2000
---- ./src/master/master.c Thu Jun 1 22:43:50 2000
-***************
-*** 104,107 ****
- /* FILES
-! /* /etc/postfix/main.cf: global configuration file.
-! /* /etc/postfix/master.cf: master process configuration file.
- /* /var/spool/postfix/pid/master.pid: master lock file.
---- 104,107 ----
- /* FILES
-! /* !!PREFIX!!/etc/postfix/main.cf: global configuration file.
-! /* !!PREFIX!!/etc/postfix/master.cf: master process configuration file.
- /* /var/spool/postfix/pid/master.pid: master lock file.
diff --git a/mail/postfix-current/files/patch-ef b/mail/postfix-current/files/patch-ef
deleted file mode 100644
index 586b304a103d..000000000000
--- a/mail/postfix-current/files/patch-ef
+++ /dev/null
@@ -1,11 +0,0 @@
-*** ./src/postdrop/postdrop.c.orig Sun Apr 25 18:05:43 1999
---- ./src/postdrop/postdrop.c Thu Jun 1 22:44:22 2000
-***************
-*** 39,41 ****
- /* /var/spool/postfix, mail queue
-! /* /etc/postfix, configuration files
- /* CONFIGURATION PARAMETERS
---- 39,41 ----
- /* /var/spool/postfix, mail queue
-! /* !!PREFIX!!/etc/postfix, configuration files
- /* CONFIGURATION PARAMETERS
diff --git a/mail/postfix-current/files/patch-eg b/mail/postfix-current/files/patch-eg
deleted file mode 100644
index 2983bbfd86ea..000000000000
--- a/mail/postfix-current/files/patch-eg
+++ /dev/null
@@ -1,20 +0,0 @@
-*** ./src/sendmail/sendmail.c.orig Tue Mar 14 10:42:06 2000
---- ./src/sendmail/sendmail.c Thu Jun 1 22:47:24 2000
-***************
-*** 57,59 ****
- /* The path name of the \fBsendmail.cf\fR file. Postfix configuration
-! /* files are kept in \fB/etc/postfix\fR.
- /* .IP "\fB-F \fIfull_name\fR
---- 57,59 ----
- /* The path name of the \fBsendmail.cf\fR file. Postfix configuration
-! /* files are kept in \fB!!PREFIX!!/etc/postfix\fR.
- /* .IP "\fB-F \fIfull_name\fR
-***************
-*** 159,161 ****
- /* /var/spool/postfix, mail queue
-! /* /etc/postfix, configuration files
- /* CONFIGURATION PARAMETERS
---- 159,161 ----
- /* /var/spool/postfix, mail queue
-! /* !!PREFIX!!/etc/postfix, configuration files
- /* CONFIGURATION PARAMETERS
diff --git a/mail/postfix-current/files/patch-eh b/mail/postfix-current/files/patch-eh
deleted file mode 100644
index c104c3680d21..000000000000
--- a/mail/postfix-current/files/patch-eh
+++ /dev/null
@@ -1,11 +0,0 @@
-*** ./src/trivial-rewrite/transport.c.orig Tue Nov 16 19:15:41 1999
---- ./src/trivial-rewrite/transport.c Thu Jun 1 22:47:49 2000
-***************
-*** 32,34 ****
- /* FILES
-! /* /etc/postfix/transport*
- /* CONFIGURATION PARAMETERS
---- 32,34 ----
- /* FILES
-! /* !!PREFIX!!/etc/postfix/transport*
- /* CONFIGURATION PARAMETERS
diff --git a/mail/postfix-current/files/patch-main.cf b/mail/postfix-current/files/patch-main.cf
new file mode 100644
index 000000000000..7775cd80efb2
--- /dev/null
+++ b/mail/postfix-current/files/patch-main.cf
@@ -0,0 +1,108 @@
+*** ./conf/main.cf~ Mon Apr 26 16:54:42 2004
+--- ./conf/main.cf Mon Apr 26 16:54:42 2004
+***************
+*** 32,44 ****
+ # The command_directory parameter specifies the location of all
+ # postXXX commands.
+ #
+! command_directory = /usr/sbin
+
+ # The daemon_directory parameter specifies the location of all Postfix
+ # daemon programs (i.e. programs listed in the master.cf file). This
+ # directory must be owned by root.
+ #
+! daemon_directory = /usr/libexec/postfix
+
+ # QUEUE AND PROCESS OWNERSHIP
+ #
+--- 32,44 ----
+ # The command_directory parameter specifies the location of all
+ # postXXX commands.
+ #
+! command_directory = !!PREFIX!!/sbin
+
+ # The daemon_directory parameter specifies the location of all Postfix
+ # daemon programs (i.e. programs listed in the master.cf file). This
+ # directory must be owned by root.
+ #
+! daemon_directory = !!PREFIX!!/libexec/postfix
+
+ # QUEUE AND PROCESS OWNERSHIP
+ #
+***************
+*** 595,631 ****
+ # sendmail_path: The full pathname of the Postfix sendmail command.
+ # This is the Sendmail-compatible mail posting interface.
+ #
+! sendmail_path =
+
+ # newaliases_path: The full pathname of the Postfix newaliases command.
+ # This is the Sendmail-compatible command to build alias databases.
+ #
+! newaliases_path =
+
+ # mailq_path: The full pathname of the Postfix mailq command. This
+ # is the Sendmail-compatible mail queue listing command.
+ #
+! mailq_path =
+
+ # setgid_group: The group for mail submission and queue management
+ # commands. This must be a group name with a numerical group ID that
+ # is not shared with other accounts, not even with the Postfix account.
+ #
+! setgid_group =
+
+ # html_directory: The location of the Postfix HTML documentation.
+ #
+! html_directory =
+
+ # manpage_directory: The location of the Postfix on-line manual pages.
+ #
+! manpage_directory =
+
+ # sample_directory: The location of the Postfix sample configuration files.
+ # This parameter is obsolete as of Postfix 2.1.
+ #
+! sample_directory =
+
+ # readme_directory: The location of the Postfix README files.
+ #
+! readme_directory =
+--- 595,631 ----
+ # sendmail_path: The full pathname of the Postfix sendmail command.
+ # This is the Sendmail-compatible mail posting interface.
+ #
+! sendmail_path = !!PREFIX!!/sbin/sendmail
+
+ # newaliases_path: The full pathname of the Postfix newaliases command.
+ # This is the Sendmail-compatible command to build alias databases.
+ #
+! newaliases_path = !!PREFIX!!/bin/newaliases
+
+ # mailq_path: The full pathname of the Postfix mailq command. This
+ # is the Sendmail-compatible mail queue listing command.
+ #
+! mailq_path = !!PREFIX!!/bin/mailq
+
+ # setgid_group: The group for mail submission and queue management
+ # commands. This must be a group name with a numerical group ID that
+ # is not shared with other accounts, not even with the Postfix account.
+ #
+! setgid_group = maildrop
+
+ # html_directory: The location of the Postfix HTML documentation.
+ #
+! html_directory = no
+
+ # manpage_directory: The location of the Postfix on-line manual pages.
+ #
+! manpage_directory = !!PREFIX!!/man
+
+ # sample_directory: The location of the Postfix sample configuration files.
+ # This parameter is obsolete as of Postfix 2.1.
+ #
+! sample_directory = !!PREFIX!!/etc/postfix
+
+ # readme_directory: The location of the Postfix README files.
+ #
+! readme_directory = no
diff --git a/mail/postfix-current/pkg-install b/mail/postfix-current/pkg-install
index 99485fabb797..5765d42430c1 100644
--- a/mail/postfix-current/pkg-install
+++ b/mail/postfix-current/pkg-install
@@ -118,13 +118,14 @@ if [ x"$2" = xPRE-INSTALL ]; then
fi
if [ x"$2" = xPOST-INSTALL ]; then
+ # CONF1 copied from Makefile. Keep consistent!
CONF1="main.cf master.cf access aliases canonical \
header_checks relocated transport virtual"
for file in $CONF1
do
if [ ! -f ${PKG_PREFIX}/etc/postfix/$file ]; then
- cp ${PKG_PREFIX}/etc/postfix/sample-$file ${PKG_PREFIX}/etc/postfix/$file
+ cp ${PKG_PREFIX}/etc/postfix/dist-$file ${PKG_PREFIX}/etc/postfix/$file
fi
done
diff --git a/mail/postfix-current/pkg-plist b/mail/postfix-current/pkg-plist
index bfb0b53f40e3..2dd0abfec279 100644
--- a/mail/postfix-current/pkg-plist
+++ b/mail/postfix-current/pkg-plist
@@ -1,52 +1,29 @@
-@unexec if cmp -s %D/etc/postfix/main.cf %D/etc/postfix/sample-main.cf; then rm -f %D/etc/postfix/main.cf; fi
-@unexec if cmp -s %D/etc/postfix/master.cf %D/etc/postfix/sample-master.cf; then rm -f %D/etc/postfix/master.cf; fi
-@unexec if cmp -s %D/etc/postfix/access %D/etc/postfix/sample-access; then rm -f %D/etc/postfix/access; fi
-@unexec if cmp -s %D/etc/postfix/aliases %D/etc/postfix/sample-aliases; then rm -f %D/etc/postfix/aliases; fi
-@unexec if cmp -s %D/etc/postfix/canonical %D/etc/postfix/sample-canonical; then rm -f %D/etc/postfix/canonical; fi
-@unexec if cmp -s %D/etc/postfix/header_checks %D/etc/postfix/sample-header_checks; then rm -f %D/etc/postfix/header_checks; fi
-@unexec if cmp -s %D/etc/postfix/relocated %D/etc/postfix/sample-relocated; then rm -f %D/etc/postfix/relocated; fi
-@unexec if cmp -s %D/etc/postfix/transport %D/etc/postfix/sample-transport; then rm -f %D/etc/postfix/transport; fi
-@unexec if cmp -s %D/etc/postfix/virtual %D/etc/postfix/sample-virtual; then rm -f %D/etc/postfix/virtual; fi
-bin/rmail
+@unexec if cmp -s %D/etc/postfix/main.cf %D/etc/postfix/dist-main.cf; then rm -f %D/etc/postfix/main.cf; fi
+@unexec if cmp -s %D/etc/postfix/master.cf %D/etc/postfix/dist-master.cf; then rm -f %D/etc/postfix/master.cf; fi
+@unexec if cmp -s %D/etc/postfix/access %D/etc/postfix/dist-access; then rm -f %D/etc/postfix/access; fi
+@unexec if cmp -s %D/etc/postfix/aliases %D/etc/postfix/dist-aliases; then rm -f %D/etc/postfix/aliases; fi
+@unexec if cmp -s %D/etc/postfix/canonical %D/etc/postfix/dist-canonical; then rm -f %D/etc/postfix/canonical; fi
+@unexec if cmp -s %D/etc/postfix/header_checks %D/etc/postfix/dist-header_checks; then rm -f %D/etc/postfix/header_checks; fi
+@unexec if cmp -s %D/etc/postfix/relocated %D/etc/postfix/dist-relocated; then rm -f %D/etc/postfix/relocated; fi
+@unexec if cmp -s %D/etc/postfix/transport %D/etc/postfix/dist-transport; then rm -f %D/etc/postfix/transport; fi
+@unexec if cmp -s %D/etc/postfix/virtual %D/etc/postfix/dist-virtual; then rm -f %D/etc/postfix/virtual; fi
etc/postfix/LICENSE
etc/postfix/main.cf.default
etc/postfix/makedefs.out
etc/postfix/post-install
etc/postfix/postfix-files
etc/postfix/postfix-script
-etc/postfix/sample-access
-etc/postfix/sample-aliases
-etc/postfix/sample-canonical
-etc/postfix/sample-header_checks
-etc/postfix/sample-relocated
-etc/postfix/sample-aliases.cf
-etc/postfix/sample-auth.cf
-etc/postfix/sample-compatibility.cf
-etc/postfix/sample-debug.cf
-etc/postfix/sample-flush.cf
-%%SUB_IPV6%%etc/postfix/sample-ipv6.cf
-etc/postfix/sample-ldap.cf
-etc/postfix/sample-lmtp.cf
-etc/postfix/sample-local.cf
-etc/postfix/sample-main.cf
-etc/postfix/sample-master.cf
-etc/postfix/sample-mime.cf
-etc/postfix/sample-misc.cf
-etc/postfix/sample-pgsql-aliases.cf
-etc/postfix/sample-qmqpd.cf
-etc/postfix/sample-rate.cf
-etc/postfix/sample-relocated.cf
-etc/postfix/sample-resource.cf
-etc/postfix/sample-rewrite.cf
-etc/postfix/sample-scheduler.cf
-etc/postfix/sample-smtp.cf
-etc/postfix/sample-smtpd.cf
-etc/postfix/sample-transport.cf
-etc/postfix/sample-virtual.cf
-etc/postfix/sample-transport
-etc/postfix/sample-verify.cf
-etc/postfix/sample-virtual
-%%SUB_TLS%%etc/postfix/sample-tls.cf
+etc/postfix/dist-main.cf
+etc/postfix/dist-master.cf
+etc/postfix/dist-access
+etc/postfix/dist-aliases
+etc/postfix/dist-canonical
+etc/postfix/dist-header_checks
+etc/postfix/dist-relocated
+etc/postfix/dist-transport
+etc/postfix/dist-virtual
+%%SUB_IPV6%%etc/postfix/dist-ipv6.cf
+%%SUB_TLS%%etc/postfix/dist-tls.cf
libexec/postfix/anvil
libexec/postfix/bounce
libexec/postfix/cleanup
@@ -82,81 +59,127 @@ sbin/postmap
sbin/postqueue
sbin/postsuper
sbin/sendmail
-bin/newaliases
-bin/mailq
+%%SUB_TEST%%sbin/qmqp-source
%%SUB_TEST%%sbin/smtp-sink
%%SUB_TEST%%sbin/smtp-source
+bin/rmail
+bin/newaliases
+bin/mailq
+%%PORTDOCS%%%%DOCSDIR%%/AAAREADME
%%PORTDOCS%%%%DOCSDIR%%/ADDRESS_CLASS_README
+%%PORTDOCS%%%%DOCSDIR%%/ADDRESS_CLASS_README.html
+%%PORTDOCS%%%%DOCSDIR%%/ADDRESS_REWRITING_README
+%%PORTDOCS%%%%DOCSDIR%%/ADDRESS_REWRITING_README.html
%%PORTDOCS%%%%DOCSDIR%%/ADDRESS_VERIFICATION_README
+%%PORTDOCS%%%%DOCSDIR%%/ADDRESS_VERIFICATION_README.html
+%%PORTDOCS%%%%DOCSDIR%%/BACKSCATTER_README
+%%PORTDOCS%%%%DOCSDIR%%/BACKSCATTER_README.html
+%%PORTDOCS%%%%DOCSDIR%%/BASIC_CONFIGURATION_README
+%%PORTDOCS%%%%DOCSDIR%%/BASIC_CONFIGURATION_README.html
+%%PORTDOCS%%%%DOCSDIR%%/BUILTIN_FILTER_README
+%%PORTDOCS%%%%DOCSDIR%%/BUILTIN_FILTER_README.html
+%%PORTDOCS%%%%DOCSDIR%%/CONTENT_INSPECTION_README
+%%PORTDOCS%%%%DOCSDIR%%/CONTENT_INSPECTION_README.html
+%%PORTDOCS%%%%DOCSDIR%%/CYRUS_README.html
+%%PORTDOCS%%%%DOCSDIR%%/DATABASE_README
+%%PORTDOCS%%%%DOCSDIR%%/DATABASE_README.html
%%PORTDOCS%%%%DOCSDIR%%/DB_README
+%%PORTDOCS%%%%DOCSDIR%%/DB_README.html
%%PORTDOCS%%%%DOCSDIR%%/DEBUG_README
+%%PORTDOCS%%%%DOCSDIR%%/DEBUG_README.html
%%PORTDOCS%%%%DOCSDIR%%/ETRN_README
+%%PORTDOCS%%%%DOCSDIR%%/ETRN_README.html
%%PORTDOCS%%%%DOCSDIR%%/FILTER_README
-%%PORTDOCS%%%%DOCSDIR%%/HOSTING_README
+%%PORTDOCS%%%%DOCSDIR%%/FILTER_README.html
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%SUB_IPV6%%%%DOCSDIR%%/IPV6_README
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.html
%%PORTDOCS%%%%DOCSDIR%%/LDAP_README
+%%PORTDOCS%%%%DOCSDIR%%/LDAP_README.html
%%PORTDOCS%%%%DOCSDIR%%/LINUX_README
-%%PORTDOCS%%%%DOCSDIR%%/LOCAL_RECIPIENT_README
+%%PORTDOCS%%%%DOCSDIR%%/LINUX_README.html
%%PORTDOCS%%%%DOCSDIR%%/LMTP_README
-%%PORTDOCS%%%%DOCSDIR%%/MACOSX_README
+%%PORTDOCS%%%%DOCSDIR%%/LMTP_README.html
+%%PORTDOCS%%%%DOCSDIR%%/LOCAL_RECIPIENT_README
+%%PORTDOCS%%%%DOCSDIR%%/LOCAL_RECIPIENT_README.html
%%PORTDOCS%%%%DOCSDIR%%/MAILDROP_README
+%%PORTDOCS%%%%DOCSDIR%%/MAILDROP_README.html
%%PORTDOCS%%%%DOCSDIR%%/MYSQL_README
+%%PORTDOCS%%%%DOCSDIR%%/MYSQL_README.html
%%PORTDOCS%%%%DOCSDIR%%/NFS_README
+%%PORTDOCS%%%%DOCSDIR%%/NFS_README.html
+%%PORTDOCS%%%%DOCSDIR%%/OVERVIEW
+%%PORTDOCS%%%%DOCSDIR%%/OVERVIEW.html
%%PORTDOCS%%%%DOCSDIR%%/PACKAGE_README
+%%PORTDOCS%%%%DOCSDIR%%/PACKAGE_README.html
%%PORTDOCS%%%%DOCSDIR%%/PCRE_README
+%%PORTDOCS%%%%DOCSDIR%%/PCRE_README.html
%%PORTDOCS%%%%DOCSDIR%%/PGSQL_README
+%%PORTDOCS%%%%DOCSDIR%%/PGSQL_README.html
%%PORTDOCS%%%%DOCSDIR%%/QMQP_README
+%%PORTDOCS%%%%DOCSDIR%%/QMQP_README.html
+%%PORTDOCS%%%%DOCSDIR%%/QSHAPE_README
+%%PORTDOCS%%%%DOCSDIR%%/QSHAPE_README.html
%%PORTDOCS%%%%DOCSDIR%%/RELEASE_NOTES
%%PORTDOCS%%%%DOCSDIR%%/RESTRICTION_CLASS_README
+%%PORTDOCS%%%%DOCSDIR%%/RESTRICTION_CLASS_README.html
%%PORTDOCS%%%%DOCSDIR%%/SASL_README
+%%PORTDOCS%%%%DOCSDIR%%/SASL_README.html
%%PORTDOCS%%%%DOCSDIR%%/SCHEDULER_README
+%%PORTDOCS%%%%DOCSDIR%%/SCHEDULER_README.html
+%%PORTDOCS%%%%DOCSDIR%%/SMTPD_ACCESS_README
+%%PORTDOCS%%%%DOCSDIR%%/SMTPD_ACCESS_README.html
%%PORTDOCS%%%%DOCSDIR%%/SMTPD_POLICY_README
+%%PORTDOCS%%%%DOCSDIR%%/SMTPD_POLICY_README.html
%%PORTDOCS%%%%DOCSDIR%%/SMTPD_PROXY_README
+%%PORTDOCS%%%%DOCSDIR%%/SMTPD_PROXY_README.html
+%%PORTDOCS%%%%DOCSDIR%%/STANDARD_CONFIGURATION_README
+%%PORTDOCS%%%%DOCSDIR%%/STANDARD_CONFIGURATION_README.html
+%%PORTDOCS%%%%DOCSDIR%%/TUNING_README
+%%PORTDOCS%%%%DOCSDIR%%/TUNING_README.html
%%PORTDOCS%%%%DOCSDIR%%/ULTRIX_README
+%%PORTDOCS%%%%DOCSDIR%%/ULTRIX_README.html
%%PORTDOCS%%%%DOCSDIR%%/UUCP_README
+%%PORTDOCS%%%%DOCSDIR%%/UUCP_README.html
%%PORTDOCS%%%%DOCSDIR%%/VERP_README
+%%PORTDOCS%%%%DOCSDIR%%/VERP_README.html
%%PORTDOCS%%%%DOCSDIR%%/VIRTUAL_README
+%%PORTDOCS%%%%DOCSDIR%%/VIRTUAL_README.html
%%PORTDOCS%%%%DOCSDIR%%/XCLIENT_README
+%%PORTDOCS%%%%DOCSDIR%%/XCLIENT_README.html
%%PORTDOCS%%%%DOCSDIR%%/XFORWARD_README
+%%PORTDOCS%%%%DOCSDIR%%/XFORWARD_README.html
%%PORTDOCS%%%%DOCSDIR%%/access.5.html
%%PORTDOCS%%%%DOCSDIR%%/aliases.5.html
%%PORTDOCS%%%%DOCSDIR%%/anvil.8.html
-%%PORTDOCS%%%%DOCSDIR%%/architecture.html
-%%PORTDOCS%%%%DOCSDIR%%/backstage.html
-%%PORTDOCS%%%%DOCSDIR%%/basic.html
-%%PORTDOCS%%%%DOCSDIR%%/big-picture.gif
-%%PORTDOCS%%%%DOCSDIR%%/big-picture.html
%%PORTDOCS%%%%DOCSDIR%%/body_checks.5.html
%%PORTDOCS%%%%DOCSDIR%%/bounce.8.html
%%PORTDOCS%%%%DOCSDIR%%/canonical.5.html
%%PORTDOCS%%%%DOCSDIR%%/cidr_table.5.html
%%PORTDOCS%%%%DOCSDIR%%/cleanup.8.html
-%%PORTDOCS%%%%DOCSDIR%%/commands.html
%%PORTDOCS%%%%DOCSDIR%%/defer.8.html
-%%PORTDOCS%%%%DOCSDIR%%/delivering.html
%%PORTDOCS%%%%DOCSDIR%%/error.8.html
-%%PORTDOCS%%%%DOCSDIR%%/faq.html
%%PORTDOCS%%%%DOCSDIR%%/flush.8.html
-%%PORTDOCS%%%%DOCSDIR%%/goals.html
%%PORTDOCS%%%%DOCSDIR%%/header_checks.5.html
-%%PORTDOCS%%%%DOCSDIR%%/inbound.gif
%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ldap_table.5.html
%%PORTDOCS%%%%DOCSDIR%%/lmtp.8.html
%%PORTDOCS%%%%DOCSDIR%%/local.8.html
%%PORTDOCS%%%%DOCSDIR%%/mailq.1.html
%%PORTDOCS%%%%DOCSDIR%%/master.8.html
-%%PORTDOCS%%%%DOCSDIR%%/motivation.html
+%%PORTDOCS%%%%DOCSDIR%%/mysql_table.5.html
%%PORTDOCS%%%%DOCSDIR%%/newaliases.1.html
%%PORTDOCS%%%%DOCSDIR%%/oqmgr.8.html
-%%PORTDOCS%%%%DOCSDIR%%/outbound.gif
%%PORTDOCS%%%%DOCSDIR%%/pcre_table.5.html
+%%PORTDOCS%%%%DOCSDIR%%/pgsql_table.5.html
%%PORTDOCS%%%%DOCSDIR%%/pickup.8.html
%%PORTDOCS%%%%DOCSDIR%%/pipe.8.html
%%PORTDOCS%%%%DOCSDIR%%/postalias.1.html
%%PORTDOCS%%%%DOCSDIR%%/postcat.1.html
%%PORTDOCS%%%%DOCSDIR%%/postconf.1.html
+%%PORTDOCS%%%%DOCSDIR%%/postconf.5.html
%%PORTDOCS%%%%DOCSDIR%%/postdrop.1.html
+%%PORTDOCS%%%%DOCSDIR%%/postfix-logo.jpg
+%%PORTDOCS%%%%DOCSDIR%%/postfix-power.png
%%PORTDOCS%%%%DOCSDIR%%/postfix.1.html
%%PORTDOCS%%%%DOCSDIR%%/postkick.1.html
%%PORTDOCS%%%%DOCSDIR%%/postlock.1.html
@@ -166,18 +189,16 @@ bin/mailq
%%PORTDOCS%%%%DOCSDIR%%/postsuper.1.html
%%PORTDOCS%%%%DOCSDIR%%/proxymap.8.html
%%PORTDOCS%%%%DOCSDIR%%/qmgr.8.html
+%%PORTDOCS%%%%DOCSDIR%%/qmqp-sink.1.html
+%%PORTDOCS%%%%DOCSDIR%%/qmqp-source.1.html
%%PORTDOCS%%%%DOCSDIR%%/qmqpd.8.html
-%%PORTDOCS%%%%DOCSDIR%%/queuing.html
-%%PORTDOCS%%%%DOCSDIR%%/rate.html
-%%PORTDOCS%%%%DOCSDIR%%/receiving.html
+%%PORTDOCS%%%%DOCSDIR%%/qshape.1.html
%%PORTDOCS%%%%DOCSDIR%%/regexp_table.5.html
%%PORTDOCS%%%%DOCSDIR%%/relocated.5.html
-%%PORTDOCS%%%%DOCSDIR%%/resource.html
-%%PORTDOCS%%%%DOCSDIR%%/rewrite.html
-%%PORTDOCS%%%%DOCSDIR%%/security.html
%%PORTDOCS%%%%DOCSDIR%%/sendmail.1.html
%%PORTDOCS%%%%DOCSDIR%%/showq.8.html
-%%PORTDOCS%%%%DOCSDIR%%/small-picture.gif
+%%PORTDOCS%%%%DOCSDIR%%/smtp-sink.1.html
+%%PORTDOCS%%%%DOCSDIR%%/smtp-source.1.html
%%PORTDOCS%%%%DOCSDIR%%/smtp.8.html
%%PORTDOCS%%%%DOCSDIR%%/smtpd.8.html
%%PORTDOCS%%%%DOCSDIR%%/spawn.8.html
@@ -185,7 +206,6 @@ bin/mailq
%%PORTDOCS%%%%DOCSDIR%%/trace.8.html
%%PORTDOCS%%%%DOCSDIR%%/transport.5.html
%%PORTDOCS%%%%DOCSDIR%%/trivial-rewrite.8.html
-%%PORTDOCS%%%%DOCSDIR%%/uce.html
%%PORTDOCS%%%%DOCSDIR%%/verify.8.html
%%PORTDOCS%%%%DOCSDIR%%/virtual.5.html
%%PORTDOCS%%%%DOCSDIR%%/virtual.8.html
diff --git a/mail/postfix-current/scripts/configure.postfix b/mail/postfix-current/scripts/configure.postfix
index ba8aae46b62a..8e2e74cd1d12 100644
--- a/mail/postfix-current/scripts/configure.postfix
+++ b/mail/postfix-current/scripts/configure.postfix
@@ -23,9 +23,9 @@ NOPCRE "DISABLE Perl Compatible Regular Expressions" "$status_NOPCRE" \
SASL "Cyrus SASLv1 (Simple Authentication and Security Layer)" "$status_SASL" \
SASL2 "Cyrus SASLv2 (Simple Authentication and Security Layer)" "$status_SASL2" \
SASLKRB "If your SASL requires Kerberos select this option" "$status_SASLKRB" \
-TLS "SSL and TLS" "$status_TLS" \
-IPv6 "IPv6 support" "$status_IPv6" \
-IPv6TLS "IPv6 support with SSL and TLS" "$status_IPv6TLS" \
+TLS "SSL and TLS (BROKEN)" "$status_TLS" \
+IPv6 "IPv6 support (BROKEN)" "$status_IPv6" \
+IPv6TLS "IPv6 support with SSL and TLS (BROKEN)" "$status_IPv6TLS" \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" "$status_DB3" \
DB40 "Berkeley DB4.0 (required if SASL also built with DB4.0)" "$status_DB40" \
DB41 "Berkeley DB4.1 (required if SASL also built with DB4.1)" "$status_DB41" \
@@ -107,8 +107,8 @@ while [ "$1" ]; do
echo "USE_OPENSSL= yes"
echo "POSTFIX_CCARGS+= -DHAS_SSL -I\${OPENSSLINC}"
echo "POSTFIX_AUXLIBS+= -L\${OPENSSLLIB} -lssl -lcrypto"
- echo "DISTFILES+= \${DISTNAME}.tar.gz pfixtls-0.8.18-2.0.18-20040205-0.9.7c.tar.gz"
- echo "EXTRA_PATCHES+= \${WRKDIR}/pfixtls-0.8.18-2.0.18-20040205-0.9.7c/pfixtls.diff"
+ echo "DISTFILES+= \${DISTNAME}.tar.gz pfixtls-0.8.18-2.1.0-0.9.7d.tar.gz"
+ echo "EXTRA_PATCHES+= \${WRKDIR}/pfixtls-0.8.18-2.1.0-0.9.7d/pfixtls.diff"
echo "PATCH_STRIP= -p1"
echo "TLS_SUFFIX= +tls"
SUB_TLS=""
@@ -183,7 +183,8 @@ while [ "$1" ]; do
echo "OPENLDAP_SUFFIX= +openldap"
;;
Test)
- echo "BIN1= smtp-sink smtp-source"
+ echo "BIN1= smtp-sink smtp-source qmqp-source"
+# echo "MAN1+= smtp-sink.1 smtp-source.1 qmqp-sink.1 qmqp-source.1"
SUB_TEST=""
;;
IPv6)
@@ -193,7 +194,7 @@ while [ "$1" ]; do
exit 1
fi
echo "PATCH_SITES+= http://www.ipnet6.org/postfix/download/"
- echo "PATCHFILES+= ipv6-1.21a-pf-2.0.18-20040209.patch.gz"
+ echo "PATCHFILES+= ipv6-1.23-pf-2.1.0.patch.gz"
echo "PATCH_DIST_STRIP= -p1"
echo "IPv6_SUFFIX= +ipv6"
echo ""
@@ -211,7 +212,7 @@ while [ "$1" ]; do
echo "POSTFIX_CCARGS+= -DHAS_SSL -I\${OPENSSLINC}"
echo "POSTFIX_AUXLIBS+= -L\${OPENSSLLIB} -lssl -lcrypto"
echo "PATCH_SITES+= http://www.ipnet6.org/postfix/download/"
- echo "PATCHFILES+= tls+ipv6-1.21a-pf-2.0.18-20040209.patch.gz"
+ echo "PATCHFILES+= tls+ipv6-1.23-pf-2.1.0.patch.gz"
echo "PATCH_DIST_STRIP= -p1"
echo "TLS_SUFFIX= +tls+ipv6"
SUB_TLS=""