aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authornsayer <nsayer@FreeBSD.org>2001-04-05 05:45:52 +0800
committernsayer <nsayer@FreeBSD.org>2001-04-05 05:45:52 +0800
commitf892ee363072833ec9da1cd93508c4f49bafaf75 (patch)
tree5dd0fd92b403c2cbc469464fe05fc2b01d1f0c34 /mail
parenta51075d674d079a5c634834cfacaf9950734535d (diff)
downloadfreebsd-ports-gnome-f892ee363072833ec9da1cd93508c4f49bafaf75.tar.gz
freebsd-ports-gnome-f892ee363072833ec9da1cd93508c4f49bafaf75.tar.zst
freebsd-ports-gnome-f892ee363072833ec9da1cd93508c4f49bafaf75.zip
Mega commit for cclient based port SSL
1. Update cclient and imap-uw to latest code from uwash. 2. Enable building cclient with SSL turned on. Warn folks that subordinate ports will need SSL libraries added in case we missed any. 3. Enable building imap-uw with SSL support. 4. Add WITH_SSL for pine so that it adds the crypto link options. 5. Finally de-orbit pine4-ssl port. Submitted by: anders@fix.no Maintainer timeout: petef@databits.net
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/imap-uw/Makefile38
-rw-r--r--mail/imap-uw/distinfo2
-rw-r--r--mail/imap-uw/pkg-message9
4 files changed, 38 insertions, 12 deletions
diff --git a/mail/Makefile b/mail/Makefile
index ca3dc3448b41..e7495122c3f8 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -110,7 +110,6 @@
SUBDIR += pgp4pine
SUBDIR += pgpsendmail
SUBDIR += pine4
- SUBDIR += pine4-ssl
SUBDIR += pmail
SUBDIR += pop3gwd
SUBDIR += pop3lite
diff --git a/mail/imap-uw/Makefile b/mail/imap-uw/Makefile
index 8135a1dc42eb..d18e3e59ce66 100644
--- a/mail/imap-uw/Makefile
+++ b/mail/imap-uw/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= imap
-PORTVERSION= 2000c
+PORTVERSION= 0104031813
CATEGORIES= mail
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
ftp://ftp.funet.fi/pub/mirrors/ftp.cac.washington.edu/mail/%SUBDIR%/ \
@@ -14,8 +14,8 @@ MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
ftp://ftp.uni-halle.de/pub/mail/pine/%SUBDIR%/
MASTER_SITE_SUBDIR= . old
PKGNAMESUFFIX= -uw
-DISTFILES= ${DISTNAME}.tar.Z \
- imap-utils.tar.Z
+DISTNAME= imap-2001.BETA.SNAP-${PORTVERSION}
+DISTFILES= ${DISTNAME}.tar.Z imap-utils.tar.Z
MAINTAINER= petef@databits.net
@@ -23,9 +23,16 @@ LIB_DEPENDS= c-client4.8:${PORTSDIR}/mail/cclient
.if defined(WITH_DRAC)
BUILD_DEPENDS= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
.endif
+.if defined(WITH_SSL)
+USE_OPENSSL= yes
+.endif
MAN8= ipopd.8 imapd.8
+.if defined(WITH_SSL)
+ALL_TARGET= bsf SSLTYPE=unix
+.else
ALL_TARGET= bsf
+.endif
.include <bsd.port.pre.mk>
@@ -49,8 +56,9 @@ do-install:
${INSTALL_MAN} \
${WRKSRC}/src/ipopd/ipopd.8c ${PREFIX}/man/man8/ipopd.8
-.if defined(WITH_DRAC)
post-install:
+ @${CAT} ${PKGMESSAGE}
+.if defined(WITH_DRAC)
@${ECHO} "================================================================================"
@${ECHO} "To have DRAC working, you must create ${PREFIX}/etc/dracd.host, containing"
@${ECHO} "the hostname of the DRAC server:"
@@ -58,8 +66,26 @@ post-install:
@${ECHO} "localhost"
@${ECHO} "================================================================================"
.endif
+.if defined(WITH_SSL)
+ @${ECHO} "To create and install a new SSL certificate for imapd and ipop3d, type \"make"
+ @${ECHO} "cert\"."
+ @${ECHO}
+ @${ECHO} "Example inetd config for the SSL services:"
+ @${ECHO}
+ @${ECHO} "pop3s stream tcp nowait root /usr/local/libexec/ipop3d ipop3d"
+ @${ECHO} "imaps stream tcp nowait root /usr/local/libexec/imapd imapd"
+ @${ECHO}
+ @${ECHO} "Remember to recompile and reinstall your cclient port with SSL support too, if"
+ @${ECHO} "you had it installed without SSL support."
+ @${ECHO}
+ @${ECHO} "================================================================================"
+.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
+cert:
+ @${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/certs
+ @openssl req -new -x509 -days 365 -nodes -config ${FILESDIR}/imap-uw.cnf -out ${PREFIX}/certs/imapd.pem -keyout ${PREFIX}/certs/imapd.pem
+ @openssl x509 -subject -dates -fingerprint -noout -in ${PREFIX}/certs/imapd.pem
+ @${CHMOD} 700 ${PREFIX}/certs/imapd.pem
+ @${LN} -s ${PREFIX}/certs/imapd.pem ${PREFIX}/certs/ipop3d.pem
.include <bsd.port.post.mk>
diff --git a/mail/imap-uw/distinfo b/mail/imap-uw/distinfo
index 3437048116be..e60e98d340ba 100644
--- a/mail/imap-uw/distinfo
+++ b/mail/imap-uw/distinfo
@@ -1,2 +1,2 @@
-MD5 (imap-2000c.tar.Z) = 90bdc0670812234a0589286798575980
+MD5 (imap-2001.BETA.SNAP-0104031813.tar.Z) = 327a8494019c07880072a855eb24060f
MD5 (imap-utils.tar.Z) = a6453029f201b32e9ed761e662c47b0f
diff --git a/mail/imap-uw/pkg-message b/mail/imap-uw/pkg-message
index a2687d0f55da..ab37cbb21a5a 100644
--- a/mail/imap-uw/pkg-message
+++ b/mail/imap-uw/pkg-message
@@ -5,10 +5,11 @@ pop2 stream tcp nowait root /usr/local/libexec/ipop2d ipop2d
pop3 stream tcp nowait root /usr/local/libexec/ipop3d ipop3d
imap4 stream tcp nowait root /usr/local/libexec/imapd imapd
-If PAM authentication support has been compiled in you may need to add the
-following lines to /etc/pam.conf:
+If PAM authentication support has been compiled in you may need to add
+something like the following lines to /etc/pam.conf (PAM authentication is
+default):
imap auth required pam_unix.so try_first_pass
imap account required pam_unix.so try_first_pass
-pop auth required pam_unix.so try_first_pass
-pop account required pam_unix.so try_first_pass
+pop3 auth required pam_unix.so try_first_pass
+pop3 account required pam_unix.so try_first_pass