aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authornbm <nbm@FreeBSD.org>2003-01-10 01:24:37 +0800
committernbm <nbm@FreeBSD.org>2003-01-10 01:24:37 +0800
commit05952574073e56b05a5114ce5923df575c4de42c (patch)
tree98da9d3381ab3d9b5ca6b2df11b6bc98025335d1 /mail
parentb87e2cf2c0f76ee9319956a957e63d45c8ce98c3 (diff)
downloadfreebsd-ports-gnome-05952574073e56b05a5114ce5923df575c4de42c.tar.gz
freebsd-ports-gnome-05952574073e56b05a5114ce5923df575c4de42c.tar.zst
freebsd-ports-gnome-05952574073e56b05a5114ce5923df575c4de42c.zip
Update mail/courier-imap to 1.6.1
PR: 45762 Submitted by: Sergei Kolobov <sergei@kolobov.com>>
Diffstat (limited to 'mail')
-rw-r--r--mail/courier-imap/Makefile80
-rw-r--r--mail/courier-imap/distinfo2
2 files changed, 41 insertions, 41 deletions
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index 37225ae56b43..7a6c14effb87 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= courier-imap
-PORTVERSION= 1.5.3
-PORTREVISION= 0
+PORTVERSION= 1.6.1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= courier
MAINTAINER= nbm@FreeBSD.org
+USE_BZIP2= yes
USE_REINPLACE= yes
USE_PERL5= yes
GNU_CONFIGURE= YES
@@ -24,6 +24,7 @@ USE_GMAKE= YES
#
# WITHOUT_OPENSSL: Don't build in TLS support
# WITHOUT_PAM: Don't build in PAM support
+# WITH_CRAM: Build in CRAM-MD5 authentication support
# WITH_VPOPMAIL: Build in vpopmail support
# WITH_MYSQL: Build in mysql support
# WITH_POSTGRESQL: Build in postgresql support
@@ -31,6 +32,13 @@ USE_GMAKE= YES
# WITH_LDAP1: Build in ldap support with openldap 1.x
#
+CONFDIR?= ${PREFIX}/etc/${PORTNAME}
+RCDIR?= ${PREFIX}/etc/rc.d
+USERDB?= ${PREFIX}/etc/userdb
+LIBEXECDIR?= ${PREFIX}/libexec/${PORTNAME}
+
+VPOPMAILDIR?= ${LOCALBASE}/vpopmail
+
.if !defined(WITHOUT_OPENSSL)
USE_OPENSSL= YES
PLIST_SUB= OPENSSLFLAG=
@@ -38,32 +46,28 @@ PLIST_SUB= OPENSSLFLAG=
PLIST_SUB= OPENSSLFLAG="@comment "
.endif
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --without-authshadow \
- --sysconfdir=${PREFIX}/etc/courier-imap \
- --with-userdb=${PREFIX}/etc/userdb \
- --datadir=${PREFIX}/share/courier-imap \
- --libexecdir=${PREFIX}/libexec/courier-imap \
+ --sysconfdir=${CONFDIR} \
+ --with-userdb=${USERDB} \
+ --datadir=${DATADIR} \
+ --libexecdir=${LIBEXECDIR} \
--enable-workarounds-for-imap-client-bugs \
--enable-unicode \
--disable-root-check
-VPOPMAILDIR?= ${LOCALBASE}/vpopmail
.if !defined(WITH_VPOPMAIL)
-CONFIGURE_ARGS+= \
- --without-authvchkpw
+CONFIGURE_ARGS+= --without-authvchkpw
.else
-CONFIGURE_ARGS+= \
- --with-authvchkpw
+CONFIGURE_ARGS+= --with-authvchkpw
BUILD_DEPENDS+= ${VPOPMAILDIR}/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
.endif
.if !defined(WITH_LDAP) && !defined(WITH_LDAP1)
-CONFIGURE_ARGS+= \
- --without-authldap
+CONFIGURE_ARGS+= --without-authldap
PLIST_SUB+= LDAPFLAG="@comment "
.else
-CONFIGURE_ARGS+= \
- --with-authldap
+CONFIGURE_ARGS+= --with-authldap
PLIST_SUB+= LDAPFLAG=""
.if defined(WITH_LDAP)
@@ -76,8 +80,7 @@ LIB_DEPENDS= ldap.1:${PORTSDIR}/net/openldap \
.endif
.if !defined(WITH_MYSQL)
-CONFIGURE_ARGS+= \
- --without-authmysql
+CONFIGURE_ARGS+= --without-authmysql
PLIST_SUB+= MYSQLFLAG="@comment "
.else
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
@@ -85,8 +88,7 @@ PLIST_SUB+= MYSQLFLAG=""
.endif
.if !defined(WITH_POSTGRESQL)
-CONFIGURE_ARGS+= \
- --without-authpgsql
+CONFIGURE_ARGS+= --without-authpgsql
PLIST_SUB+= PGSQLFLAG="@comment "
.else
LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
@@ -94,19 +96,15 @@ PLIST_SUB+= PGSQLFLAG=""
.endif
.if !defined(WITHOUT_PAM)
-CONFIGURE_ARGS+= \
- --with-authpam
+CONFIGURE_ARGS+= --with-authpam
.else
-CONFIGURE_ARGS+= \
- --without-authpam
+CONFIGURE_ARGS+= --without-authpam
.endif
.if !defined(WITH_CRAM)
-CONFIGURE_ARGS+= \
- --without-authcram
+CONFIGURE_ARGS+= --without-authcram
.else
-CONFIGURE_ARGS+= \
- --with-authcram
+CONFIGURE_ARGS+= --with-authcram
.endif
MAN1= couriertcpd.1 maildirmake.1
@@ -137,20 +135,22 @@ post-patch:
${WRKSRC}/Makefile.in
post-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/authlib/authtest ${PREFIX}/bin/
- @${MKDIR} ${PREFIX}/share/doc/courier-imap
- @${INSTALL_DATA} ${WRKSRC}/imap/imapd.cnf ${PREFIX}/etc/courier-imap/imapd.cnf.dist
- @${INSTALL_DATA} ${WRKSRC}/imap/pop3d.cnf ${PREFIX}/etc/courier-imap/pop3d.cnf.dist
+ ${INSTALL_PROGRAM} ${WRKSRC}/authlib/authtest ${PREFIX}/bin/
+.for i in imapd pop3d
+ ${INSTALL_DATA} ${WRKSRC}/imap/${i}.cnf ${CONFDIR}/${i}.cnf.dist
+ ${LN} -s ${LIBEXECDIR}/${i}.rc ${RCDIR}/${PORTNAME}-${i}.sh.sample
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
.for a in ${EXTRA_DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${a} ${PREFIX}/share/doc/courier-imap/
+ ${INSTALL_DATA} ${WRKSRC}/${a} ${DOCSDIR}
.endfor
- ln -s ${PREFIX}/libexec/courier-imap/imapd.rc ${PREFIX}/etc/rc.d/courier-imap-imapd.sh.sample
- ln -s ${PREFIX}/libexec/courier-imap/pop3d.rc ${PREFIX}/etc/rc.d/courier-imap-pop3d.sh.sample
- @echo ""
- @echo "You will have to run ${PREFIX}/share/courier-imap/mkimapdcert to create"
- @echo "a self-signed certificate if you want to use imapd-ssl."
- @echo "And you will have to copy and edit the *.dist files to * in"
- @echo "${PREFIX}/etc/courier-imap ."
- @echo ""
+.endif
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You will have to run ${DATADIR}/mkimapdcert to create"
+ @${ECHO_MSG} "a self-signed certificate if you want to use imapd-ssl."
+ @${ECHO_MSG} "And you will have to copy and edit the *.dist files to *"
+ @${ECHO_MSG} "in ${CONFDIR}."
+ @${ECHO_MSG} ""
.include <bsd.port.post.mk>
diff --git a/mail/courier-imap/distinfo b/mail/courier-imap/distinfo
index fc315344b736..e61f07adb927 100644
--- a/mail/courier-imap/distinfo
+++ b/mail/courier-imap/distinfo
@@ -1 +1 @@
-MD5 (courier-imap-1.5.3.tar.gz) = 132c2405e3857b3fa2a6369d77e19fd9
+MD5 (courier-imap-1.6.1.tar.bz2) = 313a1b1c7a6813c81f543b524f4f2a3d