aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2012-02-05 18:28:24 +0800
committerlwhsu <lwhsu@FreeBSD.org>2012-02-05 18:28:24 +0800
commitee184d22897f3f8e5feb78c8fde9c0f697cfbf58 (patch)
tree37491b8e5d4d560ca4cee0cf2d8dd3dbb8101d51 /mail
parent9425fd57a68719e9936577372ca1d23d67da3cb5 (diff)
downloadfreebsd-ports-gnome-ee184d22897f3f8e5feb78c8fde9c0f697cfbf58.tar.gz
freebsd-ports-gnome-ee184d22897f3f8e5feb78c8fde9c0f697cfbf58.tar.zst
freebsd-ports-gnome-ee184d22897f3f8e5feb78c8fde9c0f697cfbf58.zip
- Update to 5.2.1
- Add LICENSE PR: ports/164771 Submitted by: Joe Horn <joehorn@gmail.com> (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/phpmailer/Makefile22
-rw-r--r--mail/phpmailer/distinfo4
-rw-r--r--mail/phpmailer/pkg-plist65
3 files changed, 80 insertions, 11 deletions
diff --git a/mail/phpmailer/Makefile b/mail/phpmailer/Makefile
index 2262f22e453f..13580899e026 100644
--- a/mail/phpmailer/Makefile
+++ b/mail/phpmailer/Makefile
@@ -6,16 +6,19 @@
#
PORTNAME= phpmailer
-PORTVERSION= 5.1
+PORTVERSION= 5.2.1
CATEGORIES= mail
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20for%20php5_6/PHPMailer%20v${PORTVERSION}
-DISTNAME= PHPMailer_v${DISTVERSION}
+MASTER_SITES= http://${PORTNAME}.apache-extras.org.codespot.com/files/
+DISTNAME= PHPMailer_${PORTVERSION}
MAINTAINER= joehorn@gmail.com
COMMENT= Full Featured Email Transfer Class for PHP
+LICENSE= LGPL3
+
WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_ZIP= yes
USE_DOS2UNIX= yes
NO_BUILD= yes
IGNORE_WITH_PHP= 4
@@ -28,17 +31,20 @@ do-install:
.for f in class.phpmailer.php class.pop3.php class.smtp.php
@${INSTALL_DATA} ${WRKSRC}/$f ${DATADIR}
.endfor
- @${MKDIR} ${DATADIR}/language
- @${INSTALL_DATA} ${WRKSRC}/language/* ${DATADIR}/language
- @${MKDIR} ${DATADIR}/test
- @${INSTALL_DATA} ${WRKSRC}/test/* ${DATADIR}/test
+.for d in extras language test
+ @${MKDIR} ${DATADIR}/$d
+ @${INSTALL_DATA} ${WRKSRC}/$d/* ${DATADIR}/$d
+.endfor
+ @${CP} -R ${WRKSRC}/test_script ${DATADIR}
+
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for f in aboutus.html changelog.txt README LICENSE
+.for f in changelog.txt README LICENSE
@${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
.endfor
@${CP} -R ${WRKSRC}/docs/* ${DOCSDIR}
.endif
+
.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
@${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
diff --git a/mail/phpmailer/distinfo b/mail/phpmailer/distinfo
index 373330c4a3a4..10588559110c 100644
--- a/mail/phpmailer/distinfo
+++ b/mail/phpmailer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PHPMailer_v5.1.tar.gz) = f64b366c760d625133010ef94f30e71a4f5101ae980a733bdba2d67350f00a11
-SIZE (PHPMailer_v5.1.tar.gz) = 84081
+SHA256 (PHPMailer_5.2.1.zip) = 812f8d26013b1a319ac65977eed32da484a60769b2fe395259edd7d3f33c85da
+SIZE (PHPMailer_5.2.1.zip) = 254840
diff --git a/mail/phpmailer/pkg-plist b/mail/phpmailer/pkg-plist
index 2322b2850538..8d277b183584 100644
--- a/mail/phpmailer/pkg-plist
+++ b/mail/phpmailer/pkg-plist
@@ -1,9 +1,15 @@
+%%PORTDOCS%%%%DOCSDIR%%/5.0-phpdocs/blank.html
+%%PORTDOCS%%%%DOCSDIR%%/5.0-phpdocs/classtrees_PHPMailer.html
+%%PORTDOCS%%%%DOCSDIR%%/5.0-phpdocs/elementindex.html
+%%PORTDOCS%%%%DOCSDIR%%/5.0-phpdocs/elementindex_PHPMailer.html
+%%PORTDOCS%%%%DOCSDIR%%/5.0-phpdocs/index.html
+%%PORTDOCS%%%%DOCSDIR%%/5.0-phpdocs/li_PHPMailer.html
+%%PORTDOCS%%%%DOCSDIR%%/5.0-phpdocs/packages.html
%%PORTDOCS%%%%DOCSDIR%%/Callback_function_notes.txt
%%PORTDOCS%%%%DOCSDIR%%/DomainKeys_notes.txt
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/Note_for_SMTP_debugging.txt
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/aboutus.html
%%PORTDOCS%%%%DOCSDIR%%/changelog.txt
%%PORTDOCS%%%%DOCSDIR%%/extending.html
%%PORTDOCS%%%%DOCSDIR%%/faq.html
@@ -29,6 +35,7 @@
%%DATADIR%%/class.phpmailer.php
%%DATADIR%%/class.pop3.php
%%DATADIR%%/class.smtp.php
+%%DATADIR%%/extras/htmlfilter.php
%%DATADIR%%/language/phpmailer.lang-ar.php
%%DATADIR%%/language/phpmailer.lang-br.php
%%DATADIR%%/language/phpmailer.lang-ca.php
@@ -58,9 +65,65 @@
%%DATADIR%%/test/test.png
%%DATADIR%%/test/test_callback.php
%%DATADIR%%/test/testemail.php
+%%DATADIR%%/test_script/LGPLv3.txt
+%%DATADIR%%/test_script/contents.html
+%%DATADIR%%/test_script/images/aikido.gif
+%%DATADIR%%/test_script/images/bkgrnd.gif
+%%DATADIR%%/test_script/images/phpmailer.gif
+%%DATADIR%%/test_script/index.php
+%%DATADIR%%/test_script/scripts/clipboard.swf
+%%DATADIR%%/test_script/scripts/shBrushBash.js
+%%DATADIR%%/test_script/scripts/shBrushCSharp.js
+%%DATADIR%%/test_script/scripts/shBrushCpp.js
+%%DATADIR%%/test_script/scripts/shBrushCss.js
+%%DATADIR%%/test_script/scripts/shBrushDelphi.js
+%%DATADIR%%/test_script/scripts/shBrushDiff.js
+%%DATADIR%%/test_script/scripts/shBrushGroovy.js
+%%DATADIR%%/test_script/scripts/shBrushJScript.js
+%%DATADIR%%/test_script/scripts/shBrushJava.js
+%%DATADIR%%/test_script/scripts/shBrushPerl.js
+%%DATADIR%%/test_script/scripts/shBrushPhp.js
+%%DATADIR%%/test_script/scripts/shBrushPlain.js
+%%DATADIR%%/test_script/scripts/shBrushPython.js
+%%DATADIR%%/test_script/scripts/shBrushRuby.js
+%%DATADIR%%/test_script/scripts/shBrushScala.js
+%%DATADIR%%/test_script/scripts/shBrushSql.js
+%%DATADIR%%/test_script/scripts/shBrushVb.js
+%%DATADIR%%/test_script/scripts/shBrushXml.js
+%%DATADIR%%/test_script/scripts/shCore.js
+%%DATADIR%%/test_script/scripts/shLegacy.js
+%%DATADIR%%/test_script/src/shCore.js
+%%DATADIR%%/test_script/src/shLegacy.js
+%%DATADIR%%/test_script/styles/help.png
+%%DATADIR%%/test_script/styles/magnifier.png
+%%DATADIR%%/test_script/styles/page_white_code.png
+%%DATADIR%%/test_script/styles/page_white_copy.png
+%%DATADIR%%/test_script/styles/printer.png
+%%DATADIR%%/test_script/styles/shCore.css
+%%DATADIR%%/test_script/styles/shThemeDefault.css
+%%DATADIR%%/test_script/styles/shThemeDjango.css
+%%DATADIR%%/test_script/styles/shThemeEmacs.css
+%%DATADIR%%/test_script/styles/shThemeFadeToGrey.css
+%%DATADIR%%/test_script/styles/shThemeMidnight.css
+%%DATADIR%%/test_script/styles/shThemeRDark.css
+%%DATADIR%%/test_script/styles/wrapping.png
+%%DATADIR%%/test_script/test.html
+@dirrm %%DATADIR%%/test_script/styles
+@dirrm %%DATADIR%%/test_script/src
+@dirrm %%DATADIR%%/test_script/scripts
+@dirrm %%DATADIR%%/test_script/images
+@dirrm %%DATADIR%%/test_script
@dirrm %%DATADIR%%/test
@dirrm %%DATADIR%%/language
+@dirrm %%DATADIR%%/extras
@dirrm %%DATADIR%%
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/images
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/5.0-phpdocs/media
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/5.0-phpdocs/__filesource
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/5.0-phpdocs/PHPMailer
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/5.0-phpdocs
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@exec mkdir -p %D/%%DOCSDIR%%/5.0-phpdocs/media
+%%PORTDOCS%%@exec mkdir -p %D/%%DOCSDIR%%/5.0-phpdocs/__filesource
+%%PORTDOCS%%@exec mkdir -p %D/%%DOCSDIR%%/5.0-phpdocs/PHPMailer